Install FTB Infinity 1.7 server for noobs

Hi all,

I rented a server from Kimsufi nearly a month ago with a view to installing FTB Infinity 1.7 on there through MineOS.

After what has been hours of installing, re-installing, researching and trying, as my first month of renting the server comes to an end, my efforts so far have been in vain to get the server up and running. I just cannot get it to start. It’s probably something really small and easy to fix I’m missing that is obvious to someone with even a basic grasp of Linux that I just cannot see! I think it’s around the commands involved in the second link below re the separate install process needed on new FTB server packs.

I have had no problems previously installing vanilla or FTB servers on Kimsufi-MineOS before although admittedly, this is the first attempt since FTB Monster way back when.

Although my knowledge of commands within the Linux environment is appalling, I have had no problem in doing the necessary through tutorials previously.

Seeking help for what is, to most of you, such a noob question, is the final step for me before giving up. I have done my best to research and troubleshoot myself but I am just coming up blank. I was not able to find any useful videos on YouTube (which is either a first, or my blindness/poor search query!) and I have exhausted the suggestions provided in the following threads:!topic/mineos/7fMtC024TL0!topic/mineos/P4vQMgLKcbw

I appreciate it is an arduous task for those that know how, but I’d love it if someone could put together a definitive, step-by-step, idiot-proof tutorial for installation of FTB Infinity 1.7.

Although I back myself to learn and carry out anything I was once previously unable, I think I’ve just about run out of patience. If someone isn’t able to help me, I may have to seek out a readymade server solution through another host :frowning:

Key info that may be of use:
OS installed on Kimsufi server: Minecraft Gameserver (Debian 7) (64bits)
MineOS webui version: 24b30ef

Any help greatly appreciated. Maybe even a very small reward in the form of a PayPal donation to a person that may have the patience to instruct the successful installation.


FTB Infinity has caused known issues before. It seems that FTB Infinity–unlike many other FTB packs–is just way more complex and far less straightforward.

Here’s a Git Issue created that called out FTB Inifinity in particular:

The biggest problem is that I actually couldn’t really get FTB Infinity working entirely without MineOS – at least not consistently. If I can’t get it to work with just a base Ubuntu install and command line, there’s no chance I can get it working through my own programming, automation and the like.

So here’s a question I’ll put back at you: are you able to get FTB Infinity working–just working–no MineOS at all?

If I can be given the steps that work to get it working, I am the person who can make it work in the webui. It’s a rather humble request, after all, since the time it takes to integrate it into MineOS is far more involving and time-consuming than just getting it to work.

Blimey… thanks for the quick response.

No, I haven’t even tried installing the server on another OS.

Well I guess that’s the answer to my question!Maybe I don’t feel so bad about getting it running now when I have previously been able to install basic servers! lol

You don’t have to install it on a different OS, you just have to see if you can get it working–ignoring the use and existence of MineOS.

No, I don’t think I have been able to. I assumed this was because I was doing something wrong.

I have a FTB infinity server running with version 1.7 (FTBServer-1.7.10-1291).

It was set up using MineOS (not node), and I’ll attest to that it waseverything other than trivial. I still shudder at (and refuse trying ) udating it. It never starts up after updates. Thats another story.

I finally managed to get it working by followng these instructions, only swapping out for infinity in stead for direwolf:

As I said, i did this with the non-node version of MineOS. For node, i think it should be enough to just skip all the Profile-steps, as node reads out any .jar files available in the server directory.

I think the relevant commands for you would be:

mkdir ftbi 
cd ftbi 
unzip ../
chmod +x

( – ignore if you are running MineOS Node:
the commands sections for profile in the instructions:
As root:

mv /home/mc/ftbi /var/games/minecraft/profiles
cp -R /var/games/minecraft/profiles/ftbi /* /var/games/minecraft/servers/(servername)/
chown -R mc:mc /var/games/minecraft/servers/(servername)

– ignore if you are running MineOS Node end)

After this you should be able to follow the directions as is on page :slight_smile:

Then again, the FTB-servers (and in particular infinity) are ficle beasts easily angered…

Thanks for your suggestion but I think I’m a bit out of my depth installing Infinity myself given the aforementioned problems. Moreover, I am now less inclined to attempt trying to fix it on the basis that, if it goes wrong, I really will have no idea how to fix it!

Although I rented and installed my own server previously, nothing ever went wrong with it that required my intervention. If it had crashed/corrupted/anything, I would have been screwed by my lack of understanding for Linux commands.

Thanks once again :smile:

My infinity server is running nicely, and the times it has crashed, a restart (or simply starting it up again) is enough to get it going again. I only had a serious crash once, and that was with an earlier version :slight_smile:

Unfortunately it’s not quite legal to share server jars between us, or I could have given you a stripped archive of my server.

(Stripped = removed world direcotry to force regeneration, removed all logg files, removed all crash reports, removed all users from whitelist, op and admin files. Just a barebone server ready for startup. Youd have to edit the to set it up the way you wanted, and add your whitelisted users, ops and such yourself)

Hi All,
I didn’t want to jump in, but I kind of had to. I followed the steps for the Node version of MineOS, fresh install - and tons of errors. Now, I know I Maybe did something off along the way, but I quite literally followed the step above line by line. First, I skipped the profile copy, and sent the files directly to the Server folder - to no avail. With the new version of MineOS, you cannot create a custom Profile, so I have to select the FTBInifity1.11.2. Now, I see tons of Java errors on startup and cannot log into the server from the client.
I just really need to be pointed in the right direction, as I’m coming from using the Tekkit Attack of the B-Team pack running on Windows with MCMyAdmin as a frontend. Pain? Yes. Working? Yes. I don’t mind the CLI, I’m just rusty with my Linux as I’ve been more involved in Windows server admin work lately.


Alright, to start off, I’m going to begin with a little griping. I need a little bit of venting frustration when I continue to hear often the same complaints about ‘profiles’ and the inability to make custom profiles. I have–without reservation–absolute confidence that there is no ways in which the custom profile system of old is more usable than the current system.

Here is what happened in the Python with profiles:

  1. user enters in the custom profile info; the custom profile info was saved to profiles.config
  2. user assigned a server to the particular profile
  3. user starts a server
  4. profile was copied from the profile directory to the live server directory

Here is what happens in the nodejs system with profiles:

  1. user downloads a profile already listed
  2. user assigned a server to the particular profile
  3. user starts a server
  4. profile was copied from the profile directory to the live server directory

Here is what happens when you instead of starting the server, just use the ‘copy profile button’:

  1. user downloads a profile already listed
  2. user assigned a server to the particular profile
  3. ‘copy profile’ pushed, copies from the profile directory to the live server directory
  4. user starts a server

I hope it is abundantly clear now that custom profiles offer no difference to how servers work in MineOS. At All. The new system simply affords an easier way that doesn’t involve copy/pasting URLs, arbitrarily naming server jarfiles and understanding what “unmanaged” servers are.

I’m not sure why you’re skipping utilities that are designed to reduce user error. The purpose of the ‘copy profile’ button is to a) allow you to stay still within the webui to make a file copy and b) ensure that permissions of the copy are 100% correct, by ensuring the correct user owns the files.

If you copy it manually (read as: doing more work than you need to), you also run the risk of permissions being incorrect. Profiles get downloaded as root:root, but when in the server directory must be mc:mc (or whichever user you’re using). The webui always makes sure it’s assigned to the user creds you used for the login, but in SSH, it could be the right user, or you might have been using sudo or been doing it as root. I don’t know–when doing things manually, assumptions about how things are getting put into place that I’ve made and coded into MineOS can’t be relied upon anymore.

So it is is not “because you cannot create a custom profile” that you should select FTBInfinity, you should be selecting FTBInfinity because “it is the more reliable, dependable way to install FTBInfinity”.

The errors you get are pretty much the only thing that would be useful in order to diagnose your problem. If you take a look, you’ll see there are LOTs of people who have problems with stock FTBInfinity who aren’t using MineOS–so they understandably are not seeing “custom profiles” as being the problem at hand. If the problem is being reported in Java, then the answer is likely to be found in Java, not “custom profiles” and skipping the “copy profile” button.

Please know, I am not trying to single you out, but I am–for my own sanity–needing to point out that how you frame your issue and request for help has a significant effect on my attitude toward this free project I maintain.

With that said and done, here is what I have just done to get FTB Infinity FTBInfinity-1.11.2 working.

  1. logged into the webui as my non-root user, will. (mc or any other name works just as well).
  2. downloaded the profile “FTBInfinity-1.11.2”
  3. created a server asdf
  4. set asdf to use the new FTB profile.
  5. hit the ‘copy profile’ button
  6. MineOS reported I needed to accept the EULA because ‘eula.txt’ was copied over. If the webui were closed, I could manually accept the EULA by hitting the “Accept EULA” button in the webui.
  7. opened up a terminal window and connected to my server as the user will
  8. ran the installation shell script
    cd /var/games/minecraft/servers/asdf
  9. Set the runnable jar to FTBServer-1.7.10-1448.jar
  10. Set Java_XMX to 2048 (it has to be higher than 1GB, as far as I’ve seen)
  11. Hit ‘start’ and the Minecraft process began.

Now here is one of the biggest issues. This profile, as it is distributed from FTB directly, is broken. It doesn’t work, and you likely saw this in the Java logs or if you try to do anything.

Again, it’s important to mention that if there is a Java error at this point, it is not because of profiles–even if you did this on a fresh install of Ubuntu with NO MineOS, you’d get this issue typing “help”.

[09:44:23] [Server thread/INFO]: An unknown error occurred while attempting to perform this command
[09:44:23] [Server thread/ERROR]: Couldn't process command: 'help'
java.lang.IllegalArgumentException: Comparison method violates its general contract!
at java.util.ComparableTimSort.mergeHi( ~[?:1.7.0_79]
at java.util.ComparableTimSort.mergeAt( ~[?:1.7.0_79]
at java.util.ComparableTimSort.mergeForceCollapse( ~[?:1.7.0_79]
at java.util.ComparableTimSort.sort( ~[?:1.7.0_79]
at java.util.ComparableTimSort.sort( ~[?:1.7.0_79]
at java.util.Arrays.sort( ~[?:1.7.0_79]
at java.util.Collections.sort( ~[?:1.7.0_79]
at net.minecraft.command.CommandHelp.func_71534_d(SourceFile:84) ~[au.class:?]
at net.minecraft.command.CommandHelp.func_71515_b(SourceFile:38) ~[au.class:?]
at net.minecraft.command.CommandHandler.func_71556_a( [z.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71333_ah( [lt.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71190_q( [lt.class:?]
at net.minecraft.server.MinecraftServer.func_71217_p( [MinecraftServer.class:?]
at [MinecraftServer.class:?]
at net.minecraft.server.MinecraftServer$ [li.class:?]

Apparently, the stock FTBInfinity ships broken. Many forum threads recommend Helpfixer, which I promptly visited.

After downloading this to /var/games/minecraft/servers/asdf/mods, I stopped the server and restarted it.

[09:57:01] [Server thread/INFO]: Done (3.227s)! For help, type "help" or "?"
[09:57:16] [Server thread/INFO]: --- Showing help page 1 of 17 (/help <page>) ---
[09:57:16] [Server thread/INFO]: /AlterRate <essentia rate> <vis rate>
[09:57:16] [Server thread/INFO]: /achievement give <stat_name> [player]
[09:57:16] [Server thread/INFO]: Commands provided by Applied Energistics 2 - use /ae2 list for a list, and /ae2 help _____ for help with a command.
[09:57:16] [Server thread/INFO]: /aroma1997 OR /aroma1997 reloadclient
[09:57:16] [Server thread/INFO]: /ban <name> [reason ...]
[09:57:16] [Server thread/INFO]: /ban-ip <address|name> [reason ...]
[09:57:16] [Server thread/INFO]: /banlist [ips|players]

Alas, FTBInfinity starts up and connects! Now, I know that it is not desirable to have to leave the webui and use command line, but apparently FTBInfinity is an outlier. Pretty much every other profile works simply through downloading it, but FTBInfinity has the special requirement to run an external shell script.

So this is how I get FTBInfinity working. It is the recommended way, the way least likely to introduce user error, and the least amount of command line.

I hope this helps.

If I were your typical forum dingus, right now would be some counter-insults and general whining about the world.

But, I get it. I made those comparisons to the ‘Custom Profile’ in response to the thread I was replying to. When I did the server completely through the WebUI, it didn’t work - in the sense that it did download, and I hit the copy to active server button, but then…nothing. So, I followed the above walkthrough, and it got farther, but the Java errors were/are everywhere.

That being said, since you MAY have been the one to write this software, I think I’ll give it a shot. For reference, this is on the latest download of the MineOS Turnkey, with nothing else done so far. I tried as the created user, and as root. I will follow your instructions now with a new deployment, and give you the update.

I do really appreciate your time Hex. And for using me as your venting board. I’m cool with it.

Thanks again,

::ehem:: So, in the console, I see no errors. As I’m at work, I’m limited to staring at that. As soon as I can tonight, after the kiddos get to bed, I’ll try a client connect and let you know.

Again, thank you Hex. This is why people like us do the things we do.

Now, about those custom profiles… heh heh


Ok - so I leave no one hanging - if there is anyone…it worked like a charm. Logged in last night from 2 clients, no issues. Well, except on one client that didn’t like Java - but that was me, not the game.

So, umm…resolved.

Thanks Hex.

Hi, when I get to the step to run the shell command I get an error that the certificates for and cannot be verified.

Any help will be appreciated,