FTB Infinity server won't allow connections

I’ve been setting up an FTB Infinity server with MineOS.

I’ve installed MineOS on an older laptop that’s connected to my LAN.

Last night my problem was that others could not connect to my server, but I could connect using the internal network IP. I know it worked because I played for a couple hours. Now this morning the server wouldn’t even stay up. It would go down after about 5 seconds. I followed this: Install FTB Infinity 1.7 server for noobs and got it “working” again. Working as in the server does not go down right away. INSTEAD, what it does is give me this error: “java.net.ConnectException: Connection refused: no further information:” and does not allow me to connect, even from within the LAN.

EDIT: And sometimes it says “Server still starting”

One point that might be relevant, I have it set to broadcast on LAN and I’ve also got a server entry in the minecraft client. Last night I could see the server pop up on both. It would get broadcast to me and it would be listed in the server browser where I added it. Now it only shows up in the lan broadcast section and where I’ve added it specifically it says “Can’t connect to server”.

So it’s a problem in two parts. First, is figure out how to get LAN clients back on the server. Second, fix the original problem which was allowing outside connections.

As for the outside connections, I have port forwarded port 25565 to the internal IP of the server. Didn’t work last night, doesn’t work now.

outside connections:

  • Do they connect with your outside IP-adress? Or you LAN-IPadress? (use http://www.myipaddress.com/show-my-ip-address/ to find your external adress)
  • Do your internet service provider allow you to host servers? Some ISP’s do not directly allow this, and blocks all ports on their end of the link. Then a simple port forward would not work, as the port is not routed to your netwrok for external queries in the first place.

Internal problems:
is your network card on the laptop set up with DHCP? Or hare you configured it with a set IP-adress? you can use the command /ifconfig in SSH to see your laptops current IP-adress. I do however think this might not be a problem, since it seems you can connect to the webui. I think this is more of an FTB-issue. The latest FTB-infiity has several errors that are cripling, so it is really not reccomended for the time being.

As for the problems with the server: Without the logs we cannot really help. We need mineos.log, latest.log and latest-ftb.log

They attempt to connect via my external IP address. I’ve not actually had a chance to get someone else to try it while internal connections were working so what I’ve done is added my own external ip address to my server browser list. Last night (When it was working internally) the internal one would show up properly, green bars, etc. But the external one would say it couldn’t connect. I can host other games just fine, both dedicated and listen servers.

Internally. WELL. It just now started working. It does have an internally static IP address, and I just checked with the command, it’s not changed.

As for getting the logs, give me a moment. I’m not SSHing into the laptop, I’ve just got it sitting beside me. Where do I find latest-ftb.log? latest.log I’ve found in the other two log files.

My fault. The correct name of the last log is (probably) fml-server-latest.log

The logs are too big for pastebin, here is a dropbox link to a rar file containing the logs.

I can’t really see anything directly wrong.

You seem to have two servers: [Calvin_Is_Pretty_Great] and [Server2].
You also seem to favour the “Kill” button instead of the “Stop” button. Killing you server is not recomended, since it do not get a chance to shut down gracefully, and it might result in server problems (like the one you had: problems starting up again).

I also see traces of one server trying to start up, but failing gracefully due to a blocked port. Do both server have the same port number (25565) ? Remember that one port number may be connected to one server only. If you want to run two minecraft server at the same timw, you need to use separate port numbers for each (25565, 25566, … and so on).

I cannot see anything in your logs that hints at anything that should stop external users connecting.

I briefly had a server 2 because I wanted to see what the default server settings looked like. Both servers did have the same port number but were never on at the same time. Either way, server 2 is gone now. If it’s not a mineOS thing though then I guess it’s a router issue which I’ll have to sort out for myself. Thanks for at least narrowing things down for me.

hi Calvin,

i did not gather @iMelsom imply it was not a MineOS thing, only he did not see issues.

looking at your logs i can see it may or may not, be a MineOS settings issue. in that yours are not correct, imho.

in the beginning, you seemed to have some error out problems starting the sever Calvin_Is_Pretty_Great that you resolved yourself because that stopped happening. fine, good job.

but then your Calvin_Is_Pretty_Great server started failing to:

Server thread/INFO: Generating keypair
[20:29:37] [Server thread/INFO]: Starting Minecraft server on
[20:29:38] [Server thread/WARN]: **** FAILED TO BIND TO PORT!
[20:29:38] [Server thread/WARN]: The exception was: java.net.BindException: Cannot assign requested address

seems crystal clear to me, Calvin_Is_Pretty_Great server can not bind to port on

apparently not happy with this result you then attempt to bind Calvin_Is_Pretty_Great to another incorrect address:

{“level”:“error”,“message”:“Cannot bind broadcaster to ip”,“timestamp”:“2016-09-06T20:11:17.066Z”}

that failed, so you swap it back to:

{“level”:“error”,“message”:“Cannot bind broadcaster to ip”,“timestamp”:“2016-09-06T20:16:05.376Z”}

then i see you created Server2 because that must be the problem and then:

{“level”:“error”,“message”:“Cannot bind broadcaster to ip”,“timestamp”:“2016-09-06T21:05:48.882Z”}

that failed so now try the first Calvin_Is_Pretty_Great server with the 3rd address:

{“level”:“error”,“message”:“Cannot bind broadcaster to ip”,“timestamp”:“2016-09-06T21:08:25.019Z”}

you know ports must be the problem so remove them only to get this error for awhile:

“level”:“error”,“message”:"uncaughtException: port should be >= 0 and < 65536: ",“timestamp”:“2016-09-06T21:08:54.212Z”}

pick a port, any port between 0 and 65536, but we don’t need no stinking ports, thanks. (bad joke time.)

so i have to ask because clearly i am missing something, why do you begin with using these wrong addresses? where did you get them from? it is clear the correct address i would have to use is, if that was my assigned address. right now my assigned is but that can change when i re-boot the main server and re-start MineOS. port 25565 is the default port to log in with a client on your internal lan.

did you ever try that address and port for your internal lan? typically it is the same address as you would use to log in to the WebUI on port 8443.

outside lan clients must come through a correctly configured modem/router and is a separate issue.

also by the way, the current commit is 8dc5529 not 37e4a9d however, this is not why your servers fail to start.

Good Luck!


Yes, I could see that, and you do have som errors in your log saying that one of your servers could not connect to it’s designated port number. If that message pops up, and you are certain there is no other servers running, you probably have a hanging port-reservation, or a hanging java-applet running (Most minecraft servers run in java applets). To kill off hanging java applett you open ssh and use killall java.If you only run one server this will kill any leftover java that stops your server. If you have several servers running besideeach other, that command will kill ALL JAVA BASED minecraft servers.

@tNt points to why you might have had problems connectiong locally for a while, but do not explain why you could connect locally and not externally.

As a rule of thumb:

  • if you can connect on your LAN but not from the internet: It’s either routerconfig, or firewallconfig.
  • if you cannot connect at all it is either firewall or minecraft server related.

99/100 times this error occurs because you’re putting the IP address in the server.properties file. Most of the time, this is unnecessary–the one time it is necessary is when the only host that responds to this IP is the server itself.

If you are home-hosting and using a router, this is the cause of the problem.

(if you are home-hosting) Your server does not have the IP address 96.x.x.x. Other clients may be able to connect using that IP address, but that is because of NAT (network address translation) and port forwarding.

Empty out the server-ip value in server.properties and try again and let us know what issue if any arises. Be sure to have a port filled in, too. Realistically, Minecraft is used at 25565 -> 25575 even if you’re technically able to use a much wider range.

It was the server properties thing, which I have already cleared up.

As for the ip, is my home computer. (And x.222 before that) is the internal ip of the server itself and is the correct one.

Once dealing with that I discovered the actual problem. My modem has it’s own routing settings (Port forwarding, etc) Until recently it was set just to pass everything through which is why I could host other games just fine. But we got a replacement recently, and it was still set to the default which did not have it set to pass through. I set it to pass through and now it’s actually forwarding the port and people can connect.