[Closed] Old world-file crashes after a very long history of messing around

Hot Mess of God Knows What

[Preface]

Ok. I have been using MineOS Turnkey for quite a number of years now. I forget how long ago it was that I made this Server/World that ill be discussing in this post.

** When I first started using the MC Server, I must have misread or not understood that I wasn’t supposed to use the root login in the web-UI. So all the servers I have ever made have been under the root user. **

I’m not sure if all this backstory is going to be helpful but I think if I explain it all it may give some context as how deep in the pile of (ahem) I actually am.
Skip to [Actual Problem] to skip ahead

[Long Story Long]

I started on this World (hereafter I will call “Server Two” as that was its’ name) years ago and I expected the build to take me very long to complete. I started Server Two mainly using the vanilla /fill command to start building and eventually upgraded to using World Edit. I’m pretty sure I used the Spigot function through the GUI (profile loader) to get it working at the time. I think I installed some other plugins for grief protection but they didn’t really matter as I was building on Server Two alone.

Later on, a couple years ago, I decided to re-install the OS on the same machine, now having more RAM added. All the file transfers worked fine (typically through Filezilla).
I played on other Worlds but Server Two was a long term project and I decided to start working on it again. With the fresh install I did update the actual world creation from 1.12.0 to 1.16.1 and it seemed to work fine… Server Two is a very thin Flatworld (3 dirt, bedrock, void) so I had maximum building space to build limit. Through all of this the system had a few hiccups but I dug deeper and found the update and reset scripts so I started using those every so often. The actual Host machine is Local in another room and has a set Dedicated IP. At this point I quit using Plugins and went back to a Vanilla server setup.

At some point I learned about the mc acct and that I shouldn’t have used the root acct. I reset the password for mc and then copied over some server files to the new acct but it wouldn’t work properly (obvious now… but I was dumb). I continued using the root acct as that’s the only way it worked.

The Other day (Nov 10th '22) I went into the server file and changed a couple things to get it ready for a couple friends to login and check out the build / help. I didn’t mess with anything important (a couple fields in server.properties, player limit, whitelist, and World Name) but when I restarted Server Two it went through a whole new world Generation Cycle and it was a new Flat-land world. I had plenty of backups and double backups on a External HDD. I went to restore one of the restore points and I mis-clicked and hit the “Prune Older” Button next to the most recent restore point (after the new map generation).

One thing I changed was the server name from Server Two to Big Build Energy. I think this is what messed something up. Ill keep calling it Server Two just for clarity.

I panicked for a second but remembered my old copy (a few months ago). I got into the files and put the old Server Two file into the system and it loaded perfectly, albeit with a couple things missing from the build (not a major loss).
I sufficed that it would have to do and I went to bed somewhat relieved that I didn’t lose everything.

The next day I checked again and found a perfect archive in the server files and I downloaded it to my local machine then renamed it and pushed it into the live server file. It Worked! The whole build was still there and I made sure to make complete copies of this “Fresh” version of Server Two as my Main Backup point from here forward (hopefully).

[Actual Problem]

That’s when I started to notice something was weird. For some reason after Server Two was successfully recovered from the archive folder (/var/games/minecraft/archive/ServerTwo) The automatic Restore Points via the Crontab scheduling was not working. Pushing make new restore point manually in the WebUI would say it failed. I could still type /save-all in the command prompt in-game and in the WebUI latest.log console, and it replied that it saved properly. There were blank spaces in the scheduling section of the WebUI, and the other tasks such as reboot warnings and the reboot itself would fail to work properly. Server Two would shutdown but not restart by itself. A couple times I restarted the Host Machine just to try and “Turn it off and on again”.

Now after this happened I had another bright idea… I knew which files in Server Two were the actual world map files and the data about them. So I created a new Flatworld Server and got it running and generated. (Same jar 1.16.1 as Server Two, same general properties mobs spawn false, generate structures false, creative, peaceful etc.) I accepted the EULA after first boot up and it generated properly. I then stopped the new world and went into the files to delete the new ones and add the world/maps from Server Two. When I restarted the newly created world everything was there and functional again. I made a whole new Crontab scheduling and waited around a couple hours to make sure the restore point was working properly. It was… but at that point, in the WebUI latest.log screen was showing just a couple lines about accepting eula and see eula.txt for more info. I could still send commands via the “console” and they still worked properly on the live server but no new logs were being generated / saved as usual between server boot ups.

I continued playing / building today… marking out some boundaries… and then the server crashed and gave me an “Internal Exception: java.lang.StackOverflowError”. Now I can login but the server will crash after a few seconds, (same error). This is when I realized that no logs were being saved, I went into new ServerTwo and the the only file was latest.log with the same few lines about eula.

I looked around these forums a bit and found Hex mention the mineos.log file. I found it and its quite long… Nov 10th 2022 is about 3300 lines into the file.

[What I’d Like]

[Quick Fix]

  • Make it stop crashing
  • Get the console to function again to make logs and read chat live
  • Re-do my scheduling to make sure it saves every 30m-1h reboots 1/day

[Real Fix]
I’d really like to Re-install the whole OS again onto the same machine and re-setup the server so mc is the main acct used and root is never touched. I fear though that since i’ve copied and moved and messed with this world file so hard and so much that if I try to copy it over again it wont have the correct permissions or something will go wrong (again).

I hope the Minecraft Gods or the Elders can perform a miracle here because i’m at my wits end with what to do next. This build is a massive one and having to start from scratch might just make me give up on it.

PS [Welcome to the club]
I just joined the forum officially and I kept looking through similar problems to what i’m dealing with.
These are those Threads:

– suggested fix → chown folders for mc mc

– I learn about mineos.log (very long file)

– Learning more about NOT using Root

– More about using mc instead of Root

– Great Thread in General since I’m new

I’m going to re-read them tonight but I’m not sure if I should start poking around since no new logs are generating and I might miss / lose an error that will help.

Any advice would be immensely helpful. I’m pretty confident working with the root acct (since i’ve been using it this whole time) so i’m not scared of changing permissions or ownership, i’d just like to be cautious and see what someone suggests before I keep going on my own blindly.

Thank You

Honestly it sounds like a lot to try and troubleshoot and to someone external there is to many parameters evolved to truly know what is wrong in your situation.

What i am gathering from this

  • Permission issues.
  • Sounds like there could be webui issues mixed in here too.
  • Changing the servers name should not of messed anything up.
  • You also sound unsure about the underlying issues so that shapes how you relay and also how people offer advice. The search party could be a few miles to far over in comparison as an Analogy.

The restore point issue will probably be permission related.

Idk i think the fastest and easiest thing to do at this point would be to back up your world to your local computer and just wipe the server and start with a fresh install ftp the world back over again. Make sure you do everything on a non root account unless stated in any reference material you may follow and maybe also spend time and research/look at the file structure and the permission hierarchy of it all.

Once you know what files need what permissions then you can fix these sorts of problems on the fly as it stands now though its kind of hard if you don’t know. The easiest way would be start small know what your perms should be past var/games and any of its sub dirs.Once you know this you can fix this stuff easy.

I am really only saying to fresh install atm becasue reading all this i suspect there is factor X involved and its just easier to avoid that.

Also think of it like this Root supersedes all users so anything you do on a non privileged account, root can bypass if you keep this line of thinking you can’t go wrong really.

Thank you for reading about my problems
I’m taking notes and I will reply again tomorrow after work with my findings and what I think some good next steps might be.

I"m willing to submit the mineos.log file but it’s quite lengthy. I’ve been reading this forum for years but I just joined today. I still need to learn a few things about the forum

This mineos.log File … it starts on June 17th 2022 and part 2 starts on July 18th 2022 so buckle your seat belts. If I can find an older file ill make sure to upload it.

My problems started (somewhere) around line 3,343 (part 2 line 840)
looking backwards… this problem might have been persistent for a bit longer than I suspected

Part I

Part II

God Speed to anyone who can read this and understand it

no one is really going to try to read a log file that long because its hard, you want to delete it and then as soon as you have an issue capture the log at that point of time. It would even be wise to make a cronjob or some sort of automated system that deletes the log each time you close the server.

That way if you ever have trouble with the server your log at that point of time is going to be pretty small and any errors will stick out and be really obvious.

Realistically this is relative meaning to someone else its just going to be a lot of reading but you personally might know key points when the server was acting strange or doing stuff out of the ordinary to someone else its just a massive wall of text. I had a skim over it and could not really tell if anything tbh,

but when i say skim i just ctrl+f for error and then literally skimmed.

Hi.
I would start by copying over the old logfiles to something like “mineos.log.old”, then deleting the file you copied from (mineos.log).

Next time you start the server, MineOS wil have a much shorter logfile to load to write to, and it’ll be easier for both you and us to read through to debug.

You do not have to reinstall to reset user rigts. This post has info on how to reset the rights in your current install:

Changing the field “level-name” changes not only the name of the world, but also the folder names the server stores it world files in, so changing names will most definately have an effect of resetting your world. The old world files wil be in a folder named after the old world though.

The “level-name” value is used as the world name and its folder name. The player may also copy their saved game folder here, and change the name to the same as that folder’s to load it instead.

From:

I suspsect your problems have a few possible sources:

  1. java version mismatch
  2. read errors due to file rights
  3. possible spigot plugin bugs / coexistency problems
  4. possible spigot bugs

I would try to sort out the rights issue first, to see if that solves anything. The checking out the java issue, then disalbing all plugins for spigot to see it runs smoothly without plugs, and finally check the spigot forums to see if they have anyone repporting the same problems.

If it is a spigot plugin-crash, enable one plug at a time, untyou find the combination that crashes your server. Then see if that one has a fix, or update

if you changed the server name in the server.properties then yes this will change the relevant files as it makes a instance based of this. Sorry i misinterpreted what you meant here.

I did also state to the OP that if you know how to handle perms then you can easily fix your issues but seeing as OP has by the sounds of been doing most of their stuff as root and at the same time unknowing of the ramifications imposed then there is going to be all sorts of cans of worms tbh that we don’t know about unless diagnosing it as first hand problem.

Tbh this is going to be possibly harder and more stuff involved than we know unless you in front of the specific computer itself and can check it first hand.

Hence why i said nuke the server and start fresh its a catch all and tbh if OP does not know about perms and what they need to do and the significance of doing everything as root which led them to this then there is more to it. Possibly out of the frying pan into the fire.

Idk you have to learn either way OP so you can tackle this by all means but if you semi greenhorn still not intended to offend we all are at one point.
Then i would suggest starting over and then learning about perms and how you should be running the server etc from a clean slate that way you automatically have a good standpoint to learn off of not one that is all messed up.

Also there will be a time when you don’t have to nuke anything because you automatically know what to do but at the start of learning something it is totality acceptable to do this.

Turnkey distro offered by MineOS is going to be a good baseline to learn what is what but all the other methods are fine too.

Thanks for all the great information. I got home from work a little bit ago, so I am just going to take this easy and slow.

A little more backstory on me. I’m a Linux Main for about a decade now, so I know my way around a terminal and headless ssh, some networking, ftp and filezilla, also pretty good at trouble shooting (since i’ve had this host working for years so far with minor problems). I have run into other problems with the MineOS but they’ve all been easily resolved by looking through this helpful forum. I have backups of backups and I typically save everything.

I just backed up then erased the mineos.log file and tried to boot up ServerTwo again… This time with no StackOverflowError. It seems to be functioning as “normal” just without the latest.log console not updating or writing log files.
I pushed a recent backup (before i changed the name stupidly) to the server file and the WebUI latest.log updates properly and works fine but the restore points do not work either through scheduling or pressing the button in the WebUI.

I have a couple ideas about how I should proceed but I would love your advice on if I’m correct and what order I should do things in.
The Basics - Backup
A- Backup all files from main Server Files (var/games/minecraft/servers) to my gaming machine, and keep a second copy on a External HDD
B- Backup the entire server file system as a hard backup so I can get back to square one (where im at now) and backup copy on HDD

Idea 1 - change permissions for the “most functional” server file backup to full ownership for user mc
1.b - login to user mc and try to push that functional file (with perms changed) to the mc acct in the same var/games/minecraft/servers folder and see what happens

Idea 2 - Nuke the Host machine and Pave a new copy of MineOS setting up in the exact same way as I have on prior “OS Refreshes”
2.b - login via mc account and get the WebUI Operational (create a blank vanilla world for test)
2.c - using my gaming machine, push the copied “functional” file to the mc user folder system into the /minecraft/servers folder
2.d - login as root and specifically change the permissions of that copied folder to be owned my mc
2.e - login again as mc and test the world for generation (map still there) and WebUI functions (restore and reboots via scheduling)

The Host machine is still in pretty good shape considering it’s early-middle age, I dust it out regularly. I’ve gotten used to re-freshing my computers OS’s so It wouldn’t take me very long to have the Host Nuked and Paved fresh.

I have no for-seeable work the rest of this week so I’ll lurk this post frequently for updates.
Thanks Again

[Edit] - I remembered another idea for what I could do
Idea 3. Nuke & Pave a fresh Host
3.b strictly inside the mc user account create an identical flat world (as similar to original ServerTwo as possible but on 1.16.1
3.c Make sure the flat land loads properly and WebUI is functioning
3.d Overwrite the world-data files (as I did before) and push My Build into the fresh Flatworld and see what happens

I just realized I bought two of these computers at the same time, I have almost an exact copy of the same Host machine that has been running the server. The Main Host has a little more RAM and more HDD space. Both machines have over 150GB of space & 8Gb of RAM

I think I will try Idea 3 on this 2nd Host machine tomorrow and i’ll let you know what happens

Fingers Crossed

[Edit]
Advice is still welcome

Sever.properties- world name actually changes the folder that holds the world files. This is why it generated a new world, it no longer found the existing world.

I’ve never renamed a server so can only comment in ignorance, if it works the same as world name then the whole thing would stop.

When MineOS is running smoothly you shouldn’t have to run the reset or update script.

If you’ve backed up the server I’d load up a new server install, use the MC user, set up a new server, run it once then copy the world into the world folder. You’ll want to replace the owner:group on the files you copy across.

Host 2 is now live and functioning… I have created a flat world as a test and the scheduling and restore points / latest.log screen are all working perfectly.

I’m going to attempt to push the map/data files into a 2nd new Flat-world for testing and ill post an update.

I don’t like that a Nuke & Pave might be the only way to save this world because it wont go to actually solving the problem I had, instead just resetting and going from square 1.
This thread might not be very helpful to people in the future if they have a similar problem.

Ill let ya know

I’m not reading all that.

Nuke and pave, as you put it, is a valid troubleshooting strategy.

Everything seemed to be working great.

I noticed the latest.log file was not updating or outputting saved logs to the folder
The scheduling worked (after I fixed the timezone) but once again… the server would go through a restart and never actually start back up. I had to suffocate the Host to reboot

Now… I am having trouble even connecting to the WebUI login screen and the server is not responding even though it should have started up on this last boot cycle (after i suffocated it).

I checked out the old forum post above
Suggested fix was
“”
chown -R mc:mc /var/games/minecraft/servers/*
chown -R mc:mc /var/games/minecraft/archives/*
chown -R mc:mc /var/games/minecraft/backup/*
“”

I am still able to login via the host machine and I went in as root to make those specific changes to the permissions of those specific folders.

I went through another reboot and the WebUI is functional again, but the latest.log is still not working
I’m going to re-set my scheduling so that there is no reboot tasked, If I want to reboot the machine walking 25 ft to the other room is not that hard.

I would really love some advice… I can post the new mineos.log file because it was working for an hour or so when I got it up and running. I double checked just now and it IS still outputting to this mineos.log but not outputting regular log files.

Paste to new Mineos.log - only about 400 lines (just from this morning)

[Edit]
To those who can understand the log file… the problems in short are

  • latest.log file quit populating and outputting
  • scheduled reboot turned the server off but not back on again
    Everything else is working perfectly

Another question popped into my head…

This most recent server was generated then the region / data files were overwritten from an older file. Why would just those files (even with permissions changed entirely to mc) cause the latest.log console to stop functioning? And the restore points were all created inside the WebUI for the new server… so idk why the reboot function would only shutdown and not go through a proper re-boot-up.

I hope this thread doesnt die. Even with the new version Im going to keep building on it. I may have to go through the map overwrite again in the future but I can make it work until then… unless something else goes wrong soon.

You have been on Linux for 10 years? i find that hard to believe simply because of what has been said so far no one who has been on that long would be using root to do everything because its rule number one. Your opening post corroborates this somewhat too. Not trying to be rude or anything but it just seems like you should know these things.

I got into Linux at almost the same time I learned of MineOS. I started running a server on windows when I was working in 2012… very soon after that I moved to Linux as a noobie.

I had just started playing Minecraft in 2011-2012. So I started using MineOS as soon as I found it and went from there. ( I even ran a portable version of a bootleg MC, saved and running from a USB, to learn how to play the game. I still have that world save)

I was a noob when I started thats why I used root instead of mc…
I was able to learn and grow but previously when I tried to switch to mc acct it didnt work (obviously) so I kept going with root. until now (see my first post)

I can assure you, i’m fully versed in how to do what im doing and am confident in using SU commands and I know how to respect the power behind root.
I could run this server headless from another state if I had to.

Im not a power user … but im not a novice

ok does node even go back 10 years? or are you on crux still?

because as it stands you are making it sound like this is the same Mineos instance from 10 years ago and if you have been using root that long or at least initially then again like i mentioned earlier you should nuke the server. Because there is probably more issues than we know.

Also it sounds slightly catch 22 here in that you say you know what you are doing but yet you are asking a some pretty beginner questions in some of your posts.

Sorry i am totally not trying to be offense or abrasive towards you i am just blunt and say things how i see them that is just how i am as person.

And at the end of the day we do want to help you here and if the instance is years old like you keep saying then the best option might just be to start fresh and you do still have the world backed up.

I have also not read the thread properly since i last came in here and its much bigger now so if i am possibly out of context atm.

no problem, you’re not abrasive or offensive. I am new to the forum but ive been using it as a resource for a long time.

When I started this server probably closer to 6-8 years ago… and I started using it as root (because I didnt know better). I have nuked and paved the server a time or two, and used to use plugins all straight from the WebUI and plugin tutorials. This Big Build is not the only server ive had running on this machine… I created and ran maybe 10 others on the same machine the whole time. Never more than 1 at a time… and very small user group (if any).
Ive even created a multiplayer map around a short story I read a long time ago.

Ive rebooted the whole Server OS at least once and was able to continue functioning (as root) up until now. Only now… the forums failed me and the server is having massive hiccups with logs not populating / being saved and the crontab scheduling not working properly. These all worked fine the whole time ive been using MineOS (which is great).

I would like to know about what you mean im asking beginner questions. I appreciate any and all help in this… I just want it to function properly again so I can keep an eye on everything and maintain my server.

It would take you maybe 5-10 minutes to read the whole thread. If I May, Please talk to me like someone who knows what they’re doing but cannot read the error logs.

With the knowledge I have… its very unlikely that I will ever lose this world. I just want the WebUI and scheduling to work (which it has amazingly until my years of shenanigans)

Just reading most of your premise and certain context sounds like stuff that would come from a beginner. I guess the whole pretense would be that someone who has been using linux this long would probably not be starting a thread like this to begin with.

Stuff like this sounds pretty beginner and its dotted all over the thread and is just one example. Sorry you have to realize that we didn’t know you have been using this for 10 years until like just now, but stuff like this seems inconsistent and does not sound like something someone would say that should know better.

Reason being you would know how to reinstall the OS

Really not trying to put you on blast but you did just ask.

Lets get away from that anyway its irrelevant this is not supposed to sound like an attack