[RESOLVED] Fresh Server has some interesting problems

Hello again,

My last post got long-winded and confusing. I was suggested to create a new thread since I have made some progress from the original problems I was having.
This is the old post. For more backstory/context behind the current issue

[Fresh Install]
I’m mainly using this server as a private Build-World and sometimes, on a different World file, as a place to play with friends and my nephew.
This issue is just with the Build-World that I have been calling ServerTwo (in the last thread).

Just yesterday I refreshed a Host machine with the most up-to-date MineOS instance. I was able to generate a new flat world as a test then I used Filezilla to push the /regions and /data folders into this new flat-world (this world was created with the exact same properties and jar file as the ServerTwo copy/backup that I got the /regions & /data files from). After the files were in place I logged into the host machine physically (only this once as root) and used chown -R on the /backup, /servers, and /archive folders to be owned by the user acct “mc”. I changed nothing else and I moved no other files to this newly generated flat-world.

[What went wrong]
The server generated the map properly. After a reboot of the Host machine, I setup a couple scheduling tasks to create restore points and to reboot the world. The scheduling only worked for restore points and sending /say commands like “server reboot in x minutes” and “restore point created”. But during the reboot-task the server would still appear live in the WebUI but I could not connect and it did not properly re-boot the world. I had to reboot the Host machine manually to get back into the world.

On top of this the latest.log file (and console in WebUI) quit populating and also was not saving the .log files to the /log folder. The console still worked (I can send commands and they work fine) but no lines are being written in the latest.log window.

The Mineos.log file IS still being created / updated, and is much shorter than it used to be (see old thread).


On my new server I pushed the region and data files into a newly generated flat world to continue a big build project. I corrected the permissions (as root) for those files. I am using ONLY the mc acct to handle the server WebUI and world creation.

For some reason,

  • Scheduling is working with restore points but not with reboots
  • The latest.log file is not outputting to console or generating .log files
  • The Mineos.log file IS working and I can upload a new pastebin link if requested.

[Let me know how I can help]
I’m familiar with Linux file systems and am willing to submit other info if you tell me what you’d like to see.
I have discord… I can take notes during a call and make sure all relevant info is noted and posted here.
It’s hard to offend me so just be blunt if i’m doing something stupid.

MineOS Turnkey is a great project and I appreciate any and all help received and even suggestions

Thank You

Scheduling assuming you are talking about the webui and restarting the server you probably just have the command wrong. There is no restart command unless its changed or unless you are using a mod or plugin you can only use /stop.

if you are not generating latest.log files and none are appearing then you probably have perm issues again.

Check the perms for your world folder and world/logs folder if its owned by root and you are running the server as non privileged then you won’t be allowed to write to that folder because the java binary will be non privileged at runtime.

if /restart is not working then you have the syntax wrong. Assuming you are still using spigot.

You wont be getting console output in your browser because there is no latest.log generating hence nothing to tail.

Just skip doing stuff as root man. There is also absolutely no reason to ftp over anything past var/games as root it should all be done as mc.

I know you said you changed the perms but there really is not much outside of this that is going to stop you from generating files like latest.log except like disk space which i doubt is an issue on a single player server and is probably the only other issue that this problem could stem from really. Which is also doubtful because you would have unstable and slow server if you are pressed for space.

idk just stop ftp stuff over as root there is no need lol do it all as mc because again remember root supersedes mc

Permissions for file /world/log
mc@mineos-tkldev …/servers/Big_Build_Energy$ ls -l
drwxrwxr-x 2 mc mc 4096 Nov 15 11:14 logs

I’m not using /restart. I setup the crontab for an automatic server restart and it didn’t work properly through the WebUI. I know that /restart wont work because this server (fresh install) is completely vanilla. No plugins have been installed or plug files transferred to the host this time.

I already had the server files (which had previously been owned by root) saved on my local gaming machine. After the fresh install I pushed the two folders (/data and /regions) to the Flat-world server files… logging into filezilla as mc (i’ve learned not to mess with root, finally)
Only after the files were transferred (as mc) to the server files, I went to the Host machine in the other room and physically logged into the server as root (just once) to use /chown -R on /servers/* /archive/* and /backups/*
(I read this guide by Hex to get those commands) Server starts then crashes a few seconds later - #6 by hexparrot

Disk space is not an issue the new Host has over 150GB of space.
Again… I didn’t push files to the server as root. I did it as MC and then used root (via the host) to change the permissions of those specific files.

mc@mineos-tkldev …/servers/Big_Build_Energy$ ls -l
drwxr-xr-x 4 mc mc 4096 Nov 15 10:41 data
drwxr-xr-x 2 mc mc 4096 Nov 15 16:01 region

It seems like the perms are correct to me… If there is anything I should change please let me know. Thanks

If those are the only two files/folders in your server directory you’re missing the rest of the server files… to the point where the server wouldn’t start…
Have you omitted the rest of the entries?

How about you paste the entire contents of /servers/Big_Build_Energy
An example of the proper folder structure is like so -

[ansible@mineos .../servers/VaultHunters]$ ls -la
total 40492
drwxrwxr-x. 17 ansible ansible     4096 Oct  1 06:57 .
drwxrwxr-x.  4 root    root          45 Sep 11 09:22 ..
drwxrwxr-x.  2 ansible ansible        6 Oct 13 21:19 backups
-rw-rw-r--.  1 ansible ansible        2 Nov 13 04:32 banned-ips.json
-rw-rw-r--.  1 ansible ansible        2 Nov 13 04:32 banned-players.json
drwxrwxr-x. 15 ansible ansible     8192 Aug 25 08:17 config
drwxrwxr-x.  2 ansible ansible       50 Aug 22 07:40 crash-reports
-rw-rw-r--.  1 ansible ansible        0 Aug 22 07:38 cron.config
drwxrwxr-x.  3 ansible ansible       23 Aug 22 07:40 data
drwxrwxr-x.  2 ansible ansible      100 Aug 22 07:40 defaultconfigs
-rw-rw-r--.  1 ansible ansible      184 Aug 20 11:17 eula.txt
-rw-rw-r--.  1 ansible ansible   212574 Aug 31 08:02 forge-1.16.5-36.2.39.jar
-rw-rw-r--.  1 ansible ansible  2504067 Aug 31 08:02 forge-1.16.5-36.2.39-univer                                                                            sal.jar
-rw-rw-r--.  1 ansible ansible   212574 Aug 31 08:02 forge.jar
drwxrwxr-x. 12 ansible ansible     4096 Aug 22 07:41 libraries
drwxrwxr-x.  3 ansible ansible       26 Aug 23 07:49 local
drwxrwxr-x.  2 ansible ansible     8192 Nov 17 03:00 logs
-rw-rw-r--.  1 ansible ansible    10859 Aug 20 05:46 manifest.json
-rw-rw-r--.  1 ansible ansible   440784 Aug 20 05:48 minecraftinstance.json
-rw-rw-r--.  1 ansible ansible 37962360 Aug 20 10:18 minecraft_server.1.16.5.jar
-rw-rw-r--.  1 ansible ansible    12897 Aug 20 05:46 modlist.html
drwxrwxr-x.  2 ansible ansible     8192 Sep 23 21:31 mods
drwxrwxr-x.  4 ansible ansible       49 Aug 22 07:42 openloader
-rw-rw-r--.  1 ansible ansible      407 Nov 13 04:32 ops.json
drwxrwxr-x.  2 ansible ansible        6 Aug 22 07:42 patchouli_books
drwxrwxr-x.  2 ansible ansible     4096 Oct  2 23:36 playerSnapshots
drwxrwxr-x.  2 ansible ansible       38 Aug 22 07:42 resourcepacks
drwxrwxr-x.  2 ansible ansible     4096 Aug 22 07:42 scripts
-rw-rw-r--.  1 ansible ansible       76 Aug 31 09:20 server.config
-rw-rw-r--.  1 ansible ansible     1088 Nov 13 04:31 server.properties
-rw-rw-r--.  1 ansible ansible      656 Nov 13 04:51 usercache.json
-rw-rw-r--.  1 ansible ansible      345 Oct  2 23:33 usernamecache.json
-rw-rw-r--.  1 ansible ansible      443 Oct  2 23:33 whitelist.json
drwxrwxr-x. 16 ansible ansible     4096 Nov 17 20:35 world

In my case the servers, archive, backup, profiles,import directories themselves are owned by root (though I am not sure that owned by mc is going to make a difference for this issue).
Inside the servers folder I have this VaultHunters folder which is owned by my ansible account.
The contents of the VaultHunters folder is as pasted above.

What you’ve provided as the output of ls -l is not a whole working server directory.
I assume the region and data folder you copied is supposed to go inside the <server>/<server.properties.level-name> directory. In my case level-name = world which is where the world data is kept.

the logs for the world are kept (using my modded server as a guide) inside the servers/<server>/logs where I find latest.log (a location that MineOS will find and attach to).

My bad… I was asked about those files permissions so I excluded everything else. All the other files are still there from a newly generated Flat-World

mc@mineos-tkldev …/servers/Big_Build_Energy$ ls -la
total 37176
drwxrwxr-x 12 mc mc 4096 Nov 17 12:40 .
drwxrwxr-x 3 root root 4096 Nov 15 10:49 …
drwxrwxr-x 3 mc mc 4096 Nov 15 10:30 DIM-1
drwxrwxr-x 3 mc mc 4096 Nov 15 10:30 DIM1
drwxrwxr-x 2 mc mc 4096 Nov 15 10:31 advancements
-rw-rw-r-- 1 mc mc 2 Nov 16 08:50 banned-ips.json
-rw-rw-r-- 1 mc mc 2 Nov 16 08:50 banned-players.json
-rw-rw-r-- 1 mc mc 136 Nov 15 20:23 cron.config
drwxr-xr-x 4 mc mc 4096 Nov 15 10:41 data
drwxrwxr-x 2 mc mc 4096 Nov 15 10:30 datapacks
-rw-rw-r-- 1 mc mc 9 Nov 15 10:30 eula.txt
-rw-rw-r-- 1 mc mc 1394 Nov 17 12:40 level.dat
-rw-rw-r-- 1 mc mc 1395 Nov 17 12:35 level.dat_old
drwxrwxr-x 2 mc mc 4096 Nov 15 11:14 logs
-rw-rw-r-- 1 mc mc 37968964 Nov 15 10:05 minecraft_server.1.16.1.jar
-rw-rw-r-- 1 mc mc 133 Nov 16 08:50 ops.json
drwxrwxr-x 2 mc mc 4096 Nov 16 17:44 playerdata
drwxrwxr-x 2 mc mc 4096 Nov 15 22:13 poi
drwxr-xr-x 2 mc mc 4096 Nov 15 16:01 region
-rw-rw-r-- 1 mc mc 194 Nov 15 11:17 server.config
-rw-rw-r-- 1 mc mc 1063 Nov 16 08:49 server.properties
-rw-rw-r-- 1 mc mc 3 Nov 16 08:49 session.lock
drwxrwxr-x 2 mc mc 4096 Nov 15 10:31 stats
-rw-rw-r-- 1 mc mc 104 Nov 16 17:42 usercache.json
-rw-rw-r-- 1 mc mc 83 Nov 15 10:43 whitelist.json

I went up a couple directories to /minecraft and i get this

mc@mineos-tkldev …/games/minecraft$ ls -l
total 20
drwxrwxr-x 3 root root 4096 Nov 15 10:49 archive
drwxrwxr-x 3 root root 4096 Nov 15 10:49 backup
drwxrwxrwx 2 root mc 4096 Nov 15 09:27 import
drwxrwxr-x 3 root root 4096 Nov 15 10:04 profiles
drwxrwxr-x 3 root root 4096 Nov 15 10:49 servers

Yeah your folder structure is not a MineOS created structure

[ansible@mineos test_flat]$ ls -la
total 37120
drwxrwxr-x. 4 ansible ansible     4096 Nov 17 21:02 .
drwxrwxr-x. 5 root    root          62 Nov 17 21:00 ..
-rw-rw-r--. 1 ansible ansible        2 Nov 17 21:02 banned-ips.json
-rw-rw-r--. 1 ansible ansible        2 Nov 17 21:02 banned-players.json
-rw-rw-r--. 1 ansible ansible        0 Nov 17 21:00 cron.config
-rw-rw-r--. 1 ansible ansible        9 Nov 17 21:02 eula.txt
drwxrwxr-x. 2 ansible ansible       51 Nov 17 21:02 logs
-rw-rw-r--. 1 ansible ansible 37968964 Nov 17 21:00 minecraft_server.1.16.1.jar
-rw-rw-r--. 1 ansible ansible        2 Nov 17 21:02 ops.json
-rw-rw-r--. 1 ansible ansible      122 Nov 17 21:02 server.config
-rw-rw-r--. 1 ansible ansible     1052 Nov 17 21:02 server.properties
-rw-rw-r--. 1 ansible ansible        2 Nov 17 21:02 usercache.json
-rw-rw-r--. 1 ansible ansible        2 Nov 17 21:02 whitelist.json
drwxrwxr-x. 9 ansible ansible     4096 Nov 17 21:02 world

the contents of the world folder

[ansible@mineos world]$ ls -la
total 16
drwxrwxr-x. 9 ansible ansible 4096 Nov 17 21:02 .
drwxrwxr-x. 4 ansible ansible 4096 Nov 17 21:02 ..
drwxrwxr-x. 2 ansible ansible    6 Nov 17 21:02 data
drwxrwxr-x. 2 ansible ansible    6 Nov 17 21:02 datapacks
drwxrwxr-x. 3 ansible ansible   18 Nov 17 21:02 DIM1
drwxrwxr-x. 3 ansible ansible   18 Nov 17 21:02 DIM-1
-rw-rw-r--. 1 ansible ansible 1250 Nov 17 21:02 level.dat
drwxrwxr-x. 2 ansible ansible    6 Nov 17 21:02 playerdata
drwxrwxr-x. 2 ansible ansible   78 Nov 17 21:02 poi
drwxrwxr-x. 2 ansible ansible   78 Nov 17 21:02 region
-rw-rw-r--. 1 ansible ansible    3 Nov 17 21:02 session.lock

and the contents of logs

[ansible@mineos logs]$ ls -la
total 12
drwxrwxr-x. 2 ansible ansible   51 Nov 17 21:02 .
drwxrwxr-x. 4 ansible ansible 4096 Nov 17 21:02 ..
-rw-rw-r--. 1 ansible ansible  216 Nov 17 21:02 2022-11-17-1.log.gz
-rw-rw-r--. 1 ansible ansible 2683 Nov 17 21:02 latest.log

When I mentioned copying your world folder over I meant the entire folder into the world folder - not the root directory of the server.

i agree with Elpress your FS is messed up this stuff should be in the world folder.

If this is how your world has been for a while then this is all kinds of messed up and i am surprised it even plays?

[I’m having some issues posting? and the thread looked deleted when I went back to the homepage, sorry if duplicate im posting again because I dont see it below ElPres’ recent post]

Forgive me because I dont understand how I can make a new server using MineOS and the server folder structure is “not a MineOS created structure”

You posted
[ansible@mineos …/servers/VaultHunters]$ ls -la

I posted
mc@mineos-tkldev …/servers/Big_Build_Energy$ ls -la
My server seems to have one less(?) branch
It looks like yours follows as /var/games/minecraft/servers/test_flat/world/(Here are Region and Data Files)
Yet mine is just /var/games/minecraft/servers/Big_Build_Energy/(Here are Region and Data Files)

Your system has an extra "directory layer between /servers/ and /world/

What you’ve provided as the output of ls -l is not a whole working server directory.
Would you like me to post an “ls -la” command from another directory? All the files for my Server are inside /servers/Big_Build_Energy

Is it because the version installed is the mineos-tkldev version?
This is how the folder structure has always looked to me.

Picture is of me going to my server folder via ssh and showing contents
imgur. com/a/iGewMJe (link broken intentionally, I was seeing constant loading icon upon 1st attempted post)

that is correct structure

isn’t TKLDev? for development purposes? i totally missed that

Hmmm… this is very weird. I see the difference now. I just made a new server through the WebUI andit looks the same as ElPres.

The old file system (that i posted) has looked like that to me for a long time.

Ok… I see how this is a major problem but the server DOES still boot and run/save properly.

=-=-=-=-=-=-= I asked that exact question… the previous versions ive used didnt have the tkldev at the end.

Im not any kind of Dev… I just went to https://wiki.codeemo.com/ and downloaded the mineos-node_bullseye-X64 file and burned the iso to a thumb drive

im creating another new world but making it flat this time to see if the FS is different… This is ecatly what I did on fresh install before i pushed the region&data files (to the exact same place they were in the folders)

Ok well this would of been your defining factor in terms of this was the main problem all along and then everything else would of stemmed from this.

Minecraft always wants a world folder even outside of MineOS like even in singleplayer there will be one, its not a convention unique to MineOS. I am surprised that the world even plays like that tbh.

Then again it might not matter it could be just aesthetics and the JVM might read in a top down fashion so it may not actually matter at the end of the day as long as the JVM can see the files from the parent dir probably…i have seen this before in some games like Arma 2 can do this and it might even be a native thing i am not entirely sure.

Although MIneOS will be looking for stuff in defined locations which will be how the problem arise.

I looked through my old copies of the world and it DID have a world file it was just named A+New+World… But i dont understand how the system got so messed around when I only had moved two files. Moved might be the wrong word. I had the saved copies of the files (in the directory where they were) and I located the matching files (in the newly created flat world) and I over-wrote the new files with my old copies. That shouldnt have affected the whole filesystem structure.

I made the flat world test and the structure is exactly the same as ElPres’. (How it should be)
I cloned (overwrote) the same files to push my world into this new flat_test and It propagated and loaded the build perfectly with Latest.log reporting. I didnt try crontabs yet but I assume they work fine (with the proper file structure)

Im going to do some more work on this for a quick bit.
These are the steps im going to take.
1 - Backup the Big_Build File in its entirety (just as a backup, i like backups and I built a little)
2 - remove the 2 new test worlds I just created for testing the file system
3 - Create a new flat-world again… this time making sure the properties files and all minor fields are as matching to the current Build server (no mobs, peaceful, player limit, whitelist etc)
3a - Boot that server up as a flat-world with EULA accepted
3b - Stop the server
4 - look at the file system via ssh or filezilla
5 - push the two files over again like I just did with the test_flat world (the one with the proper filestructure)
6 - Restart it and see if the logs are generating
7 - then ill test the crontab

If you have any other ideas or a change in what I should do ill be watching

Thanks so much… this feels like its going to be the real fix i was hoping for in my original thread

Ok… it didnt work for some reason… the latest.log quit outputting again
The filesystem structure was produced in the proper way, but the error happened in between steps 3b & 6

The only thing I did was
Stop server
overwrite the region and data files
I also added an additional java argument (below the Xms Xmx fields)
Reboot – (map generated build successfully, log never posted the boot-up lines)

Then the latest.log quit writing
Would this phrase be causing a problem?

I had done research when Log4J happened and I have had this command in the extra arguments field for a while… Might this be a problem?

I even looked into the permissions of all folders (data and region specifically) and they are all mc mc

Its Alive!!!

I duplicated the exact steps above again and now everything is working… even the crontab scheduling

latest.log , restore points, server /say commands, and reboots are all working perfectly

Thank you all so much for your help. Idk why the first re-do didnt work but it did on the 2nd re-do. lol. This has been quite a problem. Thanks So Much! I just wanted it to run smooth with scheduling and logs outputting. Now its fixed!

I still dont know how to change the title of the thread. Can you guys tell me how or alert a mod to mark this thread and my last one as [Fixed] or [Closed]

btw did I say THANK YOU yet?
If not… Thank you

1 Like

Now. Don’t mess with it :laughing:

I had a little trouble posting earlier but I want this to be sure.
2nd post - a couple new questions about the java argument I added before and a peek at the Build im working on. Thanks Much. I wanted the thread to be complete with all my posts so others may find it useful in the future

IT WORKED. I re-tried the steps from my post above and it finally completely worked.
The only thing I didnt do was add the extra java argument protecting from Log4J. Would the 1.16.1 jar file be updated by Mojang to defend against that… or is there another argument I can use that is better?

World file is my build, latest.log is populating and saving, scheduling is outputting server /say messages / restore points / server restarts. Everything is working perfectly now. Thank You So Much

You all deserve a sneak peek into the build ive been working on.
Im building the home I grew up in 1 block = 1 inch^3 and to building code… studs, insulation and everything.
Imgur link broken intentionally (posting fails when i try a live link)
imgur. com/a/7w4QLSo

I have a long way to go but you all were invaluable in making sure my project kept on progressing smoothly
I am Soo very much Thankful for your help

[final ps]
Thank You All
I promise I wont mess with it


I still dont know how to change the title of the thread. Can you guys tell me how or alert a mod to mark this thread and my last one as [Fixed] or [Closed]

Nice good that it is working

The forum settings must of changed i just looked on an old thread and the title had been edited after making the thread. I just tried on one thread and its no longer possible. This could be a timeout related thing idk.

That imgur link won’t work even in the address bar it just opens an irrelevant search page. You would need the embed link for us to see it.


it is also more ethical to embed stuff because its more eco for the forum.

Apparently I can change titles