New webui programmed with node.js

I’m hoping the community at large will come and help me test mineos-node, the new iteration of the mineos web user interface.

Among other things, this new version showcases real-time updating of host and server status, logs, a new design of the profiles system, and cron task scheduling in the webui. However, I have not yet gotten any real feedback on its operation since I posted on it about a month ago.

I know admins are often reluctant to be early adopters of new tech–and I’m not asking you to replace your existing systems with mineos-node–quite the contrary, I’m asking for the community to help provide some feedback on the installation and workflow on fresh installations, preferably on virtual machines.

I’ve poured hundreds of hours into this mineos-node version and I feel like it most certainly can and will happily replace Python mineos over time, but I’m asking for a little bit of your time and effort to test it out and see how well it holds up against more than just programming test-suites.

All feedback is welcome. Please, show your support of MineOS and my efforts for this free and open source community and give it a shot.



1 Like

I would be willing to try it out sometime, but being a complete Linux novice I don’t know if I would provide any good feedback?

Then you’re the exact type of person who needs to test it.

I have installed the current MineOS on an old pc from a disk. This is the only way I foresee myself installing MineOS. How would I emulate this installing this new version on a Virtual box? I can’t quite seem to work it out :confused: (complete n00b to VirtualBox too :P)


I installed a fresh Ubuntu Server 14.1 and followed the instructions for installing the new node.js MineOS.

Installation seemed to go well, as did the initial start.

I downloaded the latest Mojang jar file, 1.8.7 - that worked well.

However I cannot seem to create a new server. I also noticed that there is no place to choose which profile to use.

I run a small-mid size server “network” (bungeecord) with 4 active servers. I am not an expert but I can usually find my way around. Of course when I run into problems it is usually in the wee hours of the morning, like it is now. So maybe I just need some sleep? :smile:

my server:

You should please start a new topic for your issue and you’ll receive help there.

Please start your own topic and we shall help there thanks.

I would be more then happy to test a new build. I currently don’t have a server running so perfect time for testing. I’ll also test it on my arm devices. Hmm wait will this not work on Ubuntu or Debian based systems.

The Ubuntu instructions I wrote should be fairly similar for Debian.

Well if it works on Ubuntu I’ll get it working on Debian. My question will be arm platform. I’ve been down this road before with mineos and have made videos allowing users with devices like Raspberry Pi and Cubox-i. And soon Hummingboard. Can’t wait to test for you later tonight. Oh and if you could link to your Ubuntu guide that would be helpful. Or is it the same github install as before?

It’s the how to at the top of the list of topics.

Here’s the topic: How to emulate installing MineOS node.js from a disk on VirtualBox


Well looks like for now my arm device is a no go on Debian. Keep getting a CERT_HAS_EXPIRED on the install all command via npm. I’ll try later via virtualbox.

I got it to work on an ODROID-C1, on Debian Wheezy and Ubuntu. What’s your full error?

Basicly that I have an old Cert. Here is a pastebin link. NPM ERROR

I’m also installing debian now on a virtualbox to test and posibly make something to help users with install. Great instructions btw.

Update: Seems everything is working fine with the virtualbox install. going to look back into the issue with my Arm board. There is no official support for nodejs it seems for Arm so that could have something to do with it.

Ok ignore that other error log, We are working on a dev build of Debian so that was the issue with the CERT. but I do have a different error now. Take note that i’m building NPM from source that means that nodejs,nodejs-lagecy,npm are not found in apptitude. Anyways this is my error now. enter link description here

Is the error you’re getting actually stopping the webui from working?

It seems to be a known issue that uname fails to build on some systems, namely Arch and OSX. OSX from that git issue, Arch from my own experience.

However, uname is only used in one part of the code and I’ve been able to design it so failures on this module shouldn’t prohibit the whole webui from working. Go ahead and try starting the web-ui and see if it works, all the same.

You are correct. I didn’t even attempt to start the server. Got this error. “MineOS unable to load “uname” module; tally failed.” but started up great. I must say that the new UI seems sooooooo much smoother. I’m running this on very limited hardware and it’s flying. Hardware info

Solidrun Hummingboard-i4pro

CPU : Quad core ARM A9 (1ghz)
Memory : 64bit,2GB DDR3 @1066Mbps
Running on Msata 30gb ssd

Ok so yes it starts and allows me to add a server and download a profile. But I am unable to start it. On my virtual machine there are no issues so I know it’s my box. Anyways I’ve included a full pastebin of the install and attempt to run/start a server. I hope this is helpful to you.

Link:Arm start failure

Check your rsync version from the command line. Is it at least 3.1.0?