MineOS Server won't stay "Up" for more than a few seconds, if at all

Hello! I’m a huge newb, and I assume I’m missing something obvious, but after a couple hours of googling, I figured it was time to ask for help from the pros.

My friend and I are doing a Direwolf20 (1.10.2) pack server. There’s just two of us, no huge crazy build planned or anything. The problem is, my server won’t stay on for more than a few seconds at a time before it switches back to “down.” I have MineOS installed to an old Dell PC and I’m trying to run it from the Web UI on my gaming PC. The log didn’t seem to have any useful information in terms of solving the problem. Here are some pics of my settings in the UI.

Server PC Specs:
Dell Optiplex gx 280 from like… 2007?
Intel Pentium 4 (i386) @ 3.2 GHz
MineOS (x86)

Gaming PC Specs:
MSI GeForce GTX 1060 Gaming X
Intel Pentium G3258 @ 4.2 GHz
Windows 10 (x64)

Any help you could offer would be greatly appreciated.

Bonus points for possibly unrelated question: I can’t SFTP into the files as Root, only as MC which is read-only, so I can’t upload my own single player world save even if the server worked. It says “authentication failed.” Anyone know why that may be?

To start at the bottom:

The root user is by default limited, and not intended for using. If you added or managed servers as root in The WebUI you block the mc user from being able to add files. Never use the root user, unless you are updating MineOS itself.

To import your old server/world, add it as a zip-archive in the “import” directory, then choose “Import a server” from the WebUI.

The next thing to do is semantic:
It is not your MineOS server that cant stay up. It is your Minecraft server. MineOS is a multi server handler for minercraft servers. It may seem minor, but the distinction makes it easier to help correctly in the first place.

To help you with the server that won’t stay up, we need logs. There are two of them, the mineos log, and the minecraft server log:

MineOS log: /var/log/mineos.log
Minecraft server log: /var/games/minecraft/servers/servername/logs/latest.log

As you are trying a direwolf, there may be other logs as well, but these two are a good start.

But since the server starts, then stops again there are a few common errors that usually are the cause:

  1. you have several servers, and try to run two or more on the same port
  2. you have not accepted the eula, and the server stops when it do not find this accept.
  3. you are trying to start with the wrong file, so it aborts
  4. there is an error in the file, and java crashes and aborts the file.

Without the logs mentioned above we cannot give any better advice.

Direwolf is a FTB-type server, and those are notoriously tricky, and are prone to errors due to faults in the scripts from the developers. Remeber that MineOS is not affiliated by any of the different developers of minecraft servers, MineOS is merely a web-admin panel for administering such servers.

1 Like

Hey, iMelsom!

Thanks for the quick reply! Since I posted I did check a couple of things.

  • I was able to run a vanilla server successfully
  • I only had one server when the problem began
  • I have accepted the EULA
  • I am using the files that downloaded for this pack from MineOS itself

I logged out and logged back into the Web-UI as MC, as well. The FTB server still does not work, however.

Here is my mineos.log

After it didn’t work, I deleted the server and now don’t have access to the logs. :confused: I didn’t realize the log files would go with it. I tried recreating the server as MC instead of root, but now it won’t even start at all, so I can’t provide a log if it won’t start to create one, unfortunatley. It says “[DireWorldXX] Start Failed. Server may not be running.” (It is, as the vanilla server worked).

In mineos.log you also have this error:

 command \"start\" errored out:","timestamp":"2016-11-17T19:32:41.249Z"}

This suggests to me that there may be something wrong with the file that MineOS downloads from FTB.

Profiles are not a surefire way to get working server files. It merely downloads provided files from the server developers, and puts them in a “server-file bank” so that they become available for all your servers. MineOS are still dependant on the files the deveolpers make available, and that they are as bug free as possible. This is why (for example) pocketmine and Imagicalmine where removed, they could no longer deliver working updated server files.

It’s to bad you deleted the server, and thus the log-files, since we will not be able to track the actual error in it self. That being said. There is several forum posts in here that outlines and describes how to get a FTB-type server running.

Then again, there are lots of post where FTB servers do not work: https://discourse.codeemo.com/search?q=FTB
A common error seems to be that java needs to be upgraded, or that the FTB-package is bugged out.
As I said. FTB servers are tricky.

1 Like

How do I update Java on the server PC? Is that possible?

I also just got the server to start up and then fail again, but there is no log folder in the server profile.

Please search the forums. There are several questions about that as well…
But anyways:

In the server profiles??
As in here:
/var/games/minecraft/profiles/ ?
That is not where I asked you to look for logs :wink:
FTB has a separate log as well, and do quite a lot of work before the minecraft java (and the minecraft server logs) start. Please provide that as well:

/var/games/minecraft/servers/(the name of your server)/logs/fml-server-latest.log

Yeah, I can get as far as /var/games/minecraft/servers/(the name of my server), but there’s no “logs” folder in there.

Here’s a screenshot of the contents of that directory: http://imgur.com/a/c0myD

I also successfully updated to Java 8 on the server machine, but it did not solve the problem.

I guess you are trying to use the only jar-file available in that directory to start the server?

Problem is, that file is not a complete minecraft server. That is the file that contains a lot of modifications and routines for running mods on a minecraft server.

You need to log in to your server with ssh, go to the server directory, and run “FTBinstall.sh” to actually get and compile a server version you can run. This produces a server file you can run.

I reccomend reading through this thread for a discussion and howtos for installing a FTB server, and some of the pitfalls, and commonly met bugs.


Dude, that completely solved the problem. I just ran the FTBInstall.sh file and it worked like a charm. Server is up and running, SFTP and SSH are working perfectly, and I got my single player world setup as my server world.

Thank you so much! I will still go through and read that thread you linked to, though, so that I have a better understanding in case I run into any more problems. But I really appreciate all your help! :slight_smile:


I just want to say that as I nooooooooob to anything networking and servers this thread really helped me figure out my problem(mostly cause it was easier to read than other longer/older threads) thanks a lot

1 Like