MineOS won't run FTB but runs Vanilla

Hello all, I’m looking for some help getting a FTB server up and running on my FREENAS 9.10 box, I am using MineOS plugin v9.3.5.

I am able to download a vanilla profile, create a server and get it running no problems, I have tried using several FTB servers but for ease of explanation I’ll stick to the one I actually want to use which is “FTB Presents Direwolf20 1.10 (mc: 1.10.2)”

The problem is the Server status after clicking “Start Server” on server status page indicates “UP” for about 5 seconds then goes back to “DOWN.” no log is generated on WebUi or in /var/minecraft/servers/dw20/logs. My server start settings are -Xmx 4096 Jararg nogui, but I have tried sever different ram combinations and removed the argument with no change.

I found this topic MineOS Server won’t stay “Up” for more than a few seconds, if at all, but the solution didn’t resolve my issue.

To summarise, I have downloaded the vanilla jar using # sh /FTBInstall.sh and have made the ServerStart.sh executable using # chmod a+x Serverstart.sh.

all ownership was correct # ls -l shows everything owned by mcserver with the curious exception of eula.text file which is owned by root which I changed using chown -R.

To eliminate a bad .zip I transferred to a win10 machine and it ran first time. I also tried different profiles such as 1.7.10 and 1.6.4 ftb packs but all are same, vanilla works fime but ftb doesn’t.

I attempted to run server from shell, I’m not sure if it is able to work this way but # ./ServerStart.sh just says java : not found. none of the other topics I’ve read have mentioned needing to install Java manually, does this need to be done?

Since vanilla runs permissions within my freenas jail don’t seem to be the issue but without a generated log I’m not really sure where to start looking, any help would be greatly appreciated as my very limited admin skills have been exhausted.

Thanks in advance

update, I have wiped everything and tried again to see if it was any of the various things I’d read elsewhere re: user permissions, storage ownership etc. The result is the same except I now have some logs in server dir. None of it makes any sense to me, it says something about a forge mod loader error but again, it is beyond my level to troubleshoot.


Unfortunately, I don’t know FTB or modding very well, but very likely the best way to approach this is to remove mods systematically until it does work, or to remove all mods and to add them systematically until it breaks.

hi Brky,

i hope you are still trying and did not give up.

looking at your logs, i see:

Java is OpenJDK 64-Bit Server VM, version 1.7.0_76, running on FreeBSD:amd64:10.3-RELEASE, installed at /usr/pbi/mineos-amd64/openjdk7/jre

please update to java 8. it is my understanding forge requires java 8 for 1.10.2.

another thing to try on your server is build a new 1.10.2 vanilla server and start it. stop it and then use MineOS to manually install the forge-1.10.2- to /var/games/minecraft/servers/dw20/ (or forge flavor of your choice, d/l direct from forge and SFTP copy to the server root folder logged in as mc). this will install everything required to run the server correctly. simply select it in your java settings. MineOS does the rest and shuts down the server, then select the new newly installed forge you find in java settings drop down and start the server. if you do not see it at first then log out and log back in.

this establishes you can run a forge server on your setup. FTB does things a little differently server side so to proceed, i would use the FTB Launcher (client) to d/l the desired server files (FTB Presents Direwolf20 1.10 (mc: 1.10.2) to do this, start the FTB launcher and locate the d/l server function, save the files to hard drive, locate the mods folder in your d/l and SFTP copy to your servers mods folder. attempt to start the server. if it did not crash, you have a choice to make how to proceed form here.

use a vanilla minecraft launcher (like teamextream) and build your own forge launcher with all the direwolf mods to use as a client by using forge-1.10.2- and copy the mods to the mods folder at appdata/roaming/.minecraft/mods.

OR move on to SFTP u/l the rest of the FTB Direwolf files to your server, make sure all are in the correct location,again logged in as mc and then you can use the FTB Launcher.

if after trying to start your server again, if it fails post your new logs here for further help.

if it all works then move on to getting your custom launcher (or FTB Launcher) logged on. that can be tricky as well :wink: either way you should now know how to build you own forge server with any combination of mods installed. getting them to work together is a different story.

good luck!


Can confirm that the mod pack runs fine using Java 1.8 - just tried it and the server stays up and I can connect to it.

I am away at the moment for the holidays but this sound promising. I will attempt to remote in and do this as it seems rather a simple fix.

I am familiar with manually compiling mods on top of vanilla . I use to do it back in MC 1.4 before I discovered forge so I guess that is always an option.

Thanks for the help, I will post back the results


Hi again, Finally home and able to follow the above steps.

I have update to openJDK8 and initially it didn’t work, so I exported the jdk8 dir to /bin of mineos jail, restarted and everything is up and working.

Not sure if that was what you meant for me to do but results are results :slight_smile: all that’s left now is for me to sftp my config and world files over from my win10 machine.

Thanks to tNt and Dermot for the help. much appreciated

1 Like