What's going on here?

So I’ve noticed twice now that there have been half a dozen log entries in the WebUI for the latest MineOS that look like this:

[23:11:01] [Server thread/INFO]: com.mojang.authlib.GameProfile@3efb0b48[id=,name=hhjabris,properties={},legacy=false] (/ lost connection: Disconnected

I’ve got two instances of half a dozen of these attempts. I’ve got a whitelist set up (with the intention that this is a private server) and I don’t think the entity has been able to actually log in, but is this a failed login attempt, or what?

That looks like an error that pops up when the connection between your minecraftserver and mojangs login server fails.

If you run with your server in online mode (recommended) your server connects to mojang to check if the user that tries to log on has a valid mojang account (AKA: actually bought or otherwise legally procured a minecraft license). If the connection to this server fails I would expect to see this error. But I would also expect to hear from my users that they cannot log on to your server.

Reasons for this error can be:

  • local network errors (did you have problems with your internet connection?)
  • Mojang did some work, or had problems with their servers
  • Mojang had problems with the network connection to their server.

If this error persists we wil help you troubleshoot as far as we can, but for now it looks like an error that is out of your (and MineOS’s) controll.

I got one very strange one too:

[Steve/WARN]: Couldn’t look up profile properties for com.mojang.authlib.GameProfile@48771623[id=53909932-f794-33c0-9329-948045a4c1ce,name=steve,properties={},legacy=false]
com.mojang.authlib.exceptions.AuthenticationUnavailableException: Cannot contact authentication server
at com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService.makeRequest(YggdrasilAuthenticationService.java:71) ~[minecraft_server.1.7.10.jar:?]
at com.mojang.authlib.yggdrasil.YggdrasilMinecraftSessionService.fillProfileProperties(YggdrasilMinecraftSessionService.java:135) [minecraft_server.1.7.10.jar:?]
at ganymedes01.headcrumbs.network.packet.TextureRequestPacket$1.run(TextureRequestPacket.java:55) [TextureRequestPacket$1.class:?]
at java.lang.Thread.run(Thread.java:745) [?:1.8.0_72-internal]
Caused by: java.net.UnknownHostException: sessionserver.mojang.com
at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184) ~[?:1.8.0_72-internal]
at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392) ~[?:1.8.0_72-internal]
at java.net.Socket.connect(Socket.java:589) ~[?:1.8.0_72-internal]
at sun.security.ssl.SSLSocketImpl.connect(SSLSocketImpl.java:668) ~[?:1.8.0_72-internal]
at sun.net.NetworkClient.doConnect(NetworkClient.java:175) ~[?:1.8.0_72-internal]
at sun.net.www.http.HttpClient.openServer(HttpClient.java:432) ~[?:1.8.0_72-internal]
at sun.net.www.http.HttpClient.openServer(HttpClient.java:527) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.https.HttpsClient.(HttpsClient.java:264) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.https.HttpsClient.New(HttpsClient.java:367) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.getNewHttpClient(AbstractDelegateHttpsURLConnection.java:191) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection.plainConnect0(HttpURLConnection.java:1148) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:989) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection$6.run(HttpURLConnection.java:987) ~[?:1.8.0_72-internal]
at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_72-internal]
at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection.plainConnect(HttpURLConnection.java:986) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.https.AbstractDelegateHttpsURLConnection.connect(AbstractDelegateHttpsURLConnection.java:177) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection.getInputStream0(HttpURLConnection.java:1513) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection.access$200(HttpURLConnection.java:90) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1433) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection$9.run(HttpURLConnection.java:1431) ~[?:1.8.0_72-internal]
at java.security.AccessController.doPrivileged(Native Method) ~[?:1.8.0_72-internal]
at java.security.AccessController.doPrivilegedWithCombiner(AccessController.java:782) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.http.HttpURLConnection.getInputStream(HttpURLConnection.java:1430) ~[?:1.8.0_72-internal]
at sun.net.www.protocol.https.HttpsURLConnectionImpl.getInputStream(HttpsURLConnectionImpl.java:254) ~[?:1.8.0_72-internal]
at com.mojang.authlib.HttpAuthenticationService.performGetRequest(HttpAuthenticationService.java:126) ~[minecraft_server.1.7.10.jar:?]
at com.mojang.authlib.yggdrasil.YggdrasilAuthenticationService.makeRequest(YggdrasilAuthenticationService.java:54) ~[minecraft_server.1.7.10.jar:?]

All those are errors about connection to Mojang Servers.
For now I assume that it is Mojang that has an error somewhere, and MineOS / Minecraft servers are just reporting their failure to connect to the servers.

You can check the status of Mojangs services on this page:
just bear in mind that this is not a fault proof method, since it is based on an external service provided by someone else than Mojang.
(BTW: @hexparrot: Would it be possible to somehow implement or include that service in MineOS? the developer of mcstatus has a git page with source code…)

Another thing is that this is not something reportedby MineOs per se, but by the minecraft servers them selves. This makes it a hard fault to do something about since we are dependant on the developers of the different minecraft server versions to actually do something about it

Thanks, iMelsom.

I look at that and begin thinking “someone with the nick ‘Steve’ tried to log in to my server.”

Then I wonder how because the server is behind two routers with hardware firewalls. No way anyone could connect to it unless I let them.

That said I have no doubt I can be hacked. Anyone can, lol.

My girls use queen elsa and princess anna as their user names,ROTFL! steve…

Steve is the default minecraft nickname (and the “true” name of the minecraft character you play). So if someone tred to log on with a client where they hadn’t changed the nickname yet, you would se the name “Steve”.

Thanks for your response. Sorry for the 2 week delay in getting back.

Alright - I appreciate that it may be an error connecting to Mojang’s authorization servers, and I appreciate that suggestion, but my issue is that I don’t want the user mentioned to be able to connect, as the server I’m running is private and has an unpublished IP.

I suppose my question might be outside the MineOS realm per se, but I’m looking for ways to prohibit users from connecting prior to relying on the whitelist, which I also use…

Edit: adding some more info, I was thinking for a second that I could maybe use MAC filtering but I realize now that only works to allow certain users on the same LAN to have access to certain other devices. This might be more an issue of networking in general, but I’m wondering if MineOS users have done this already I suppose.

Good reading to be had here: [Tutorial] Two ways to better secure your server

Good Luck!

HI, tNt, thanks for that link! I’ll pour over it! Cheers!

the way i solved this issue is to make the other user download JAVA. and they could join. i know im a genius

MineOS that look like this:
C:\Users\LI\OneDrive\Desktop>cd “C:\Users\LI\OneDrive\Documents\Minecraft Server”

C:\Users\LI\OneDrive\Documents\Minecraft Server>java -Xmx1024M -Xms1024M -jar server.jar nogui
[10:05:01] [main/INFO]: Environment: authHost=‘https://authserver.mojang.com’, accountsHost=‘https://api.mojang.com’, sessionHost=‘https://sessionserver.mojang.com’, servicesHost=‘https://api.minecraftservices.com’, name=‘PROD’
[10:05:03] [main/WARN]: Ambiguity between arguments [teleport, destination] and [teleport, targets] with inputs: [Player, 0123, @e, dd12be42-52a9-4a91-a8a1-11c01849e498]
[10:05:03] [main/WARN]: Ambiguity between arguments [teleport, location] and [teleport, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[10:05:03] [main/WARN]: Ambiguity between arguments [teleport, location] and [teleport, targets] with inputs: [0.1 -0.5 .9, 0 0 0]
[10:05:03] [main/WARN]: Ambiguity between arguments [teleport, targets] and [teleport, destination] with inputs: [Player, 0123, dd12be42-52a9-4a91-a8a1-11c01849e498]
[10:05:03] [main/WARN]: Ambiguity between arguments [teleport, targets, location] and [teleport, targets, destination] with inputs: [0.1 -0.5 .9, 0 0 0]
[10:05:03] [main/INFO]: Reloading ResourceManager: Default
[10:05:04] [Worker-Main-4/INFO]: Loaded 7 recipes
[10:05:05] [Worker-Main-4/INFO]: Loaded 927 advancements
[10:05:08] [Server thread/INFO]: Starting minecraft server version 1.16.5
[10:05:08] [Server thread/INFO]: Loading properties
[10:05:08] [Server thread/INFO]: Default game type: SURVIVAL
[10:05:08] [Server thread/INFO]: Generating keypair
[10:05:08] [Server thread/INFO]: Starting Minecraft server on *:25565
[10:05:08] [Server thread/INFO]: Using default channel type
[10:05:10] [Server thread/INFO]: Preparing level “world”
[10:05:10] [Server thread/INFO]: Preparing start region for dimension minecraft:overworld
[10:05:13] [Server thread/INFO]: Preparing spawn area: 0%
[10:05:13] [Server thread/INFO]: Preparing spawn area: 0%
[10:05:13] [Server thread/INFO]: Preparing spawn area: 0%
[10:05:13] [Server thread/INFO]: Preparing spawn area: 0%
[10:05:13] [Server thread/INFO]: Preparing spawn area: 0%
[10:05:13] [Server thread/INFO]: Preparing spawn area: 0%
[10:05:14] [Server thread/INFO]: Preparing spawn area: 0%
[10:05:14] [Server thread/INFO]: Preparing spawn area: 0%
[10:05:14] [Server thread/INFO]: Preparing spawn area: 47%
[10:05:16] [Server thread/INFO]: Time elapsed: 5837 ms
[10:05:16] [Server thread/INFO]: Done (6.031s)! For help, type “help”
[10:05:18] [Server thread/WARN]: Can’t keep up! Is the server overloaded? Running 2164ms or 43 ticks behind
[10:07:07] [Server thread/INFO]: com.mojang.authlib.GameProfile@7885d506[id=,name=isaacliyw,properties={},legacy=false] (/ lost connection: Disconnected

MineOS that look like this:
C:\Users\LI\OneDrive\Desktop>cd “C:\Users\LI\OneDrive\Documents\Minecraft Server”

This doesn’t look much like Mineos, since it appears to be a Windows filesystem, and one also on OneDrive.

[10:05:18] [Server thread/WARN]: Can’t keep up! Is the server overloaded? Running 2164ms or 43 ticks behind

Your computer is too slow for the Minecraft server or your hosting Minecraft from a OneDrive link is preventing usable speeds.

You’re not using MineOS, but we’re generally able to help with Minecraft problems. Don’t be afraid to open up your own thread instead of using anothers’, as your issue is likely quite different.