WebUI won't start a 1.13 server

The MineOS log will not show more just after recieving a “start”. “mineos.log” is the log for operations MineOS or the administrator does.

You should see the server badge go from a red “down” to a green “up” in the WebUI, and you should see the start minecraft server logsappear at the bottomof the menu panel inthe WebUI.

The minecraft server log containing the operations and events for the minecraft server is placed in /var/games/minecraft/servers/[server name]/logs/latest.log

If it was the first run of a new server you should have seen a line like this in “mineos.log” though:

{"level":"info","message":"[[server name]] transmittting existing file contents: logs/latest.log (680 bytes)","timestamp":"2018-08-01T06:05:52.219Z"}

Actually after a first run you should see this:

{"level":"info","message":"[est344] received request \"start\"","timestamp":"2018-08-01T06:23:41.115Z"}
{"level":"info","message":"[est344] latest.log created! Watchfile logs/latest.log closed","timestamp":"2018-08-01T06:23:43.485Z"}
{"level":"info","message":"[est344] Created tail on logs/latest.log","timestamp":"2018-08-01T06:23:43.485Z"}

You’ll only see the “start” line and nothing else after it when the log already exists.

Jarfiles aren’t executables–they’re actually pretty much just zip files that have certain files within, like Java manifests and other things that make it a jar file.

That said, when you were doing things like chmodding, we’re you doing it as root or as mc?

Your earlier screenshot shows root for ls and such (safe things), but doing things as root risks that root will take ownership of files for some other actions, and in any case, root should never be the owner of server files.

So, as root let’s try ensuring some things are back to their expected state:

chown -R mc:mc /var/games/minecraft/servers/LeHome
chown -R mc:mc /var/games/minecraft/archive/LeHome
chown -R mc:mc /var/games/minecraft/backup/LeHome
su - mc
cd /var/games/minecraft/servers/LeHome
java -jar minecraft_server.1.13.jar

This should start up the server. Not in the ideal way, but we’ll shut it down once we know it works, then we can go the next step to make sure it can all be done in the webui.



I don’t have a “/var/games/minecraft/servers/[server name]/logs/latest.log” folder because minecraft hasn’t successfully launched


I gotta say, I have very basic linux knowledge and im running out of the box. I googled “Unsupported major.minor version 52.0” and it says there is a version conflict.


I’m not sure why I am having so many issues with this and it’s really getting frustrating. I am running it in VMware because I couldn’t even get it working running through VirtualBox.

MineOS is supposed to be the easier solution and I really really like the webgui but I feel defeated. I’ve spent days now following instructions and googling stuff. I am sure im doing something wrong but at this point I don’t see how i’m going to be able to get this to work.

If it’s an issue with Minecraft and not MineOS, so be it; however, again, running out of the box and other people can get it working and I don’t understand what’s going on or why it just isn’t working for me.

It seems like your Java version is out of date.

Using the prebuilt ISO’s is not a failsafe to get the latest build of anything. It is a build from the time the ISO was compiled. made so it is easier to get into MineOS. Much like when you install windows, there is usually updates to install after installing the OS is done. This is why I usually forgo the ISO’s when I install, and go the ubuntu server way, then install the MineOS scripts on top of that. I get a newer install, but also a whole set of new problems, and the option to install things as I like them.

For MineOS this includes udates to the OS, and to requrired system software like Java and NodeJS

Updating java can be done by following this page:

For now you should try only updating java, but at some point you should also update your system:
Most updates can be done by following the instructions on this page:

I’d also like to remind you about this pinned forum post: Basic skills and interests you’ll need to be a MineOS admin

(Oh and if you think getting your minecraft server running puts you in the clear? Mojang currently has this nasty bug that crashes your server if a player is in the wrong area: https://bugs.mojang.com/browse/MC-131071. I have had to manually edit player files to make them start in “spawn” again when they log on since the server autocrashed when he tried to log in while he was in the affected areas. So be prepared for new and facinating ways to be frustrated)

Hey, I’m really sorry you’re running into all these issues. I don’t know what to say–I’ve never seen such issues crop up before, so this is all fairly new to me as well.

Can you refer me to what URL you used to download MineOS? I definitely want to check all ISO URLs out there because all versions of MineOS that should exist should have Java 8: the error you’re getting (from my googling) appears to only exist on Java 7. None of my ISOs (or at least, none of my Node.JS ISOs) should be coming with that outdated version anymore.

According to this SO page, this means that the Jar you’re trying to run (1.13) requires Java 8. You’re somehow on Java 7, hence the problem.

So a few things:

  1. you should be able to run a 1.12.2 server right now. It should work, no question right now.

  2. you’d need Java8 to run 1.13; we know this is actually a Minecraft requirement, so finding out why you don’t have Java8 instead of Java7 would be key.

  3. This was installed from an ISO, correct, and not a manual install? If it’s from a manual install, it was probably a repository command missed, and the solution is easy. If it’s from an ISO, you’re using an old ISO and a new one will fix it (and I need to identify it so I can put it out of circulation).

Again, sorry for all the problems. I really recommend you try out #1 just so you can see a semblance of progress. I really think getting the 1.13 fixed after that should take minutes rather than days after that.

1 Like

you should be able to run a 1.12.2 server right now. It should work, no question right now.

Family wants 1.13 :slight_smile:
Looks like MineOS isn’t for me!

you’d need Java8 to run 1.13; we know this is actually a Minecraft requirement, so finding out why you don’t have Java8 instead of Java7 would be key.

Any idea why 1.13 is an option availble through MineOS but Java 8 isn’t installed out of the box? “Hey, try this option you can’t run! Good luck!”

Also, I’ve been trying to install java 8 since i saw this msg and i just get error after error trying to get it installed. “Oracle-Java8-Installer No installation candidate” can’t get it fixed. Giving up.

you’d need Java8 to run 1.13; we know this is actually a Minecraft requirement, so finding out why you don’t have Java8 instead of Java7 would be key.

I don’t have java 8 installed because the iso i downloaded didn’t hvae it installed by default:
I downloaded it from here: https://minecraft.codeemo.com/mineoswiki/index.php?title=Main_Page
Pre-configured ISOs --> “Current 64-bit ISO download” link

So, is it now an issue of me not getting the right “current” file?

Thanks guys for your assistance but I’m just giving up. I wanted something quick, easy, and something even a n00b like me can run but I didn’t get what’s advertised. Thanks again!

Hey, sorry to hear it didn’t work out for you.

Definitely double-checked the Java version:

openjdk version "1.8.0_171"

came from here:

Current 64-bit ISO download, based on Debian “Jessie” (~400MB). This is the recommended download! It comes with OpenJDK8 right out of the box.

Best guess is you inadvertently got the link below it:

Also available are the previous ISOs, based on the Debian “Wheezy” LTS release, which comes with OpenJDK7.

Perhaps it’s ill-placed there, but the URL behind the “Jessie ~400MB” version is 100% working out of box with Java8.

Again, sorry we couldn’t get it up and working as advertised.

I had this same problem too but fixed it by downloading the official 1.13 server jar from mojang and replacing it with the jar that I downloaded with the web ui.

1 Like

Chowfatfat’s fix worked for me. I replaced my server and decided to start with a clean new MineOS VM. 1.12 servers worked just fine out of the box but 1.13 and 1.13.1 servers would not start. I had to download the official server and replace the ones in the appropriate /profile server version folders. I realize this was older thread but could still potentially cause a significant hang up for new adopters of MineOS.

Updating the Webui is and has been the fix for MineOS with Minecraft 1.13/1.13.X Server jars for the longest actually, since July.

Many of you have noticed Minecraft no longer launching vanilla version 1.13 since it has released. This is because Mojang has changed their URL pattern they have historically kept for many, many releases.


This URL used to work, for pretty much every modern version since their 1.0 release. The pattern still downloads something–in this case it’s XML for an error message. It says ‘downloaded’ because there is, in fact, a file called minecraft_server.1.13.jar, it’s just that it contains no usable game code. Here’s what the URL might potentially could have changed to:


That is, not a dependable, versioned URL, but instead a URL that could have a long SHA5 or other checksum in the URL itself.

If you want to play Minecraft 1.13, you still can, you just have to download the file manually and place it in your server’s live directory (/var/games/minecraft/servers/[myserver]).

Alternatively, you can instead replace the dummy file that exists in /var/games/minecraft/profiles/1.13 so you can continue to use the profile as normal. (this would be preferred, really). Be sure to re-copy over the new jarfile by clicking “copy profile to live server files” after doing this overwrite, too.

I’ll try to look into this further to find out a way to programmatically download this server jar without really sloppy code, but at some point it’s just them making things needlessly complicated just so we can race after them.

You just update, followed by redownloading (click on download again to properly download and overwrite what ever had been downloaded already before previously) and then proceed on as normal copying to server or using for server.

1 Like

Hey Dustin! I would love to reconnect with you! You probably don’t remember me, but my discord is Bradydawg#0001, I’d love it if you added me.