Webui loads then pauses


#1

Not sure what happened was working great, a few days ago I setup dynmap been working fine for a few days then last night Webui will load then pause. I can change to different server status pages but nothing executes stop, start, archives, pruning restore points. Also 3 of my servers are not in the list. I updated Webui, I tried in Chrome, Firefox and Edge, they all do the same thing. Webui version b28c5be


#2

Please log into your MineOS server with SSH then run the “top” command to see if any processes are eating up all your resources.

How is you rmemory configuration? Are your minecraft servers set up to use all of the available memory for your MineOS server? You need to make sure the underlaying OS has some memory spare for system tasks, so never give out all memory.

Also make sure that your minecraft servers do not try to use more memry in totalt than are physically available.

F.Eks: If you rserver has 4GB installed RAM, and you wish to run MineOS and three servers I would say that you could use somewhere between 3 and 3.5 GB in total for Minecraft servers. . This would mean that you could run (f.ex) thre minecraft servers with1 GB memory available each (3x1GB/Server = 3GB).

Your servers will seldom use all available memory, but if they do, and try to address more memory than are physically avilable, java tends to behave unpredicatbly. Sofor thie example server with 4GB available, Setting f.ex. 2GB available to each server would give a total of 6GB. Your minecraft servers will try to use 2 GB each, and when 4 GB (the physically installed size) is reached the sytem has no more to offer, and has nothing reserved for itself, with java trying to use even more.

Maprenderers use a lot of proecssing power, and memory, to make all the image tiles that make up the web-map. So while the world is rendered your server will use resources to do so. This is why I have a setup where MineOS only handles minecraft servers, a web-server that serves up webpages (and the rendered map), and a separate machine inbetween that renders the map from my MineOS installation to my WebServer installation. (https://overviewer.org/). I also only render my world maps once every 24 hours, at nighttime when there is less users on my servers, and only one minecraftserver at a time.


#3

wish I could, I can’t log into server using putty for some reason, I can log in using WinSCP.

I have 32GB Ram and total of all servers set up to use max 29GB most of the time it uses about 12GB

the 2 days it was doing a full render had no issues, just a little laggy, once the full render was done server was almost back to normal but no one could notice the slight performance slow down due to dynmap. this issue started after I attempted to roll back a area that I deleted the .mcs file to update the section of the map to 1.13.2. almost crashed server. won’t do that again, after that I Webui started to not work


#4

Any way you can log into the console is OK , Putty is just the most used software ;D


#5

If you can log in using WinSCP you definitely should be able to also use PuTTY as they both use the same protocols and ports, one just handles files while the other commandline. But, you should also be able to physically login to the system locally on the system itself. If you used the official MineOS Turnkey distro the way you do so is with [ALT]+[F1] keys pushed at the same time (…well actually this also applies to other distros such as Ubuntu, Debian, and quite possibly every other distro…), and you should get a login prompt. If not, hit enter and one should appear. Login using the same credentials you would when using WinSCP and from there you’ll be able to follow @iMelsom’s steps.

One thing I would advise however is to temporarily stop the web ui from running or to temporarily disable it from starting up with the OS (or both) for the time being, if the system is feeling a bit sluggish. Doing so will allow you to have nothing running other than OS essentials and should feel a lot snappier if your current configuration eats up all your system’s resources (or a majority of it with not really much for the core system itself to run with).

Another thing, this is kind of a known problem when using Dynmap, and you may want to see this which may be of assistance with dealing with/solving it: Potential MineOS Web UI Lag Fix for Dynmap users


#6

Putty worked last night at home, just not working at work right now


#7

Ensure the settings used are correct? Such as protocol being SSH, port 22, hostname/ip matching the one you have in WinSCP, I mean I don’t think there’s a way to have WinSCP work but not PuTTY, though I could always be wrong about that but logically with the way it works I don’t think there’s a way unless neither of them work.

There’s actually a PuTTY button in WinSCP where if you have both WinSCP and PuTTY installed (not portable versions, unless both their executables are in the same location) you can click that button and it opens a PuTTY window with the same connection information WinSCP is using as well as username and PuTTY just prompts you for your password to continue.


#8

I have winscp using a different port then putty. Also if I use mySQL is that better then sqlite for dynmap


#9

well the putty issue must be a port since I used same one as winSCP I was able to log in

top - 13:25:47 up 13:35, 1 user, load average: 0.74, 0.85, 0.86
Tasks: 117 total, 1 running, 116 sleeping, 0 stopped, 0 zombie
%Cpu(s): 18.4 us, 3.2 sy, 0.0 ni, 78.4 id, 0.0 wa, 0.0 hi, 0.1 si, 0.0 st
KiB Mem: 32879036 total, 29881920 used, 2997116 free, 326200 buffers
KiB Swap: 33412092 total, 40952 used, 33371140 free, 10360196 cached


#10

Well personally I’ve not tested MySQL vs SQlite, however I do know that SQlite is file based as in it consists of a single file on your drive, which also makes it really portable since you can pretty much just move it around anywhere anytime pretty freely just like any other file; it’s also a lot faster, easier, and less complicated to get set up to work/use with Dynmap, especially since Dynmap does all that for you. Anything beyond that I probably wouldn’t be able to answer without doing deeper research into it. I guess one advantage of MySQL is you can have it on a completely separate system (though it’s just a database so it wouldn’t really make all that much of a difference when it comes to Dynmap, and you can also store SQlite files elsewhere as well and just symbolically link to it, which negates that advantage).


#11

well I’m testing dynmap on mysql, it’s doing a full render now I have noticed it took about 7 mins to do a reboot of the server. last time Webui glitched like this I had corrupt server files. just need command lines to make current archive so I can delete this one and replace it with archive


#12

#13

been reading that and I get no such file or folder, logged in as root

./mineos_console.js -s vanilla start
./mineos_console.js -s vanilla stop


#14

Well I’m not sure if you should be logged in as root for this but reason why you get no such file or folder is because it does not exist in your current folder; “./” signifies something in the current directory. MineOS scripts are installed to /usr/games/minecraft and should be in there, then those commands should work. You can either cd to the directory or point to it directly from whatever directory you’re currently in.


#15

it works as root as long as I’m in the correct directory, Thanks


#16

I would therefore expect issues to arise if you intend to do things as your non-root user, such as mc.

Starting a server, stopping, committing files to disk–as root make those files owned by root. Further attempts to then access/modify those files as MineOS does (as not root) will fail due to normal linux permissions.

I recommend against doing things that are server-related as root, and would specifically recommend that you chown -R your servers back to the expected user ownership.


#17

don’t think I changed ownership I was just stopping and start the servers till I figured out how to fix webui


#18

After changing dynmap to store it’s data via mySQL and deleting the old data files, Webui seems to be more responsive, but still stops loading. when logged in with putty I run stop commands I get this message. Earlier I was able to run that command but I was logged as root, and was told I should not use that user to control the servers.

mc@core games/minecraft$ ./mineos_console.js -s survival stop
[survival] Error executing “stop” because server condition not met: exists


#19

Sounds like this is the case here.


#20

I read wrong the first time I will try my best to figure out the exact command, Thanks