Webui loads then pauses


#21

chown -R mc:mc /var/games/minecraft/servers/[myservername]


#22

ok that fixed the command line issue, Webui is still not completely loading, I see most of my servers but can’t control anything from panel. Last time I had this issue I believe I made current archive and delete current server then made new server. I wish I didn’t lose my notes on the commands and how it was done


#23

Everything I have done has failed to repair Webui. Is there another way to make restore points and run them, also archives till I figure out whats wrong. My servers keep starting themselves back up after I run stop command -s servername stop, not sure why or how to stop them from starting back up while I’m trying to re-create them


#24

Can you provide the contents of the MineOS log file at /var/log/mineos.log?

MineOS has a ‘start up at boot-time’ option, but the ‘stopping’ functionality doesn’t have any restart ability, so them just ‘starting themselves up again’ definitely shouldn’t be happening–not even sure how it could.


#26

I guess I should be deleting that log more often it’s 127MB do you want the whole file


#27

Probably the last hundred lines or a bit more would do.

Realistically 1mb would usually do it…but I have no idea what could possibly have created 127 mb of log, so make sure that no matter how much you cut off, it has at least the last two “base_directory found in mineos.conf” lines.


#28

been about a year since I deleted the file
https://paste.extendedclip.com/futohebizi.json


#29

Sorry, I wasn’t clear.

I wanted to make sure you provided at least the last two startup attempts, but also in that include attempts to do the things you’re trying to do that are failing.


#30

startup of hardware ?


#31

well the log ever since June of last year has it starting every minute or so

https://paste.extendedclip.com/asahujozaq.json


#32

Ok, you’ll just have to use some of your own discretion here then.

I need more logs than you provided on either of these hastebins (second one was even shorter than the first).

I need to see logs that indicate errors for actions you’re attempting to perform. Neither of these are listing any attempts at doing things, such as backup or archive, and show the accompanying failures.


#33

found this stuff about the time I last rebooted the hardware, or at least about the time Webui stopped working

https://paste.extendedclip.com/ruqiqaqute.vbs


#34

Alright, let’s start this over:

None of the logs so far have shown your attempts to do backup/archive. Do this:

  1. delete /var/log/mineos.log
  2. restart the webui
  3. try backing up, archiving, and any other behaviors you want to test
  4. provide 100% of the newly-produced log.

#35

other then going home to reboot hardware, The command to stop Webui at command prompt is ?


#36

I don’t know what method you used to install MineOS, but every method has instructions for starting/stopping.

http://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS-node_(apt-get)#Starting.2FStopping_the_webui

That said, if everything went bad after DYNMAP, that’s probably the issue. The tens of thousands of files that dynmap may potentially create is likely the culprit. I really recommend you moving those files out of /var/games/minecraft (like to your /home). If the problem goes away, at least we know the cause.


#37

OK I have removed dynmap and reset webui and still will not work, so I started dynmap back up. I deleted old dynmap folder before i started it back up, now it uses mySQL no files keep in server folder all commands work in putty but webui stops responding after about a min

this is whole log

https://paste.extendedclip.com/orefosequf.json


#38

Did you also take a look at this portion of Potential MineOS Web UI Lag Fix for Dynmap users

If the sqlite db file is still in the server directory MineOS may still hang up on it due to it’s file size which is why having it outside of a watched/monitored MineOS directory would be best, like the one in that example.


#39

I don’t think Dynmap is my issue since Webui was working fine for 2 days after the full render, to top it off I have moved the files to mySQL so they are no longer stored in the server folder. I feel my issue has to do when I run a rollback by Core Protection on a chunk the was part of the .mca files I deleted from my region folder of the world. The Rollback went back before the I deleted the mca file. Guess that was not a good idea, but it was done, anyways it almost crashed server and that when I noticed Webui not working, that’s the reason I want to delete the server I feel is the issue, but I can’t figure out how to create a new server from an archive via command. Next I would need to delete the old server to see if I can get Webui to work again


#40

Well, in that case why not just export the current live server files (since creating an archive would just wrap those files up into a single file with compression anyways) and then zip them up locally? This way you’ll have no permission issues or anything like that (since you did use root) if it succeeds.