Web-UI update script returns an error

Hey all, when I try to update the Web-UI because of the “no internet connection” bug, it returns an error, this is after restarting multiple times and from a fresh install of MineOS. Any help would be appreciated!

If you need a Pastebin with the full logs I can provide it to you, but I just took a screenshot of the part that’s not identical to the rest AKA the end of the file.

When did you run the update scripts?
@hexparrot had recently added an updated:

Logging: Enhance log capabilities by adding elastisearch plugin to Winston

I don’t know if it’s related or not.

Try deleting the node_modules directory before the npm install command again.

Additionally, what distro and version are you running?

I’m crossin my thumbs it’s not related, but posix has been a thorn in a lot of installations, all over the place. I don’t think any of the other version bumps should impact this module’s ability to compile (we’ll see!)

The first time I clean installed I ran them immediately and something went wrong (I believe the same error occurred) and suddenly the images for copy, paste, cut, shutdown, restart, etc were showing up as a missing file image, so I clean installed again, waited until my HDD activety light on my case calmed down, then restarted, ran the script, error, restart and script again only for the same error to appear.

Where is the node_modules directory located? going into the “/” directory doesn’t show any directory of that name…

The distro I’m running is the @JayMontana36 Begginer-Friendly version " JM36-MineOS-GUI-64bit-16.04"

I also ran sudo apt-get upgrade before and after running the update script for the exact same error.

Try following the manual installation-on-distro guides, specifically the node dependencies section. I have still yet to create a newer version of this OS for one reason or another, but will get around to it sooner or later.

From https://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS-node_(apt-get%2Bsystemd) on 20200905@19:51UTC - Installing Dependencies, node 10.x, run as root (sudo -i)

curl -sL https://deb.nodesource.com/setup_10.x | bash -
apt-get -y install nodejs

You may instead have to do the following (or an adaptation of the following):

wget https://deb.nodesource.com/setup_10.x
chmod a+x ./setup_10.x
apt upgrade

If this problem is due to a NodeJS version mismatch (since there’s been several changes in versions made since the release of this OS, from v4 to v8 and now v10 I believe?) then this should solve that problem. You may also have to retry Updating the webui afterwards (either Updating or Resetting, I’d opt for Resetting).

So I seem to have somewhat found out what is wrong but I still have no solution.

By running

curl -sL https://deb.nodesource.com/setup_10.x | bash -
apt-get -y install nodejs

I get the same exact problem here:

This is before running the update scripts, so far all that I have done is run the installing node 10.x script and rebooted, also when I ran the installation script, it told me that curl was not installed so I installed curl and did the same command, no errors, outputs a success, reboot and I get the web-UI to respond twice then freezes.

bumping as i still have not found any solution