Users do not see servers in the Web-UI

We have had a problem for many months now where users can log into the Web-UI but cannot see any of the servers. The servers are owned by group mc, and the users are all part of that group. Unfortunately, the only way I can use the Web-UI is by logging in as mc. I hoped updating the Web-UI would help, but, while it did seem to update properly, we still have this problem.

I tried to do some research on this issue (like this thread I Need Help Letting Other Users Manage A Server ), but I didn’t come across any solutions. I would greatly appreciate any help with this.

You’ll need to provide some information that helps us reproduce the issue you’re getting or at least let us know what you have tried.

I have 100% confirmed just now that adding a supplementary group to a user allows that user to also control a server. I followed the steps:

useradd will
passwd will
usermod -a -G mc

This is on a MineOS Turnkey installation, but the distro is not important–MineOS will respect group membership the same on all Linux/BSD platforms.

How did you confirm the update went properly? While it is not likely the cause of the issue here, there shouldn’t really be any room for uncertainty. If you click your username in the top-right of the webui, it will definitively tell you what version of the webui you’re on.

Can you provide the output to the groups command for your mc user and your other user?

root@core games/minecraft# groups will
will : will mc
root@core games/minecraft# groups mc
mc : mc

For the most directed help, let us know what distro you’re using, too.

1 Like

Thank you very much for your thorough reply.

This is a bit embarrassing, but I just created a user, following your steps, and it worked perfectly:

root@core ~# useradd workinguser
root@core ~# passwd workinguser
root@core ~# usermod -a -G mc workinguser
root@core ~# groups workinguser
workinguser : workinguser mc

I was able to log into the Web-UI as workinguser and see the servers without a problem.

My previous users do not show servers in the UI and returned:

root@core ~# groups apparition
apparition : mc

I think the problem is that I had always been setting mc as a primary group for users instead of as a supplementary group. And I didn’t realize the difference was significant until now. I’m sorry for the inconvenience; admittedly, I am rather inexperienced with Linux. Thank you again for helping us fix a problem that has gone on for months.

(Even though it’s fixed, just to answer your questions, I only assumed the update worked because I had no problems when logged on as “mc”. The version is git commit: cbe2541. As apparition, I was unable to see the servers nor the Web-UI’s version number. We’re using MineOS Turnkey.)

1 Like