I Need Help Letting Other Users Manage A Server

Hey guys! So I want to let another user, that i made in the turnkey webui, manage my server but when i add that user to my group, the server doesnt show up for them.

Thanks In Advance!

First thing to do is restart the webui (kill the webui process, restart the server, etc.). Upon startup, the webui caches all the user/group affiliations. Groups added to users won’t be acknowledged or usable until the webui restarts.

If that doesn’t work, can you describe in greater detail how you’ve set up your users or how I might reproduce this issue?

Would adding users to the mc account’s group then rebooting the whole pc work? Because i have tried that but it didn’t work

Yes, but I’m worried it’s more the execution of the steps rather than what you’re aiming to do. Since you have to do this in command line, you can provide to me how you’re doing it, or let me know the contents of your /etc/{group,passwd} files (privately, e.g., through email). Neither of these files contain the actual passwords or anything that could be used to gain access, but it would indicate to whether or not your steps to add groups to members actually worked.

For starters, here’s how you can list group affiliations:

root@willonubuntu:/etc# groups will
will : will adm cdrom sudo dip plugdev lpadmin sambashare

Well actually i was managing the groups and users through the turnkey webmin. If it isnt possible through there, could you point me to a good tutorial to do it?

Nope, it’s definitely possible. Any way that you can create users and assign groups is valid–but all that matters is after you make/assign them, you restart the webui.

So would restarting the webui include rebooting the system or do i have to use a command to restart the webui alone? If so, can i get a command to use to do it ?