Upgrading from Debian "Wheezy" to debian "Jessie" help

Forgive the total noobness here I play minecraft from a server that was set up with what I believe it the “wheezy” ISO from this link. http://minecraft.codeemo.com/mineoswiki/index.php?title=Main_Page

A friend set the server up for me and taught me how to use the webui to maintain the servers with the mc account. In attempting to upgrade to the latest version 1.12 in the webui i noticed the server wont start so I found this thread. [SOLVED] Newbie: Can't install 1.12 update and I think I understand what needs to be done but not sure how to go about it. I might be at a dead end.

If I understood everything correctly I need to be using the “jessie” ISO turnkey to support jdk8 to get the 1.12 server running. However when I connect to the server via winscp and try running the git fetch it says that it is denied. So I realize I need to log in as root but winscp doesn’t allow that without modifying some files I can’t modify unless I am root. I don’t have direct access to the server as my friend is on vacation for the next 3 weeks.

is there anything I can do remotely to upgrade to support jdk8 that I am missing? Or will I need to wait until he gets back to have root access to upgrade?

Forgive the total noobness here I have never messed with servers/linux based stuff ever.

Several different items to point out:

  1. though you’re using Wheezy, you do not need to use Jessie in order to get JDK8. Using Jessie would mean a clean install of your entire OS, which is not likely what you want to do (even though it is one possible path)
  2. logging in as root is an easy configuration change.
  3. JDK8 can be installed via a “backport” repository–an official repo

Putting it all together:

You needn’t worry about the Jessie ISO; so long as you have the ability to get to root (first log in as the mc user, then type su -, which will prompt you for the root password to elevate).

From there, attach the Jessie backport repository and install Java8. While root, you can also update the webui, if you choose.

Thanks for the reply! I have been going in circles for the last 3 or so hours. Hopefully I don’t have to inconvenience you to much sense I know this information is out there and is probably beating a dead horse.

So I connect to the server using winscp as mc, where do i type su - ? I am assuming into the terminal right? and that shouldn’t matter which directory I am in (again total noob here). When I do that in the terminal it just says “must be run from a terminal” even though I opened the terminal.

I followed the configuration change link you provided which I had found yesterday and when I attempt to change the “PermitRootLogin no” to yes it says I don’t have permissions to do so and I can attempt to delete and recreate the file or abort. I haven’t tried the recreate option as I don’t want to screw something up.

So I think my main problem and concern here is being able to act as a root, hopefully I can figure out the rest after that.

You will type su - from terminal, not from winscp.

One is a file transfer tool (winscp) and the other is the command prompt (putty). Provided you know the root password, you will first log in as mc–, then when successfully logged in, su -. Here, as root, you can make the changes to the SSHD configuration (or skip it if you choose), and go right to installing JDK8 & updating the webui.

oh that makes sense, I will try that when I get home from work in 6ish hours. I think I should be able to figure it out now! I will reply here either way so you know the outcome. Is there anywhere to donate with bitcoin? I would like to give back for the excellent work.

Sure is! Scroll to the very bottom of the MineOS page.

Perfect! Problem solved. Not sure why but I had to use

su -
echo “deb http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main” | tee /etc/apt/sources.list.d/webupd8team-java.list
echo “deb-src http://ppa.launchpad.net/webupd8team/java/ubuntu xenial main” | tee -a /etc/apt/sources.list.d/webupd8team-java.list
apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys EEA14886
apt-get update
apt-get install oracle-java8-installer
exit

to get it to install vs the instructions for debian in the link you provided. Not sure why but in case you wanted to know.

Thanks again.

Haven’t verified, but I see that you installed oracle-java8-installer, rather than openjdk-8-jre-headless. Both are Java 8, so it’s user’s choice, but in the spirit of Linux (and the legalities behind it!), I typically skew toward opensource.

Glad you got it working, and I hope this will help people in the future, thanks for providing your instructions!

That is a good point totally understandable. Now that I got things up and running I can go back and figure out how to uninstall the oracle and install the headless. When I attempted to install via the method in your link.

echo “deb http://http.debian.net/debian jessie-backports main” >> /etc/apt/sources.list
apt-get update

apt-get install -y -t jessie-backports openjdk-8-jre-headless ca-certificates-java

It was telling me I was missing a dependency or repository or something of that nature (maybe nodejs?) when i would attempt to install.
My first guess was that this was looking for what comes with the Jessie ISO and not the wheezy ISO. But in an attempt to figure if that was the case I discovered a thread where someone used the Oracle and resolved their problem so I just tried that.