[SOLVED] Newbie: Can't install 1.12 update

I’ve been running a server for a few weeks for my kids in a docker using the 1.11.2.jar and all was ok.

I’ve tried this week to change my two servers to the 1.12.jar update. I’ve created new Server Profiles and I’ve tried changing the server.config value to the new profile, but the servers won’t start.

Am I doing something fundamentally wrong?

Thanks in advance

1 Like

[details=Summary]the 1.12 update is not released from Mojang until tomorrow: http://minecraft.gamepedia.com/1.12[/details] <-- sorry. Im a bit tired. It was released yesterday

When it is released you use the “refresh profile list” choice in the user menu in the top right corner of your MineOS WebUI. After that you go to “Profiles” and press download on the fresh 1.12 profile. Then you go the server you wish to upgrade and choose the correct profile in the apropriate pulldown menu. Remember to pick the right jar-file in the jar-pulldown menu as well.

To clarify, did you create a new profile or download a new profile–or more to the point, do you know if you’re using the Python webui or the NodeJS webui?

I am having the same issue, and it appears to be specific to the 1.12 jar. I am using a couple of servers that have been through every version since 1.7.2, and never had a problem. Now, I can run them with any of the 1.11.X jars, but if I select the 1.12 jar, nothing occurs and nothing shows up in the server log. I tried this with a brand new, from scratch, server, and it won’t start with 1.12 either. Below is my mineos.log, the first two lines are from a server (Creative_Vanilla) that has been running 1.11.2, and the remaining lines (Test112) are from a brand new server. This is with git commit d3eb568, node.js. Running the reset_webui.sh script didn’t change the symptoms.

9213	{"level":"info","message":"[Creative_Vanilla] 192.168.5.29 issued command : \"start\"","timestamp":"2017-06-09T03:58:53.568Z"}
9214	{"level":"info","message":"[Creative_Vanilla] received request \"start\"","timestamp":"2017-06-09T03:58:53.569Z"}
9215	{"command":"create","server_name":"test112","properties":{"generate-structures":true,"server-port":"25588","difficulty":"3","gamemode":"0","enable-query":true},"level":"info","message":"[WEBUI] Received emit command from 192.168.5.29:mc","timestamp":"2017-06-09T04:04:03.217Z"}
9216	{"level":"info","message":"[test112] Discovered server","timestamp":"2017-06-09T04:04:03.269Z"}
9217	{"level":"error","message":"[test112] Create tail on logs/latest.log failed","timestamp":"2017-06-09T04:04:03.270Z"}
9218	{"level":"info","message":"[test112] Watching for file generation: logs/latest.log","timestamp":"2017-06-09T04:04:03.270Z"}
9219	{"level":"error","message":"[test112] Create tail on server.log failed","timestamp":"2017-06-09T04:04:03.272Z"}
9220	{"level":"info","message":"[test112] Watching for file generation: server.log","timestamp":"2017-06-09T04:04:03.272Z"}
9221	{"level":"error","message":"[test112] Create tail on proxy.log.0 failed","timestamp":"2017-06-09T04:04:03.273Z"}
9222	{"level":"info","message":"[test112] Watching for file generation: proxy.log.0","timestamp":"2017-06-09T04:04:03.273Z"}
9223	{"level":"error","message":"[test112] Create tail on logs/fml-server-latest.log failed","timestamp":"2017-06-09T04:04:03.274Z"}
9224	{"level":"info","message":"[test112] Watching for file generation: logs/fml-server-latest.log","timestamp":"2017-06-09T04:04:03.274Z"}
9225	{"level":"info","message":"[test112] Using skipDirEntryPatterns: world,world_the_end,world_nether,dynmap,plugins,web,logs,region,playerdata,stats,data","timestamp":"2017-06-09T04:04:03.275Z"}
9226	{"level":"info","message":"[test112] Server created in filesystem.","timestamp":"2017-06-09T04:04:03.325Z"}
9227	{"level":"info","message":"[test112] mc (192.168.5.29) joined server namespace","timestamp":"2017-06-09T04:04:03.358Z"}
9228	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"modify_sc\"","timestamp":"2017-06-09T04:04:03.367Z"}
9229	{"level":"info","message":"[test112] received request \"modify_sc\"","timestamp":"2017-06-09T04:04:03.369Z"}
9230	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"modify_sc\"","timestamp":"2017-06-09T04:04:14.057Z"}
9231	{"level":"info","message":"[test112] received request \"modify_sc\"","timestamp":"2017-06-09T04:04:14.059Z"}
9232	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"modify_sc\"","timestamp":"2017-06-09T04:04:18.193Z"}
9233	{"level":"info","message":"[test112] received request \"modify_sc\"","timestamp":"2017-06-09T04:04:18.194Z"}
9234	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"modify_sc\"","timestamp":"2017-06-09T04:04:23.167Z"}
9235	{"level":"info","message":"[test112] received request \"modify_sc\"","timestamp":"2017-06-09T04:04:23.167Z"}
9236	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"accept_eula\"","timestamp":"2017-06-09T04:04:28.076Z"}
9237	{"level":"info","message":"[test112] received request \"accept_eula\"","timestamp":"2017-06-09T04:04:28.076Z"}
9238	{"level":"info","message":"[test112] eula.txt detected: ACCEPTED (eula=true)","timestamp":"2017-06-09T04:04:28.605Z"}
9239	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"start\"","timestamp":"2017-06-09T04:04:29.956Z"}
9240	{"level":"info","message":"[test112] received request \"start\"","timestamp":"2017-06-09T04:04:29.957Z"}
9241	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"start\"","timestamp":"2017-06-09T04:04:37.806Z"}
9242	{"level":"info","message":"[test112] received request \"start\"","timestamp":"2017-06-09T04:04:37.806Z"}
9243	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"start\"","timestamp":"2017-06-09T04:05:02.871Z"}
9244	{"level":"info","message":"[test112] received request \"start\"","timestamp":"2017-06-09T04:05:02.874Z"}
9245	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"copy_profile\"","timestamp":"2017-06-09T04:05:04.209Z"}
9246	{"level":"info","message":"[test112] received request \"copy_profile\"","timestamp":"2017-06-09T04:05:04.210Z"}
9247	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"start\"","timestamp":"2017-06-09T04:05:15.607Z"}
9248	{"level":"info","message":"[test112] received request \"start\"","timestamp":"2017-06-09T04:05:15.608Z"}
9249	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"start\"","timestamp":"2017-06-09T04:05:26.021Z"}
9250	{"level":"info","message":"[test112] received request \"start\"","timestamp":"2017-06-09T04:05:26.024Z"}
9251	{"level":"info","message":"[test112] 192.168.5.29 issued command : \"start\"","timestamp":"2017-06-09T04:05:28.174Z"}
9252	{"level":"info","message":"[test112] received request \"start\"","timestamp":"2017-06-09T04:05:28.175Z"}

I’m using this docker https://hub.docker.com/r/yujiod/minecraft-mineos/ - I’m not sure which webui I’m using. At the top it says webui version 75760d0 if that helps.

What I did was click on Manage Profiles and then Create Custom Profile and then I entered the details from the minecraft page https://minecraft.net/en-us/download/server and the download url https://s3.amazonaws.com/Minecraft.Download/versions/1.12/minecraft_server.1.12.jar

I don’t have this option - is this because I’m using this docker https://hub.docker.com/r/yujiod/minecraft-mineos/?

Same thing is happening to me, I cannot get 1.12 to load at all, the server will not start with 1.12 selected, but any other version is running fine for me.

If you (alle three of you, and any others coming in later) are running the docker version, you are most likely running an outdated version of MineOS. Please read this thread for info and tips on fixing it:

If you are not running docker, you most likely still have an outdated version of MineOS, and need to upgrade: https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui

I’m using the FreeNas version of MineOS, installed through the Plugin add-on.

OK. But I still guess you need to update your MineOS installation if you haven’t done so after installation. Have you checked the link I gave above on updating WebUI? Or done a search in this forum for FreeNas and MineOS upgrade? There are threads about that as well.

since 1.12 your server needs to be running Java 8 - this is why the docker I’m using has stopped working as it’s using java 7. maybe the same problem with your plugin???/

Yes, because the docker you’re using is based off of the Python version of MineOS…an iteration of the webui that was written starting 4 years ago and hasn’t been updated in any substantive way since Mid 2015.

That’s not to say that this older version won’t work with 1.12–it will. However, without knowing the settings of your profile or other changes you’ve made since trying 1.12, it’s hard to tell.

I am guessing this might be an entirely separate, unrelated issue. You, Eric_Johnson, are using the NodeJS webui (the one I still actively maintain). So whatever issue you’re experiencing feels similar to the OP’s but couldn’t be–the webuis are entirely different.

I encourage you to open up a new, separate post so we can address this.


For clarification for all future readers:

https://hub.docker.com/r/yujiod/minecraft-mineos/ -> Non-official docker build. Doesn’t seem problematic and doesn’t seem to be set up wrongly…but it is set to a commit from May 17, 2016, just a few commits behind the head of the older, PYTHON webui.

Newer commits mean 1.11 is already listed in the webui by default. Soon, somebody will probably add 1.12 but it still won’t show up in your UI unless yujiod re-runs the docker file build (last time was a year ago or so).


https://hub.docker.com/r/hexparrot/mineos/ -> Official docker build, managed by me. This is up-to-date and the webui I actively still develop. No, you don’t have to switch to this from the Python one, but there are so many improvements, I believe the merits should compel one to use this NodeJS-version instead.

I updated it yesterday, by chance.


https://hub.docker.com/r/hexparrot/mineos-docker -> Official docker build, managed by me. I just learned yesterday how to do automated builds of docker images after each commit. This docker, which is not yet widely known of because of its newness, will always, 100% be the most recent commit I’ve made.

2 Likes

Is that right? Can you provide a source? I definitely will need to further update all my documentation and such if this is the case–some of my tutorials still run through Java7.

I did an update (d3eb568) of my node.js version before trying to migrate to the new minecraft_server.1.12.jar, and later a reset using the convenience scripts. Here is the output from the running the update script again this morning:

mc@192.168.5.66’s password:
Welcome to Linux Mint 17.2 Rafaela (GNU/Linux 3.16.0-38-generic x86_64)

Welcome to Linux Mint

  • Documentation: http://www.linuxmint.com
    Last login: Thu Jun 8 20:31:37 2017 from 192.168.5.29
    mc@IvyBridge-Server ~ $ cd /usr/games/minecraft
    mc@IvyBridge-Server /usr/games/minecraft $ su
    Password:
    IvyBridge-Server minecraft # /bin/bash update_webui.sh
    Script execution started on: Fri Jun 9 06:08:55 PDT 2017
    Updating mineos-node repository…OK
    Pulling master branch…From https://github.com/hexparrot/mineos-node
  • branch master -> FETCH_HEAD
    OK
    Updating npm dependencies…OK
    Setting node javascript files to executable…OK
    Script execution ended on: Fri Jun 9 06:09:05 PDT 2017

This issue is separate from the OP’s issue, let’s take it to a new post.

  1. System Requirements
    Starting from 1.12, Minecraft will no longer support Java 6 or 7. If you are using the latest launcher, you do not need to worry about this as Minecraft ships with its own version of Java. If you know you are using your own version of Java however, you’ll need to make sure you’re using Java 8.

Great discovery, thanks @DZMM. This will cause tons of confusion for users of MineOS, I’m sure, so it’s good to know this right from the get-go.

problem solved by moving to your official dockers - learnt a lot in the last 24 hours - thanks!

2 Likes

what’s the difference between mineos and mineos-docker? I installed the later yesterday and it was working fine, but then it got in a tizz when it tried to update because I think you deleted it as the page is a 404.

So…I deleted my installation and tired to install mineos but it won’t install… :frowning:

Edit: read this thread - think I got caught up in the deletion of ‘mineos-docker’ and the new entrypoint.sh bug with the mineos docker

Alright, I think I fixed the entrypoint.sh bug–would you care to try it out?

the docker runs now, but I can’t get into the webui.

Edit: I had the same problem with the mineos-docker version yesterday - the webui wasn’t showing but the servers were live, which is what prompted me to try the mineos version. unfortunately because this is a fresh install of the docker I don’t have any live servers running