Updating Errors WebUI


#1

Hi, Ive bee struggling with this for months now and I keep going around in circles trying to figure out what to do. Ive finally managed to putty back into my Minecraft server and was planning to rebuild it with a new modpack. but beofre all of that, I figured id update everything. MineOS, webui etc. Followed the instructions in t he wiki and I get this:

I have no idea what to do or where to go from here. I tried to use that “Git commit” link in the top right hand corner of the Webui, but just get taken to a page with code on it.

Some help would be great.please bring the explanation back to BEGINNER level so I don’t have to continually ask questions trying to understand your responses.

Best responses would be ones with solutions and not whats wrong.

Cheers


#2

Firstt off:
Those messages are warnings from the rebuild operation, not errors. So they may not mean to much. Have you tried rebooting and opening the WebUI to check if it works? If it does you do not really have to do anything other than enjoy your MineOS

All of those warnings comes from pieces of software that MineOS needs, luckily you can upgrade them quite easily if you need to:

apt-get update

and then

apt-get upgrade


#3

Thanks,

Ill do anything to try and get MineOS to work a little more efficiently on my system. I want to keep it up to date, but I dont even know what the latest version is or where to go to find out. My version of MineOS is a pain to work with.

Cant complain too much because it is free, which is appreciated

OK, So I updated and upgraded MineOS. All good. Now the Webui is still pain so I went and did the update and reset commands. Get the same "Warnings as before. What concerns me here is the messages are asking me to upgrade to the latest files. Knowing that my Webui is a friggin pain to work with and the fact that I did the upgrades, Something is not gelling here. at the moment, the Webui wont even set up a server. just hangs when I click the start button.

Is there a discord server I can speak to someone live? Waiting 12-24 hours makes for a long discussion.


#4

I notice your initial screenshot says you’re still using Node v. 4.8.5.

That version is a bit old, and could likely explain some of the issues of the webui not working, as it would depend on modules that–as you can see–are no longer maintained and expecting newer versions.

I’d say that removing your existing nodejs 4.8.5 and replacing it with the the LTS 8.0 version. There’s a newer 10x version of Node, but I don’t think I’ve tested against it so do so at your own discretion.

I don’t have one, but I’m not likely to want to personally start one, since MineOS as my hobby-project already takes dozens of hours per week from me, and adding in “live technical support” is a bit too much much for me to handle.


#5

The commands to remove the old nodeJS:

sudo apt-get remove nodejs
sudo apt-get purge nodejs
sudo apt-get autoremove

Then follow these steps to install a newer version:

Turnkey uses the same base system as ubuntu and debioan, and thus instructions for ubuntu / debian also works for Turnkey


#6

Thanks guys for your support so far, but I think I now have a deeper problem. I can no longer putty into the server, neither can I can I Open my FTP to the server. I think this one is on me as I think I had an FTP brain fart. Am I able to reinstall MineOS over itself? (Which is what I thought I was doing with this whole scenario, upgrading the OS). I need to get whatever files I stuffed up back into the right place.

Having said that, MineOS does start up and I can access the command screen on the server. Its a oldish Desktop, certainly can handle a minecraft server, but it doesn’t have a CD Player, just a USB slot.

Ill give the link above a go and see how I go…not holding my breath tho. :confused:

OK, as I suspected, those commands to remove and purge the nodejs, come back with an error state the command is not found. no idea where to go from here. There is no active server on this system so im not losing anything here regardless of what I try. (other than my calm demeaner)

Cheers


#7

What was the command you tried?

It could be anything from a typo, to being in the wrong directory, to being the wrong user–can’t determine without more information.

Keep in mind, the MineOS webui is really a collection of files put on some Linux server. You can blast away the entire disk–install a new OS–or whatever you may do… so long as those few dozen files exist in /usr/games/minecraft, it’ll run: there’s no deeper integration to MineOS other than it being bundled with Debian for convenience.

The steps from the wiki to reset the webui are only updating files downloaded from Github. All other upgrades would have to happen with a separate install or the system’s package manager.


#8

OK, So I finally have a working copy of MineOS back on my server. and I can access via FTP and Putty. I have no idea if my version is the latest but I did download it a week or so again ( [d9a604b] ). I can never find out where the latest buidls are to see if it is. But, back to creating a serve and MineOS is STILL Lagging like a Bitch and freezing, hanging and carrying on like a porkchop. will try ti update the webui (yet again) but im getting pretty dejected over this OS.


#9

Can you provide the link you used to download? Because d9a604b is from July 2017, where there have been many, many performance-improving changes since then. There have also been many, many ISO releases that should have superseded that one, providing at least a few of those improvements throughout 2018.

Clearly this old version still being findable is a detriment to the experience of MineOS and I’d like to remedy that as soon as possible.


#10

Landed at this page:
https://minecraft.codeemo.com/mineoswiki/index.php?title=Main_Page#Pre-configured_ISOs

and then downloaded the “Current ISO” link from the heading…
https://my.syncplicity.com/share/csfvlz0wumnqczc/mineos-node_jessie-x64

So much for Wikis.
Is there a page I can go to to a) find out what the latest version actually is and b)download that version?
Ive spent too much time trying to update this server already, most of it is trying to figure out what the latest version is. That numbering system is very confusing.


#11

The numbering system actually is based on the version control system GIT which represents what the last change to the codebase is. In git nomeclature, this is called the “commit hash”.

Here you’d see the hash that represents having the latest code, vs the hash d9e83a97… which is a bit older.


#12

LOL…The question mark above my head grew that much larger. The world works in alpha numeric, ie version 2 is newer than version 1 in its most basic form. The “Commit hash” as you call it must follow this in SOME manner surely. otherwise GIT has headed down the path of secret handshakes and hand signals.


#13

Commit hashes–the value themselves–I promise you, are non-sequential.

They veered away from sequential numbering because the hashes instead serve as security measures ensuring integrity of changes and also the sequence of their application.

If you’re interested in the anatomy of a git commit.


#14

Ah, security measures. so if you were to look at two random Code version that you have had nothing top do with and only compare them with the commit hashes, could you tell which was the latest version?

That Page of git commits makes a lot of sense as to the reason why btw. It’s is a good way to ensure data integrity. Does not address the version comparison tho, at least not what my limited understand saw.


#15

Still looking for the latest version of MineOS. Tried the update and upgrade .still got the same version ( [d9a604b]). node version is 4.9.11.

Whats next???


#16

Did you restart the webui background process since going through the upgrade process?

Alternatively you can just restart the entire host, but going that far isn’t even necessary.

You also can check what version the files are at…because if it the files are the right version but the webui is reporting differently, it just hasn’t been restarted.

This will report the commit your files are on.


#17

d9a604b9d4672d36cc8e860e8531b00bce27d510

It appears as though nothing has updated…sigh


#18

I understand that you’re frustrated, but the issue you’re experiencing is not a MineOS issue, it’s limited to your ability to SSH and run some bash commands.

If you’d like further assistance with updating your webui to a modern version, copy/paste the full input/output of your terminal shell and provide it here.

At this moment, all I know for certain is that you’ve run the npm update and received a few warnings.

I do not know:

  1. that you’ve updated the webui via git fetch and git reset --hard origin/master.

If you are able to provide the full session details copy/pasted from your putty session that show you entering the directory, running git fetch and git reset --hard origin/master, it will be abundantly clear that the update took and the webui (when restarted) would reflect that.


#19

I’m not ragging on MineOS or the devs. you guys do an awesome job that I could never do and I do appreciate your help, but you must acknowledge that there is an issue here and if you believe its not a MineOS issue, I’ll believe you an would love to know what the issue is, but only to get to the right solution. Other than that I really don’t care about the issue.

ALL I have done with this server is download the “Current ISO” from the Wiki, burnt the ISO to disc and loaded it to the server. Only to find that the “Current ISO” is not actually current. Then I applied the only two commands that have worked so far Apt-get update and apt-get upgrade

Not being provided with these commands, Just now I tried the “git fetch --hard origin/master” command and it returned an error

“fatal: Not a git repository (or any of the parent directories): .git”

So if you say its not a MineOS problem, then I’m happy to listen to suggestions. Turnkey maybe? but everything is packaged in the ISO.

Now regarding the “full input’output” of my terminal shell. not knowing specifically what you are after, I’ve pasted some links to the apt-get update and apt-get upgrade commands.

from the apt-get update" https://pastebin.com/cBCsGFye
from the apt-get upgrade https://pastebin.com/5j6QCDbc

Yes, I’m frustrated, but I’m still keen to get MineOS up and running smoothly. is it possible to load a Linux System separately to MineOS and then installed MineOS onto that system? IDK, just offering up ideas I’d also like to get my servers website (preferably a Joomla CMS) up and running on the same server. Tried that too, but it threw back errors as well.

I’m sorry I cant be more helpful in getting to the heart of this, just know I want to stick with you guys. you do provide a good product.


#20

The wiki shows the instructions you should be following to upgrade the webui.

I’m very sorry that up until this point we still hadn’t led you there.

Yes, this is one of the most common means of installing MineOS. Depending on which distro you use, you can follow the instructions for the standalone webui here.