Unable to update to newest version

So, I have recently discovered that te WebUI I’m running is extremely old. To be precise, it says (in the top right corner) ‘Version: 24b30ef’. It runs just fine, but I’ve seen that it doesn’t have some of the interesting features that the newest version does. I tried updating following https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui, only to find out that the command npm was not found. Fixed this by installing Node.js. When I tried running the command again I got another error.
I’m guessing the best way is to do a full distro upgrade. How would I accomplish this?

Thanks in advance,

What was the follow-up error? It’s likely easier to solve directrly than starting over with a full distro upgrade.

The following was copied from the Shell in a Box:
`npm ERR! install Couldn’t read dependencies
npm ERR! Linux 3.2.0-4-686-pae
npm ERR! argv “/usr/bin/nodejs” “/usr/bin/npm” “install”
npm ERR! node v4.3.1
npm ERR! npm v2.14.12
npm ERR! path /usr/games/minecraft/package.json
npm ERR! errno -2
npm ERR! syscall open

npm ERR! package.json ENOENT: no such file or directory, open ‘/usr/games/minecraft/package.json’
npm ERR! package.json This is most likely not a problem with npm itself.
npm ERR! package.json npm can’t find a package.json file in your current directory.

npm ERR! Please include the following file with any support request:
npm ERR! /usr/games/minecraft/npm-debug.log`

It helps in general if you can also provide the context to the errors, such as what you typed in prior to getting this error.

So where possible, don’t omit the command line and keep the full string, including this:

root@ubuntu:/usr/games/minecraft# npm install

At any rate, the error you’re getting shows:

npm ERR! package.json ENOENT: no such file or directory, open '/usr/games/minecraft/package.json'

Is that file missing? Did you do the git commands before npm?

I’m might be missing something here as well.
I’d like to update the Web-UI as I have the same version.
I built my server from the TurnKey ISO (wheezy 64-bit version) and ran through the first part of the solution:

cd /usr/games/minecraft
git fetch
git merge origin/master

npm install

I tried to search for steps on installing the node.js, but what I found seems to be how to add MineOS to an existing running system.

1 Like

What was the output?

This is what I inputted.

root@machine games/minecraft# cd /usr/games/minecraft/
root@machine games/minecraft# git fetch
root@machine games/minecraft# git merge origin/master
Already up-to-date.
root@machine games/minecraft# npm install
-bash: npm: command not found
root@machine games/minecraft#

(sorry I don’t know how to put it into code format)

This is exactly the same output that I got, until I installed Node.js.

Type this command find / -name "npm"

npm should most certainly be there on your system, but my guess is you might have caught the ISO that used the node version manager (nvm) that lasted about 5 days before I decided to replace it with a different approach installing node.

Two ways to address this:

  1. As KNO56 says, just install node.js (preferred)

    curl -sL https://deb.nodesource.com/setup_5.x | bash -
    apt-get -y install nodejs
    npm install

  2. Using the path returned by the find / -name "npm" command, type in that path, plus “install”. So if it returned that npm was found at /usr/local/bin/npm, you’d type in: /usr/local/bin/npm install

Thx for replying & mentioning me, I was afraid that this suddenly became Fornaxbeowulf’s thread. (no offense to him)

Anyways, what do you suggest I do?

^ Didn’t you say you installed node?

If not, do this: v

I already did (2nd post I think)

I asked this after your second post. Can you verify there’s a file /usr/games/minecraft/package.json?

This seems to suggest to me you were not in /usr/games/minecraft when you executed the command npm install.

Confirmation: there is no package.json in the aforementioned location

From the wiki:

Resetting scripts

If updating the scripts returns an error or otherwise fails to solve a web-ui problem, you can try resetting the scripts. This will discard any and all local changes to the source and ensure permissions are set properly.

OK will try that then

OK I did that, now when I do the update command, I get the same as before; package.json not found.

No offense taken, I was running in a similar issue… but got stuck at the install nodejs.
Thanks for the OP Kno56, I’ll continue to watch as I may run into other issues you get…

Sure no problem, I would’ve done the same.