Unable to install via USB


#1

I’ve been trying to install MineOS to a spare machine I have. I just threw a new SSD in there for the purpose of turning it into a dedicated MC server, but I can’t get MineOS to install via usb. I’ve tried various linux bootable creation tools, and nothing works. They all end with an error “unable to find a medium containing a live file system.” I’m also seeing “mounting /dev/sdb1 on /cd rom failed invalid argument” over and over. The system doesn’t even have an optical drive at all. It is literally JUST a 120gb ssd and nothing else. Slax live boots just fine and windows can see and install to the ssd just fine, but MineOS with neither boot as a liveCD in demo mode or install to hard disk.


#2

For future reference it might be nice to know how to fix this, but I did end up just going the ubuntu route. It was definitely not easy as a linux noob, but I got it all sorted.


#3

Assuming that you already checked BIOS settings to boot, and tried different distribution, or even tried another computer, with the same results?
Then in that case, I’m not sure, but I think that the boot load doesn’t installed on the USB. I had a similar issue, but ended up using a disc and a USB drive. But I was using an SD card on a netbook.


#4

I have the exact same problem, really wanted to try out MineOS :frowning:
Guess i have to do it the linux way…


#5

The “official” distro itself is very outdated at this point anyways, requiring several steps before being able to be used with today’s Minecraft versions, so you might as well at this point be going the Ubuntu route anyway (also for the broader range of hardware support). I’ve said sometime back that I would be creating my own version though I have yet to do so years later, however I may go ahead and do so sometime soon, but again maybe not; we’ll see.


EDIT: Boom


Updated Beginner-Friendly version of MineOS-Node (distro)