Ubuntu 14.04 MineOs-node wont start

I followed this guide here MineOs-node(apt-get)

When I attempt to start the server I get the message that it’s already running.

But using my browser to returns ERR_CONNECTION_REFUSED. This machine was running a very old version of MineOs and worked great. Would like to get Node working. Any help would be great.

Ubuntu 14.04 64-bit

Do you have a firewall enabled that let the old webui through but not this one at 8443?

What does /var/log/mineos.log say?

root@SERVER:~# start mineos
start: Job is already running: mineos
root@SERVER:~# cat /var/log/mineos.log
cat: /var/log/mineos.log: No such file or directory

If I run it the old way I found this is what I get.

root@SERVER:~# cd /usr/games/minecraft/
root@SERVER:/usr/games/minecraft# node webui.js
base_directory found in mineos.conf, using: /var/games/minecraft
MineOS webui listening on HTTPS://

Still no WebUI

ufw shows port 8443 as open.

Ok i’m not sure what has changed but after a reboot, now it’s working. I’m sorry for wasting your time.

Ok it was up for a bit but went down and now won’t relaunch.

server@SERVER:~$ sudo mineos start
[sudo] password for server:

throw new TypeError(‘Arguments to path.join must be strings’);
TypeError: Arguments to path.join must be strings
at path.js:360:15
at Array.filter (native)
at Object.exports.join (path.js:358:36)
at new mineos.mc (/usr/games/minecraft/mineos.js:127:15)
at Object. (/usr/games/minecraft/mineos_console.js:119:16)
at Module._compile (module.js:456:26)
at Object.Module._extensions…js (module.js:474:10)
at Module.load (module.js:356:32)
at Function.Module._load (module.js:312:12)
at Function.Module.runMain (module.js:497:10)

This is 14.04? Try:

sudo service mineos start

and see what happens. I downgraded from 15.04 and I think you’re using the start command that I was using for that one.


That just gives me the general outcome.

server@SERVER:~$ sudo service mineos start
[sudo] password for server:
start: Job is already running: mineos

What does your /etc/mineos.conf look like, and has it been modified in any way?

I just wiped everything out on my server for upgrades, It’s a clean install of 14.04 and a fresh install of mineOs from that link I Provided. Here is the config file just in case.

use_https = true
socket_host = ‘’
socket_port = 8443
base_directory = ‘/var/games/minecraft’

ssl_private_key = ‘/etc/ssl/certs/mineos.key’
ssl_certificate = ‘/etc/ssl/certs/mineos.crt’
ssl_cert_chain = ‘’

I’m not sure what’s causing it to be intermittent–it should be able to stay up. Either the crashes should be logged in /var/log/mineos.log or there should be some other sort of indicator.

If you haven’t yet gotten it working, have you tried the convenience installer script from the wiki? There’s one available and tested working (today) for Ubuntu 14.04 and there’s also a different one for 15.04.

Both should, upon running the one script, install and start the webui entirely from a fresh install. I tested it today (and updated it) to use the newly released Node v4.0 too.

I am also running Ubuntu 14.04 64 bit, and I found that when I upgraded my MineOS from the python version (what you are calling the apt-get version) to the node version, I had to be careful to completely remove the old MineOS.

So what I ended up doing to make everything work properly was (make sure everything is done as root!)::
1 Make sure MineOS is NOT running (ie as root: stop mineos)
2 Remove the /usr/games/minecraft directory (I renamed it to python.minecraft so I had the backup)
3 Remove /usr/local/bin/mineos, /etc/mineos.conf, /etc/init/mineos.conf (no need to back them up!)
4 apt-get remove nodejs nodes-legacy npm
5. Follow the instructions for the node webui install (found here:
6. Since I had problem with the webui starting up my minecraft servers after this, I had to make sure my primary minecraft account was the owner of /var/games/minecraft. In my case the username:group is minecraft:minecraft, the turnkey uses something like mc:mc, yours may be different. So:
as root:
chown <mcuser>:<mcgroup> /var/games/minecraft -R
(makes sure all subdirectories are properly owned as well.).

You should be good to go after this. Pop up a note if you are still having problems and/or everything is working!

[EDIT] BTW, I presume that you did the HTTPS setup as per the instructions? If you did not set up the security certificate, you will be denied access.
[1]: http://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS_(apt-get)

1 Like

^^ all of this! Definitely the right way to get things working

Ok so I figured i’d update on what’s happening now, The server will come up and run like it’s told to (MC server). The webui will work ONCE. The second I logout it crashes. Service mineos stop just locks up and have to kill it ctrl+z. I just followed the steps above to clear everything and ran the convenient script just to make sure it’s right… yes as root. Any ideas?

I still think the mineos.log would be the best indicator of what’s happening and why it’s crashing.

Ok this is my log. Drive Link

Anyone have any ideas?? I’m being forced to restart my server just to close my MC server down. Is there at least a way I can manually shutdown the MC server via ssh?

From ssh: killall java
or kill 1234 where 1234 is the PID of Java from top

Can you verify that each of the following directories are completely deleted:


Lastly, are you doing any deleting of files from command line/ssh/etc, (some place not the webui)? I’ve been trying to reproduce the errors you get and I just can’t do it. Fixing a problem is easiest when the problem is reproducible, but I am not sure how to get my system in the state you’re experiencing, with the crashing, etc.

Thanks for the help. I can confirm that the folders are not present.
I’m not doing any editing via ssh. The only thing I just thought of was a script I made to dump caches if it gets too low.
I know it’s not recommended but it was a way to stop my brother from crashing his server (Omegaland) from over ram usage after several days. I’ll disable that now and see if it corrects the issues. Also I can not seem to stop mineOs webui via sudo service mineos stop/start. It just sits there with a blinking cursor. I hope this helps.

Hi kicker, where did you put your mineos.conf - /etc/init or /etc/init.d? On my 14.04 system, I put it in /etc/init and just use ‘sudo start/stop mineos’ which is the upstart method used now. If I tab-complete ‘sudo service min’ with a couplel of taps of the tab key, it cannot find mineos. If you have it in both locations, that might also be a source of problems for you. I would totally recommend putting it only in /etc/init.

Also note there should be a mineos.conf in /etc which needs to be there as it is the actual config where /etc/init/mineos.conf is simply for starting and stopping the service.

My apologies if you already know this, but I am trying to help you eliminate possible sources of error.

[EDIT] It would seem on checking that I am also having problems stopping and then starting mineos from the command line. “sudo stop mineos” provides no output until I - the process at which time it tells me the process has stopped when I “sudo status mineos”. After that, tab completing the name does not work for start/stop but does work for status. Weird.
Have to reboot the service for the tab completion to work properly again for the mineos job.

{“date”:“Thu Oct 08 2015 09:58:40 GMT-0700 (PDT)”,“process”:{“pid”:1206,“uid”:0,“gid”:0,“cwd”:"/",“execPath”:"/usr/bin/nodejs",“version”:“v4.1.2”,“argv”:["/usr/bin/nodejs","/usr/games/minecraft/webui.js",“start”],“memoryUsage”:{“rss”:95096832,“heapTotal”:62899968,“heapUsed”:28561888}},“os”:{“loadavg”:[1.61962890625,0.345703125,0.11279296875],“uptime”:23},“trace”:[{“column”:null,“file”:null,“function”:“Error”,“line”:null,“method”:null,“native”:true},{“column”:32,“file”:“module.js”,“function”:“Module.load”,“line”:355,“method”:“load”,“native”:false},{“column”:12,“file”:“module.js”,“function”:“Function.Module._load”,“line”:310,“method”:“Module._load”,“native”:false},{“column”:17,“file”:“module.js”,“function”:“Module.require”,“line”:365,“method”:“require”,“native”:false},{“column”:17,“file”:“module.js”,“function”:“require”,“line”:384,“method”:null,“native”:false},{“column”:15,“file”:"/usr/games/minecraft/node_modules/userid/lib/userid.js",“function”:"",“line”:2,“method”:null,“native”:false},{“column”:26,“file”:“module.js”,“function”:“Module._compile”,“line”:434,“method”:"_compile",“native”:false},{“column”:10,“file”:“module.js”,“function”:“Object.Module._extensions…js”,“line”:452,“method”:“Module._extensions…js”,“native”:false},{“column”:32,“file”:“module.js”,“function”:“Module.load”,“line”:355,“method”:“load”,“native”:false},{“column”:12,“file”:“module.js”,“function”:“Function.Module._load”,“line”:310,“method”:“Module._load”,“native”:false}],“stack”:[“Error: Module did not self-register.”," at Error (native)"," at Module.load (module.js:355:32)"," at Function.Module._load (module.js:310:12)"," at Module.require (module.js:365:17)"," at require (module.js:384:17)"," at Object. (/usr/games/minecraft/node_modules/userid/lib/userid.js:2:15)"," at Module._compile (module.js:434:26)"," at Object.Module._extensions…js (module.js:452:10)"," at Module.load (module.js:355:32)"," at Function.Module._load (module.js:310:12)"],“level”:“error”,“message”:“uncaughtException: Module did not self-register.”,“timestamp”:“2015-10-08T16:58:40.882Z”}

I can’t tell if all these issues are cascading from a higher-up error, so if you can try the following things, I can know what your script version is and whether or not old plugins are causing issue.

cd /usr/games/minecraft
rm -rf node_modules
git fetch
git reset --hard origin/master
npm install

restart the webui (stop mineos, start mineos)–or restart the host.

ok so I checked /etc/init for mineos.conf (it’s there) it’s not in /etc/init.d/.

As to the above commands. Here is how I ran it,
sudo -i
cd /usr/games/minecraft
rm -rf node_modules
git fetch
git reset --hard origin/master
npm install

when i hit stop mineos it just hangs