Status 403 When i want to download versions 1.12.2++

when i want to download minecraft versions greater than 1.12.2 it says
“Remote server did not return minecraft_server.1.16.1.jar (status 403)”
so… when i try to delete profile(versions) from filezilla i get this…

Command: rm “/var/games/minecraft/profiles/1.7.10/minecraft_server.1.7.10.jar”
Error: rm /var/games/minecraft/profiles/1.7.10/minecraft_server.1.7.10.jar: permission denied

i got this error for all profiles
i am a newbie… but i learn things fast!

Which account did you use to log into with FileZilla? What is the Webui’s commit version?

[git commit: 0e45be7]
i was using username: mc and the root pass : **********

i can log in filezilla only with user ‘mc’ because when i try with ‘root’ it says :
|Status:|Using username “root”. |
|Status:|Access denied |
|Error:|Authentication failed.|
|Error:|Critical error: Could not connect to server|

Log into the terminal line as root and run the Webui update commands. The commit may be out-of-date.
Also, logging into the system as root with either PuTTY or FileZilla is disabled by default. I recommend that you add the sudo group to mc, or create another account with that added. If you decide to create another account, I suggest adding that to the mc group, it’ll make life easier.
Webui Update

so, at this point when i type git merge origin/master it says "Already up-to-data’’
but when i tried to log into Mineos Gui it shows this…

Did you use the Node-js install? It looks as thought that might be out of date.

This may be related, but it might be a good idea to read the thread before diving into these steps.

i installed
i’m on Debian 7, i will update my system

Upgrading to Stretch would get the Node-js working again. You may need to run the reset instructions after, but that should fix things for you.

so i got the x64 Stretch, i have made an 8gb bootable stick with rufus and this happend…

Are you using a Sandisk USB stick? They tend to fail for disk images when it comes to booting off them. If possible, I’d use a disc or a Kingston brand stick.

i use Adata C906 USB stick

If you have another stick, I would try that, or burn the ISO on a disc. Another method would be to test the ISO file on a VM. There is another ISO to image that is commonly used, belenaEtcher. You could try that.
If your box already has a disc in the drive, that could also potentially give an error. Linux would allow a device to be mounted to any directory.

ok, it worked, kinda… but it worked, i was able to start the server but only from the mc account
but i have one more thing to solve…
i can’t execute /etc/ssh/sshd_config with root as username, i have to mention: i tried with mc too… but same thing

So /etc/ssh/sshd_config is actually a file and me not a script or app. Think of it as an .ini file in Windows. This file is owned by root and is in the group root.
If your intention is to edit the config, then I suggest

  1. make a backup cp /etc/ssh/sshd_config /etc/ssh/sshd_config.bak
  2. use an account that has sudo rights (or log in as root, then you won’t need sudo in the next step)
  3. use nano to edit the original file sudo nano /etc/ssh/sshd_config
1 Like

ok, that worked, thx

1 Like