[SOLVED] WEB-GUI cannot be reached

Hello, it looks like i can’t reach the WEB-GUI, for instance, the server’s ip is 192.168.0.9 and the PC im trying to reach with the web gui is connected to the same network (ip is 192.168.0.19). It says the website cannot be reached. I tried this is several different browers and devices, non of the work so far.
By the way, I’m new to this, I was watching a tutorial and I ran to this problem.
Thank you :slight_smile:

You are doing it like this? you probably just have the wrong credentials somewhere

https://192.168.0.19:8443/admin/index.html#

Hello!
Yes, I am doing like that, actually, by pressing that link, the browser gives me the same error, it says it refused to connect. (“ERR_CONNECTION_REFUSED”).
I don’t think I have the wrong credentials though, I am connected to through the SSH to my server and it’s working totally fine.

Go through the second post by Hexparrot and see if that changes anything or shows any issues.

So, I tried to do supervisorctl start mineos but I got a spawn error.
Then I tried to test the gui starting up by using the node command node webui.js (i did got into the directory of the file before) and i got the following error on the attached print.

Is there a missing node or something?
Thank you for your patience

You need to first cd into
cd /usr/games/minecraft

and then do node webui.js

my bad lol i am half asleep atm its 4:30 am here. i am not 100% sure but yeah that is an issue. Just ls that location and see if they contain web.js and mineos.js etc. i guess that is saying no i am not sure sorry.

as I said, i did that and got me that error
here
oh and no problem pal, its fine lol
EDIT: i forgot to mention this error i attached now its the same but i simply cut the image to be more clean

its okay, i’ll try to find some solution in other posts, go rest if you want to, thank you for your support :slight_smile: have a nice day

Thank you for your help, I solved the problem, i didn’t had node.js and npm installed correctly, now everything is working as proper.