Never tried hosting a Minecraft server before, thought this might be a good way to start. Bare metal MineOS Turnkey install on an old 2 CPU PIII system with 512MB of RAM.
Server came up after install easy, only thing I changed was to set a static IP instead of the DHCP IP. I used the Admin window Advanced screen to do this. I was able to ssh into the server with putty with no problem and the :12321 and :12320 web pages come up fine.
Problem is the :8443 site will not connect, so I can admin the server but not create a minecraft server. After looking through the forums a bit I checked top to see if node was running (doesn’t seem to be and a ps -ef | grep node came up empty as well.), and tried to manually start the mineos service using: service mineos start (mineos: unrecognized service).
I’m at a bit of a loss here. Did I miss something in the instructions, or make a simple mistake somewhere? Thanks for any help.

Are there any errors in /var/log/mineos?

Also, MineOS Turnkey doesn’t use the init.d system, but instead supervisor, so you’d be able to interact with MineOS with:

supervisorctl start mineos
supervisorctl stop mineos

Additionally, you can (as root), do this to test the webui starting up:

cd /usr/games/minecraft
node webui.js

Any errors that show up here should help us figure out why 8443 isn’t listening.

Thanks for the response. Unfortunately, it looks to me like mineos didn’t install for some reason. This is what I received from the above:

root@core ~# less /var/log/mineos
/var/log/mineos: No such file or directory
root@core ~# supervisorctl start mineos
mineos: ERROR (abnormal termination)
root@core ~# less /var/log/mineos
/var/log/mineos: No such file or directory
root@core ~# cd /usr/games/minecraft/
root@core games/minecraft# node webui.js
Illegal instruction

Not sure what to do now honestly. I didn’t see any errors during install and /var/log/messages only shows 2 errors:

Oct 12 10:34:07 core kernel: [    7.350903] EXT4-fs (dm-0): re-mounted. Opts: errors=remount-ro
Oct 12 10:34:07 core kernel: [    1.300296] agpgart-serverworks: probe of 0000:00:00.1 failed with error -22

Neither of which looks serious to me, but I could be mistaken… I’ll check back after work. Thanks again for your assistance.

Any chance you can point me to a list of packages to check/install? I’m not sure what got missed specifically, but would like to figure this out.

Based on this error, “Illegal Instruction” and that you’re on a PIII, I’m guessing that it’s a CPU issue.

Nodejs 4.0 comes with Turnkey, which is more similar to 0.12.x than 0.10.x. It seems likely that it ultimately means your P3 lacks the SSE2 instruction that nodev4 depends on, and that MineOS therefore won’t run.

It’s plausible for you to install node on your own, using an older version like 0.10.x, though there’s many problems that would crop up there, with all MineOS development now depending on the stable release 4.0 on all platforms. P3s are awfully weak anyway…

Hmm, looks like that’s it alright. Apparently SSE2 started with the P4. Since this is the only server I have available at this time, I guess I’ll give the older python version a shot. It’s for a private server anyway. Just wanted a non-public server some kids can mess around on. Maybe I’ll invest in some hardware if the experiment goes well or starts growing. Thanks for your help.