[SOLVED] SSL Connection Error - Ubuntu 14.04 to 14.10 upgrade


#1

Hi All,

I upgraded my ubuntu 14.04 install to 14.10 overnight. Since the upgrade I have been getting a “Your connection is not private” message in Chrome when trying to access MineOS. Clicking “Proceed to x.x.x.x (unsafe)” gives me a “SSL connection error” message. The details being “Unable to make a secure connection to the server. This may be a problem with the server or it may be requiring a client authentication certificate that you don’t have.”

Upon reviewing the mineos.log, this is the only error I can find:

[12/Feb/2015:10:58:28] ENGINE Error in HTTPServer.tick Traceback (most recent call last):
File “/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py”, line 1968, in startself.tick()
File “/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/wsgiserver2.py”, line 2035, in ticks, ssl_env = self.ssl_adapter.wrap(s)
File “/usr/lib/python2.7/dist-packages/cherrypy/wsgiserver/ssl_builtin.py”, line 54, in wrapssl_version=ssl.PROTOCOL_SSLv23)
File “/usr/lib/python2.7/ssl.py”, line 886, in wrap_socketciphers=ciphers)
File “/usr/lib/python2.7/ssl.py”, line 498, in __init__self._context.load_cert_chain(certfile, keyfile)
IOError: [Errno 2] No such file or directory

I’ve made sure all the scripts are up to date, regenerated the certs multiple times, and have reinstalled MineOS twice just for giggles, I’ve verified all the file permissions, tried to connect from various browsers and systems (even my phone). I’ve been all over Google this morning trying to figure out whats going on.

Assuming this is related to the error above, does anyone have any insight as to how I can get cherrypy to find the correct file/directory? I don’t know much about SSL, and what poking around I’ve been able to do I’ve not been able to fix this.

Edit: python-cherrypy3 package installed in 14.10 is 3.5.0-1

If this is something extremely simple, I’m going to slap myself … but after 4 hours of Google and docs, I’m done. Uncle!

Thanks!


Recovery from MineOs-Node install
#2

The issue you’re running into seems to be caused by your python-cherrypy3 upgrade.

Basically, something went awry in cherrypy 3.3- 3.6 and they can’t figure out a way to solve this without severely impacting existing installations on the much more popular 3.2 (what Debian and most derivatives use).

In the end, it looks like the solution is to downgrade your python-cherrypy3, and you will be able to keep all the other upgrades you wanted for other packages, etc.

Using the instructions on my first link, you’ll want to:

 service mineos stop
 apt-get -y install python-pip
 apt-get remove python-cherrypy3
 pip install cherrypy==3.2.3
 service mineos start

#3

I read the first thread but I guess I couldn’t put 2 and 2 together after all the nonsense this morning. Thank you for the clear explanation and information. I ran the commands and everything is in working order, thank you for your help!


#4

+1 to those steps. I added ram to our server this morning and noticed the time in the BIOS was off; fixed it and then rebooted couldn’t check the webui panel because I just kept seeing SSL connection error, tried clearing the SSL Statem and didn’t work.

Restarted Server couple more times and noticed that mineos service wasn’t starting properly, manually tried to start and it would start and stop. Didn’t know where the mineos logs are so i just jumped on to here to check if anyone else had this issue. I just performed those steps exactly and the mineos service started right up. This is with MineOS Turnkey by the way.


Installiation Error on clean Ubuntu 15.04
#5

Using this to fix the trouble: Your connection is not private.


#6

SSL connection errors occur when you are trying to connect to an SSL-enabled website and your browser (client) is unable to make a secure connection to the website’s server. Any mismatch in the certificates causes SSL Connection Error in the browser. Check the following :

Check System Date and Time
Disable Antivirus SSL Connection
Clear Cookies and Cached Files
Reset [Chrome](http://net-informations.com/q/mis/ssl.html) Browser
Open Chrome in Incognito Mode
Expired SSL Certificates
Update Chrome Browser