Installiation Error on clean Ubuntu 15.04

I followed the instructions for Ubuntu 15.04 (no error messages). However, when I run ‘service mineos start’, I get ‘Job for mineos.service failed. See “systemctl status mineos.service” and “journalctl -xe” for details.’.

Looking at journlctl-xe, I see:

– Unit cups.service has finished starting up.

– The start-up result is done.
Jul 03 16:28:15 minecraft-server polkitd(authority=local)[738]: Unregistered Authentication Agent for unix-process:3469
Jul 03 16:29:11 minecraft-server polkitd(authority=local)[738]: Registered Authentication Agent for unix-process:3502:2
Jul 03 16:29:11 minecraft-server systemd[1]: Starting MineOS webui startup script…
– Subject: Unit mineos.service has begun start-up
– Defined-By: systemd
– Support:

– Unit mineos.service has begun starting up.
Jul 03 16:29:11 minecraft-server[3529]: Traceback (most recent call last):
Jul 03 16:29:11 minecraft-server[3529]: File “/usr/games/minecraft/”, line 11, in
Jul 03 16:29:11 minecraft-server[3529]: import cherrypy
Jul 03 16:29:11 minecraft-server[3529]: ImportError: No module named cherrypy
Jul 03 16:29:11 minecraft-server systemd[1]: mineos.service: control process exited, code=exited status=1
Jul 03 16:29:11 minecraft-server systemd[1]: Failed to start MineOS webui startup script.
– Subject: Unit mineos.service has failed
– Defined-By: systemd
– Support:

– Unit mineos.service has failed.

It looks like a permission issue but I’m running these as root (sudo -s). Any insight on this would be greatly appreciated.


Did you install cherrypy?

Since apt-get repositories might potentially pull down a broken version of Cherrypy, we install it with Python’s pip.
As root:

pip2 install cherrypy==3.2.3

It’s been installed. May upgrade/downgrade to a different version?

I installed version 3.3 on cherrypy and it looks like the mineos service is now running OK (looking at service --status-all) .

However, when connecting to the WebUI on FireFox, I get a 'An error occurred during a connection to localhost:8080. SSL received a record that exceeded the maximum permissible length. (Error code: ssl_error_rx_record_too_long) ’ error message.

Looking at the mineos.log, it looks like there is an issue with the SSL certificate.

Am I missing an SSL package?


[04/Jul/2015:14:59:35] ENGINE Bus STARTING
[04/Jul/2015:14:59:35] ENGINE Daemonized to PID: 5455
[04/Jul/2015:14:59:35] ENGINE Forking twice.
[04/Jul/2015:14:59:35] ENGINE PID 5455 written to ‘/var/run/’.
[04/Jul/2015:14:59:35] ENGINE Forking once.
[04/Jul/2015:14:59:35] ENGINE Started monitor thread ‘_TimeoutMonitor’.
[04/Jul/2015:14:59:35] ENGINE Started monitor thread ‘Autoreloader’.
[04/Jul/2015:14:59:35] ENGINE Started monitor thread ‘Monitor’.
[04/Jul/2015:14:59:35] ENGINE Serving on
[04/Jul/2015:14:59:35] ENGINE Bus STARTED
[04/Jul/2015:15:01:52] ENGINE Error in HTTPServer.tick
Traceback (most recent call last):
File “/usr/local/lib/python2.7/dist-packages/cherrypy/wsgiserver/”, line 1966, in start
File “/usr/local/lib/python2.7/dist-packages/cherrypy/wsgiserver/”, line 2033, in tick
s, ssl_env = self.ssl_adapter.wrap(s)
File “/usr/local/lib/python2.7/dist-packages/cherrypy/wsgiserver/”, line 54, in wrap
File “/usr/lib/python2.7/”, line 911, in wrap_socket
File “/usr/lib/python2.7/”, line 579, in init
File “/usr/lib/python2.7/”, line 808, in do_handshake
SSLError: [SSL: HTTP_REQUEST] http request (_ssl.c:590)

You should install 3.2.3, not 3.3.x

[SOLVED] SSL Connection Error - Ubuntu 14.04 to 14.10 upgrade

There is a known issue with 3.3 and they don’t appear to be able to nor want to fix it, so you have to downgrade.

I removed cherrypy 3.3, removed the games folder, ran through the installation steps (which reinstalled 3.2.3).

It all works now (service runs, I can log onto the WebUI).


1 Like