[SOLVED] 1.18.x, and Spigot does not run (Updated Java Version)

When pressing ‘START’ on my server (1.18.x using the recommended mine-os-turnkey.iso) nothing happens. Double clicking the button gives me this message:

[server name] start failed
Server may not be up when performing this action.

Pressing ‘STOP’ shows another contradicting message:

[server name] stop failed
Server must be up when performing this action.

Then running it on a version lower than 1.18 (i used 1.17.x) it loads and runs the server as expected. I plan on using spigot plugins for my server, so I tried teaching myself how to mod the server. This time, same issue, except it doesn’t run at all now. Not even 1.17.x.

What version of Java are you using?

How would I check? .-.

Just use java -version in the terminal

openjdk version “16.0.1”

Ok then that’s the problem you need java 17 in order to run 1.18 what operating system are you using?

mineos turnkey, the recommended one

Ok give me a sec I will give you a method to install java 17

First login as root then run
apt-get install sudo
wget https://download.oracle.com/java/17/latest/jdk-17_linux-x64_bin.deb
sudo dpkg -i jdk-17_linux-x64_bin.deb

these commands by order and let me know what happens

after running the last command, it gave a bunch of dependency problems and stopped unpacking

Hmm have you looked into any tutorials yourself on how to install java 17?

nop ill do that now ig
tysm for the help

Np let me know If you need anything else

using sudo apt update then sudo apt --fix-broken install seemed to fix my issue. I tried that last command again and it worked :slight_smile: ill see if it lets me run 1.18 now

Ok first check the version with java -version and make sure its 17

yea nah its still 16 lol

Ok then run this sudo update-alternatives --config java
And tell me what u see

error: no alternatives for java

That means that java 17 isn’t installed yet

yea. i tried redoing the commands you told me to do earlier and nothing changed .-.