[SOLVED] 1.18.x, and Spigot does not run (Updated Java Version)

Sorry I don’t use Turnkey so its hard for me to know which ones would work for that I say u should look into some tutorial on how to get java 17 for Debian

thats what im doing now :confused: ill let u (or anyone else with the same issue) if i fix it

I know that the java version is the problem i am sure of it but i dont know how to get java 17 on turnkey :frowning:

neither do I :frowning: haven’t made any progress so far. even gone into old threads/forums. still just as clueless.

YOOO i did it tysm @ARR and @ulaar

I’m about to see if this fixes the entire issue but at least its now 17.0.1 when i do java --version

omg it worked tysm :smiley:

1 Like

Im glad your able to play now :blush:

I’m having the same issue, I made a forum about it but no one has responded in over a week, so I figured I’d go in here. I have java 17, and I have the same issue using spigot 1.18 where the server starts for a couple seconds and then crashes. Please refer to my forum post for more specifics, but I don’t know where else to go. Please help!

Does it say anything in the logs?

Also having problems probably related to Java 1.18… I can run the server on my PC with Java 1.18 but not 1.17.
But I don’t know if I change java the right way in MineOS docker, it says version 1.18 when I do java -version but nothing still happens when I press start button. Only thing I get in logs when I press start is “2022-05-02 21:44:56,443 INFO reaped unknown pid 326
2022-05-02 21:44:56,443 INFO reaped unknown pid 325
2022-05-02 21:44:56,443 INFO reaped unknown pid 326”