Server starts, then immediately stops

Can’t start server (was working fine 5 mins ago) until I tried to make a new restore point and archive when it said they failed. I have 2 restore points (a real one and one that doesn’t work), I managed to delete the faulty archive but don’t know how to get rid of the bad restore point.
Here is the logs when I try and start my server:

[14:39:25] [Server thread/INFO]: Starting minecraft server version 1.15.2
[14:39:25] [Server thread/INFO]: Loading properties
[14:39:25] [Server thread/INFO]: Default game type: SURVIVAL
[14:39:25] [Server thread/INFO]: Generating keypair
[14:39:26] [Server thread/INFO]: Starting Minecraft server on *:25565
[14:39:26] [Server thread/INFO]: Using epoll channel type
[14:39:26] [Server thread/ERROR]: Encountered an unexpected exception End of input at line 1 column 1 path $
at abk.a(SourceFile:508) ~inecraft_server.1.15.2.jar:?]
at abk.a(SourceFile:524) ~inecraft_server.1.15.2.jar:?]
at zs.g(SourceFile:146) ~inecraft_server.1.15.2.jar:?]
at wc.z(SourceFile:98) ~inecraft_server.1.15.2.jar:?]
at wc.(SourceFile:25) ~inecraft_server.1.15.2.jar:?]
at wd.d(SourceFile:186) ~inecraft_server.1.15.2.jar:?]
at inecraft_server.1.15.2.jar:?]
at [?:1.8.0_252]
Caused by: End of input at line 1 column 1 path $
at ~inecraft_server.1.15.2.jar:?]
at ~inecraft_server.1.15.2.jar:?]
at ~inecraft_server.1.15.2.jar:?]
at$ ~inecraft_server.1.15.2.jar:?]
at$ ~inecraft_server.1.15.2.jar:?]
at abk.a(SourceFile:506) ~inecraft_server.1.15.2.jar:?]
… 7 more
[14:39:26] [Server thread/ERROR]: This crash report has been saved to: /var/games/minecraft/servers/SMP/./crash-reports/crash-2020-06-13_14.39.26-server.txt
[14:39:26] [Server thread/INFO]: Stopping server
[14:39:26] [Server thread/INFO]: Saving worlds
[14:39:26] [Server thread/ERROR]: Exception stopping the server
java.lang.NullPointerException: null
at net.minecraft.server.MinecraftServer.a(SourceFile:559) ~inecraft_server.1.15.2.jar:?]
at net.minecraft.server.MinecraftServer.s(SourceFile:587) ~inecraft_server.1.15.2.jar:?]
at wd.s(SourceFile:597) ~inecraft_server.1.15.2.jar:?]
at inecraft_server.1.15.2.jar:?]
at [?:1.8.0_252]

Edit: I can now create restore points and archives idk I just waited.
Server still crashes after start

Edit: I tried to make a server from the archive I just made, it didn’t work.
I also made a brand new server to see if anything would turn on and it did.

Check top or ps – both linux utilities that tell you about running processes. It’s possible that these servers are trying to start, but there are already zombie processes still running, preventing success.

Alternatively, you can try restarting the host system, which it is unclear if you tried that yet.

Lastly, share with us the log files: /var/log/mineos.log. It’s possible some troubleshooting clues are in there, as well.

at inecraft_server.1.15.2.jar:?]
at [?:1.8.0_252]

And this suggests to me that the download might be broken. You can try deleting the download for 1.15.2 (everywhere) and then redownloading it. You can and should redownload it from the profiles.

How do I check top or ps?
I restarted the host system (didn’t work)
The log file is really long, do you want me to send you all of it? (The world that has the problem is called “SMP”)
how can I delete the download for 1.15.2? (do I delete the 1.15.2.jar thing in the server?)

Hey so you said I could try deleting the download for (everywhere). I know I can download 1.15.2 in the profiles, but idk how to delete the download.