Restore Points not generated?

I updated the web-ui a few weeks ago and with the 1.9.4 release decided to update my server over the weekend. I noticed a few weeks ago that the restore points were no longer being generated. I’ve looked through the wiki and the discussions but don’t see anything related to restore points not being generated in the new web-ui nor do I see any settings like the previous webui where you could set the time interval to for the restore points to run. Is there something I need to set in the with the new web-ui or did I miss something?

I figured it was something that would get addressed later and left it. Low and behold the server crashed this morning and several region files were corrupted. Luckily I had taken a manual backup of the world folder just last night because I happened to look at the webui and notice the last “archive” was made 2 months ago.

I’ve looked at the mineos log and the only errors I see are around creating a tail on the proxy.log and server.log (unless I got far enough back to the old ui log … and that’s full of stuff). I’ve also reinstalled the scripts (i run ubuntu) as per the wiki and have no problems with it functioning outside of the restore points (granted I haven’t tried to restore from an archive or anything like that; prior to today everything had just worked). I have save-all set to 60, it was 180 before the crash.

How can I get the restore points working again? And while I’m at it, is there a way for me to schedule an archive via the webui or am I relying on the underlying OS for that?

Both restore points(backups) and archives are fired through the scheduling tab in the WebUI. From being functions baked into MineOS they where moved to use the OS functions and cron.

Also I’m not sure for everyone else but my MineOS ‘Server Status’ page has buttons to press called ‘Create a new restore point’ and ‘Create a new archive’.

When I press either of those buttons I will soon get a message ‘Restore point failed’ or ‘Archive successfully created’. So I know exactly what is going on. My question then is, why don’t you?

On the top right corner when I click it says I can logout, the first line says what git commit. What git commit does your say?



I’m running git commit: 5f06a34. I’m generally pretty good about updating the scripts every so often. It’s not that I don’t know what’s going on when I hit the buttons, that works fine … I can press those buttons all day long and manually generate restore points and archives (you can do it from the main server summary page or from the individual pages for archives/restore points using the 3 dot button on the far right at the top).

In the previous version as iMelsom mentioned, the automation of doing this was baked in and restore points were done automatically if enabled (if I recall correctly you could set the interval via a text box; how many minutes between restore point creation). This no longer appears to be a function of MineOS, which is what I was looking for. I would have preferred it stay baked in but I can go about settings things up via scripts on my own or submitting a feature request to have it added back in (I’m assuming it was removed for one reason or another).

I did not mention the previous version. This is the current versions.
Open your server.
on the side you will se a button/tab named “Scheduling”. it’s beneath the buttons / tabs for archives and restorepoints.

You have to enter a cron -job there, with the proper argument.

For an archive once a day you enter “0 0 * * *” under “cron Expression” and select “archive” under “command to run”.


Well, that’s embarrassing … I never noticed the drop down before. My apologies iMelsom, it was right in front of me the whole time.

edit: I’m all set, thanks for handing me a pair of glasses iMelsom.

1 Like

Also the current commit is 2d22dc16952c70b0124ce0ee3ec1b5671452ad02, or 2d22dc1 for short.

It says so right here:

Better get bi-focals, lol.

Best Regards,


@tnt Wouldn’t the current commit be the one listed on the main page for mineos-node?

Latest commit 5f06a34 5 days ago

Which would match the commit noted at the top of the webui after being updated?

Wow, I see your point and am confused myself.

I wonder if you and I have different distributions requiring different commits. I thought they were all the same.

Just to be safe I am updating mine again later and would say you do the same.

Best Regards,


MineOS moved to MineOS-node last year

The Webui was redone … that’s what I meant by “previous version” earlier. I redid my install a few months ago for the MineOS-node scripts. The previous version of the webui had the restore points baked in (all you did was set the minute interval to turn it on). MineOS-node now requires you to add your own cron expression. I found this post about why this may have changed:

I guess HexParrot changed this due to the number of emails about the same thing he was receiving and wanted people to know what they were doing (etc). I’m OK with that and having spent a lot of time in support or issues around support I get where he’s coming from … unfortunately it’s not as user friend to the average user (but then again, the average user should probably just be running the jar files directly).

I use MineOS purely for the interface so I know whats going on with the server at a glance without having to review log files all night (I do that all day, I don’t want to “work” all night). The archives and restores are a bonus, something I don’t have to worry about and I can just look at the UI to get an understanding of what’s happened/happening vs having to check logs, ls directories, etc … a few clicks, I’m done and back to gaming :slight_smile:

1 Like

No, they’re all the same across different distros, the steps to get the UI up and running varies on the distros however…but the UI is all the same unless you have an old CPU that the current UI won’t work on (due to the CPU not having that set of instructions, see this thread for more info)

EDIT: @Edelan and I apparently posted at the same exact time lol but his is a bit more in-depth.

1 Like

2d22dc1 was showing 5f06a34 now shows.

I had not rebooted the server because I did not want to reset/loose the 550 hours on the clock for CandC’s Challenge server and 290 hours for the FTB Infinity server, so stable, no lag.

I had also forgoten to restart MineOS so after “supervisorctl restart mineos” I got the correct commit showing.

My bad.