Port Forwarding

So I setup everything on my server and and I also added port 25565 and my internal ip to my router’s port forwarding but when I try to join the server with my external ip it doesn’t work

What error messages are you getting? And what format are you entering into the game?

io.netty.channel.abstractchannel$annotatedconnectexception: Connection refused

and what exactly do you mean by format?

In the multiplayer screen, when you create a new server, you need to enter the address as ipaddress:portnunber

Yeah I do but still doesn’t work

What did you use for the build? ISO, npm on a different distro, docker/trueNAS, etc? Verify that the iptables are accepting your port(s).

I use MineOS Turnkey and how do I check that?

The quickest way would be to use the iptables-rules.
You can check, and edit, by using the command: nano /etc/iptables-rules

And pretty much mimic the lines already entered.

Generated by iptables-save v1.6.0 on Tue Jan 25 05:45:40 2022





:f2b-sshd - [0:0]

-A INPUT -p tcp -m multiport --dports 22 -j f2b-sshd

-A INPUT -i lo -j ACCEPT

-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT

-A INPUT -p tcp -m tcp --dport 8443 -j ACCEPT

-A INPUT -p tcp -m tcp --dport 25565 -j ACCEPT


-A f2b-sshd -j RETURN


Completed on Tue Jan 25 05:45:40 2022

Looks to be an issue at the router then. Have you test the port forwarding with other ports or systems?

No I haven’t but I will give it a try

I tried but doesn’t seem to work :frowning:

Btw my server’s ip is set to on the web ui do I have to change that?

So pretty much what your router doesn’t know which device needs to handle the request. It should point to the actual IP of the server. The server should have a static IP address, so that when the DHCP renews the address assignments, it won’t mess up the port forwarding.

Sorry i didnt really get that so what do i have to do exactly?

You should be able to set the IP in the root console and it’s pretty straight forward. Log in as root and run confconsole

I would suggest you set a static lease in the router so that it’s still managed by the router.

Confirm that the ip address for your server is the one set in the router port forwarding.

Ok then i set it to the IP of the server there? Or the default gateway

Yeah it is i am sure i checked a few times

My suggestion, if it was done, would negate needing to set the IP on the server as the router would always assign it the same address.

Can you connect on the local network?
Can you screenshot and show the router port forwarding page?
Have you saved the config for the router? some routers might have a further apply step.
Are there any other external services you’ve already enabled through your router that work?