PocketMine doesn't start (mineos-node)


#1

So I switched over to mineos-node to test out a pocket mine server. I created the server OK but when I press start, nothing happened

I see this in the minos.log

{“level”:“info”,“message”:"[PublicPocket] received request “accept_eula”",“timestamp”:“2015-08-22T10:37:24.259Z”}
{“level”:“info”,“message”:"[PublicPocket] eula.txt detected: ACCEPTED (eula=true)",“timestamp”:“2015-08-22T10:37:24.716Z”}
{“level”:“info”,“message”:"[PublicPocket] ----- issued command : “start”",“timestamp”:“2015-08-22T10:37:28.239Z”}
{“level”:“info”,“message”:"[PublicPocket] received request “start”",“timestamp”:“2015-08-22T10:37:28.240Z”}

etc, repeat for numerous attempt

not sure where else to look for debug into

running on Ubuntu 15, I figure the most likely explanation is a package I’m missing that I need to install?


#2

I tried this myself on MineOS Turnkey and I ran into the same issue. It appears that the binaries that MineOS downloads for Pocketmine are pre-compiled in a way that is expecting a library that neither of our distros use anymore, GLIBC 2.16. I think we both get 2.17 by default.

I’d tested this thoroughly on Arch–which (merely by coincidence) worked, so I though nothing of it. I’ll start taking a look at the easiest way to get this working for much more popular distros.


#3

The profile PHP_5.6.10_x86-64_Linux worked and runs ok but is only v1.4.1 - however I was able to download the latest dev build for 1.5 and change the “jar” to run


#4

I’m having a similar issue where Pocket mine will not run but it doesn’t matter if I use the 1.5 still nothing happens. Even with the PHP Linux build.

Using the latest fresh download of MineOS-Node.

It may need to be noted that I did the profile downloads as Root and NOT as the mc account. But neither brother can get a pocket mine server up. Normal servers come up normally.


#5

I am haing the same issue as well. I can’t get the Pocket mine to start, press the start button and nothing happens. I am also using the latest mineos-node_tkl-x64.iso that I installed in a KVM. I also tried the imagicalmine in the profiles ection, but same results. I am sure it is probably something I am doing or missing as I am new to MineOS. I do have the mojang 1.8.9 profile running and working for use with the desktop version of Minecraft, just can’t get a pocket one to work.

Is there a tutorial or some step by step instructions somewhere to guide you through a pocketmine (or ImagicalMine) setup with the mineos-node_tkl-x64.iso?

Thanks,


#6

Same here unfortunately, does not start and no log entries. I downloaded MineOS turnkey 64bit iso for my HyperV specifically for my daughters to play PE on. Desktop servers start ok (no way to test) Have tried PHP and 1266 profiles with no luck. I see no profiles to download for ImagicalMine from my MineOS install.

Would be great if there was a tutorial or instructions somewhere as this on the face of it is such a polished great Distro.

EDIT: I did update the scripts to latest I hope git commit: 110c591


#7

Related post: Upgrade libc6 to 2.15?

The issue here is that the PHP binaries now being released by Pocketmine now requires a newer version of a library, GLIBC. It looks like they need to be updated. Following the instructions on the linked Stackoverflow page, I was able to get it updated and make more progress.

However, I’m going to preface these instructions with right now, it seems like Pocketmine and Imagicalmine just dont work.

Here’s what I did to get the libraries updated: (as root)

echo "deb http://ftp.debian.org/debian sid main" >> /etc/apt/sources.list.d/sources.list
apt-get update
apt-get -t sid install libc6
sed -i '$ d' /etc/apt/sources.list.d/sources.list

Now, the PHP binaries that Pocketmine-php downloads works. That doesn’t mean the servers work though. Running ImagicalMine:

mc@core servers/asdf$ ./bin/php5/bin/php ImagicalMine.phar

Warning: require_once(phar:///var/games/minecraft/servers/asdf/ImagicalMine.phar/src/pocketmine/PocketMine.php): failed to open stream: phar "/var/games/minecraft/servers/asdf/ImagicalMine.phar" has a broken signature in /var/games/minecraft/servers/asdf/ImagicalMine.phar on line 1

Fatal error: require_once(): Failed opening required 'phar:///var/games/minecraft/servers/asdf/ImagicalMine.phar/src/pocketmine/PocketMine.php' (include_path='.:') in /var/games/minecraft/servers/asdf/ImagicalMine.phar on line 1

Focusing on the ImagicalMine.phar" has a broken signature, this isn’t a MineOS issue…it’s an ImagicalMine issue

And Pocketmine 1266–the version that is closest to matching your version of Minecraft on your tablet?..doesn’t download. The Pocketmine 980 build is too old if you’ve updated Minecraft on your tablet since June, 2015.

So right now, at the time of this writing, there are zero Minecraft PE solutions that I know of that will work. When new builds come out, perhaps, we can see some progress and it will be worth going through these steps. In the meantime, however, it doesn’t seem like there’s a good avenue.

Last thoughts: there’s certainly a chance that downloading any of the other builds Pocketmine offers and placing them in your server directory will work–after all, we fixed the GLIBC/PHP issue, but I have only tried with these three particular builds. YMMV.


#8

As a public service to you guys I’ll post a link to the Imagicalmine phar I am using, and that are working (apart from the occational crash). It’s an older iteration, but it still works with the latest PE editions. I dont know for how long though (Only Mojang can answer that).

http://nik.melsom.be/ImagicalMine-IC_1.0dev_613.phar


#9

Thanks Guys, I will probably revisit MineOS in a couple months time see if PE is better supported but for now I will continue to run PocketMine or iMagicalMine standalone. I was looking for a better way to manage a handful of different worlds for my Kids and MineOS with PE will be just the ticket, Fantastic work.


A rant about MineOS, expectations from users, pocketmine, imagicalmine profiles and all that
#10

I am actually running two MCPE servers (and several MCPC
servers) just fine in MineOS just fine. MineOS’s support of MCPE is just fine.
For MCPE you just need to keep up with the different bleeding edge releases to
keep up with Mojang manually, wich also means keeping an eye on the different
PHP-releases to make sure it maches your selected phar-version.

The phar I linked til in my above post is the one I use in
MineOS. As far as I know it is also a PHP5 version, but you may need to get a
newer version of PHP5 than the version available in the MineOS profile list.

This also trailed off into a rant that I cut out and made
into its own thread:


#11

Can verify this works. Got a server up and running in 60 seconds.

  1. Downloaded profile “PHP_5.6.10_x86-64_Linux” from “Pocketmine-Php” (because I’m on a 64bit system)

  2. Create a new server, gave it a name “imagical”, ticked the box “unconventional” (to hide stuff that is irrelevant to PHARs)

  3. Copied the ImagicalMine-IC_1.0dev_613.phar2 to /var/games/minecraft/servers/imagical using WinSCP (3rd party SFTP tool)

  4. Refreshed the browser page

  5. Selected PHP_5.6.10_x86-64_Linux as the profile

  6. Selected ImagicalMine-IC_1.0dev_613.phar2 as “runnable jar”

  7. Started without issue

Note, this is on a system which has done the libc6 update beforehand. This step may or may not be required depending on which OS you are using.


#12

Aaand Mojang updated PE again, så this version no longer works. Sorry :confused: