Players off LAN get connection timeout

I am trying to make a family server off of a old HP pc. I used the boot method so the pc is now a server with no windows (I think) I have done the port forwarding for IP address: 25565 and still no luck my wife and I can use the server fine. I am not really sure what else to do as most of the questions asked are for people using VM’s and I am not.

Also my modem which is a Arris TG1682G is asking for a v6 address and I didn’t get one from the mineOS install and connected device option which fills in all the info from the connected pc I get a address is not in valid range for v6.

hi the_scruffy_guy,

been there done that, lol. don’t give up yet.

the problem as i see it is about a 1000 things, any of them could prevent a connection from happening (connection timeout).

it is a chance that it could be something simple too.

so lets start:

please ensure there is no space between IP:port as you have typed it. your browser will not connect if the space is there. (if i recall).

assume your old HP has a monitor, can you log in and use the command line? this ensures the server is running correctly.

are you able to log in to the WebUI? this ensures you can create a MC server and get it running properly.

once you can confirm here those issues are not your problem we can move forward.

thanks and good luck!


EDIT: not sure why the modem will ask for v6, as far as i know, MinOS uses v4. once connected correctly this may resolve itself. or not.

Also, please ensure you are using a MC client on the PC/Laptop you are trying to log in with. to do this you will first need to create a valid MC account or use a cracked client, found easy enough on the interwebs.

I have no space in between the two. And I am not sure how to get to command line.

Also I can connect to the ui

hi the_scruffy_guy,

ok, thanks.

well getting to the command line is a must. one of the very first things to do when setting up MineOS is to update the WebUI commit. that is done from the command prompt.

what version of MineOS did you load? python, node js for example?

so, after connecting to the WebUI what version of minecraft did you choose? 1.7.10? 1.11.2? did it start properly? i’m guessing you did not add forge or mods yet.



Edit: forgot to mention, there is no need to fwd ports if you are on a home network.

if you are connecting to your server from my house, you would.

you would also need an IP address to your house.

Uploading… I don’t know if this will help or not. I used the most current version or mineOS and minecraft.

I figured out how to get to the command line but it says I need to be root?

indeed, root is required.

expanding a little in reply is also required. remember i am not there and can not see what you see and what you are doing.

there is a video on the youtube made by sir hexparrot with good instructions on how to install MineOS. url is not at hand. you would have set up your root account at setup.

so you confirm that you have set up a profile and started a minecraft server? what version? the latest? what jar did you select? the latest? needing a little bit more than that, please.

also not sure what this means?

best regards,


Yes it runs great on LAN I wanted to set it up so my brother and nephew could play, we live in different states.

I used Mojang 1.11.2,
jar is minecraft_server.1.11.2.jar

I was trying to upload a screenshot of my command line.

It says I need to be in root and it says mc@mineos

The most current ISO is not always updated with the latest releases. So updating the WebUI after install is always a good idea.

You say that people outside your LAN can’t connect, and that you have port forwarded. What IP adress do your external users try to conenct with? Your external IP-adress (the one provided by your ISP) or the internal LAN address of the MineOS server? To be able to connect externally they need to use the external address.

Also you say that your modem uses IPv6 addresses. Is your MineOS installation configured to use IPv6?

right, so get your MineOS updated to the latest version and that will help a lot.

i will be away from keyboard for several hours and will check in later, iMelsom is a great help in the meantime.

good luck!


I am trying to update the ui but it tells me I need to be in root.
Also I had it forwarded but last time I check it wasn’t and when I tried it is requiring me to fill out the v6 but when I do it tells me it’s not a valid range and when I try to opt out of the v6 it tells me to check my inputs… external

To get root status simply type “sudo -s” You will be asked for your password again.

What you are having is a modem and network issue, and not related to mineos directly. Updating the WebUI will not resolve that. It is a good idea anyhow.

This is the port forwarding howto for your modem:

I will try the sudo thing but my screen is different then the one shown on the port forwarding page

Sorry for being such a nood at this. I called my isp and they restarted my modem and this time the port forwarding took… just have to wait to see it they can log on or not…

1 Like

hi the_scruffy_guy,

sorry for my mistake, i understood you could not connect to mc at all and kept timing out.

ok so outside connections are the issue.

i can not help the modem v6 issue.

on the external IP issue, please note you will require a static IP. if your IP is dynamic, the issues multiply. brother will need to know the new one each time it changes.

even with a static ip, sometimes any reboot of modem, you could be issued a new IP and you will need to give the new one each time to brother.

a solution to this is a DNS service like or some other may be a good idea in any case.

for the root log on issue, i am confused. after a new reboot i simply type root (enter), password (enter).

note that the sudo command is not needed on my version. for example, at the root prompt i just type: apt-get update (enter).

please let us all know how you do! (if the kids are like mine they will want mods installed very soon,lol.)

again, good luck!


I was able to do the update on root (I didn’t know I was supposed to type root) and the iptables are on accept will provide a screen shot shortly when I try to log on (in the game) from the IP address instead of LAN it says It refused my request and from what I have read it is a firewall issue… I got somewhere only to be lost again lmao

hi the_scruffy_guy,

rotf! that is what i mean by not giving up! if it is not one thing…

ok, i had a modem with a built in firewall that needed looked at and laptop firewall also need looked at. this was a long time ago and memory may not serve.

keep at it! just wait until you get to installing mods and find all the mods they want only work on mc 1.7.10 and you have 1.11.2 set up, LOL.

best regards,


Is the external ip different for ever device on the network or is it the router? I think this is where I am getting hung up now.