MineOS Turnkey install but no webmin or MC user name

I installed MineOS Turnkey latest (July 2020) in a vbox VM (2 processsors, 3GB, NAT) and yes to security updates. Asked for root password and MC password but not webmin user name or password. I ran the update script for the UI and was able to connect from the host and set up a 1.16.1 server. The server is running and my grandson and friends are using it. Webmin is not working so I tried to install 1.953 but the installation failed. I see that there is a problem with webmin and the new distros. Any thoughts or suggestions? Do you think it would work if I did not do the security updates?

Just to clarify, are you referring to the Turnkey webmin site?

If so, check this thread [SOLVED] MineOS Turnkey Webmin access on Jessie
It’s a bit dated, but the commands and ports are still the same.

You should be able to log in with any account that has sudo or admin access. The mc account, by default doesn’t have sudo account (I believe), so I created another account for administrative processes.

Thank you, that worked after I opened port 12321 with iptables.

Glad that worked out for you.