[SOLVED] MineOS Turnkey Webmin access on Jessie

I have my server nearly updated and I noticed a change from the available tools that were made available in Wheezy, are not active in Jessie.
In Wheezy I used to be able to go into the Webmin on port 12321.
On Jessie, I have tried that and a myriad of other ports through my research with Turnkey.
I’ve made sure that iptables were open for the ports I tested; 8080, 10000, 12321.

and access the IPADDRESS:PORT results in “page cannot be displayed.”

Thank you for any assistance.

In the interest of minimalism, Webmin doesn’t start up by default anymore; those who wish to continue to use it may still do so by running this command:

update-rc.d webmin enable
service webmin start

And also opening up the relevant ports in iptables as you have. Sorry it’s not documented anywhere.

1 Like

Does this still use the default ports from Wheezy?
I.E. 12321 for Webmin and 12320 for the console?
Or will it use another port? (Turnkey has one set for 10000.)

Through trail and error, found it to be port 12321.
Thanks for the solution, it worked although something screwy happened to tty8, but that’s of little importance.
Simply changing the screen and back again fixes it.

Will this command make it run on every start up?

Or do I need this command every start up?


The commands activates the webmin, so it starts each time from there on. So you only need to run the command once.

Very important.


How would you go about disabling it again, for if you needed to in the future?

Are you able to make an educated guess, given how to enable it?

1 Like

update-rc.d webmin disable
service webmin stop

1 Like

i would have guessed:

service webmin stop
update-rc.d webmin disable

then restart the mineos.

did you try out your guess? how did you do?

best regards,


Similar problem here. Got MineOS running in a VM within unRAID, and this solution worked fine.

I’m hoping to run it inside a Docker container (less overhead) though, and not being familiar with Docker (or unRAID, much), I’m not sure where I can go to run the above commands.

Anyone any ideas?

Have you tried to log in using SSH then using the “su” command to access root privileges? Also I recommend adding another account with sudo group added.

root ssh access is disabled by default.

Durr. Completely forgot about that, cheers. Will try and report back.

You might not be leveraging Docker properly if you’re needing to log into it to change running services and work with SSH.

If this issue is a separate issue than the original, I encourage you to start a separate thread (it’ll get more attention that way)