mineOS portforwarding


#1

I installed the mineOS on a seperate PC I had and i have a server up and running that I can connect to VIA LAN. I have been trying to portfarward this server so my friends and i can play together and I don’t see what that problem is. I have looked into this for hours and cant find the issue anywhere. i have the photos added of the portfarwarding and the screen from mineOS. Any help will be awesome thanks guys.


#2

What ports have you forwarded?

The image you supplied shows that you only portforwarded SSH (port 22).

For Minecraft you need to port forward the mineos game port to the minecraft server you wish to allow connections from the outside. The default Minecraft port is 25565, if you are running a PE server it is 19132


#3

I have also tried this configuration as well.


#4

and it is a PC server running 1.7.10


#5

Have you checked the firewall settings on your MineOS server: https://minecraft.codeemo.com/mineoswiki/index.php?title=Iptables


#6

I have not i will look into it and get back to you thank you.


#7

Im supposed to enter this into CMD correct? and if so how do i? i have mineos on a seperate system is it through the webUI?


#8

Nope. This is systemcommands, so you have to do them on the sysmet. Easiest way is SSH using putty: http://www.putty.org/


#9

Ok so doI do this to my system running mineOS or my router?


#10

On you rsystem running MineOS


#11

When i type in “iptables --list” i get a message saying “iptables v1.4.21: can’t initialize iptables table `filter’: Permission denied (you must be root)
Perhaps iptables or your kernel needs to be upgraded.” arent i already root?


#12

use “sudo iptables --list”

sudo is the command modifier telling the system to run the command folloeing it as a superuser (SuperUser DO -> sudo)


#13

i already tried using sudo and it still didnt work i also restarted the system


#14

fuck


#15

Then write “sudo -s” to open a root shell, then write the commands WO sudo.


#16

Ok i know i am signed into the right one because it asked ofr a login etc but it still isnt working.

FUCCCKKK


#17

Have you set a root password?

if sudo is missing, you can use the command “su”, but that needs your root password instead of your “mc” password.


#18

please tell me this is good and if so do i have to put something else or can i now continue with what the wiki is saying?


#19

Yup. You are now in a root shell. go on with the iptables wiki


#20

while setting up the mineOS it had me make two passwords i typed in “su” then the other password i made (not the one i use to sign into the webUI) and then this happened.