Mineos on Ubuntu 14.04

I’ve done a fresh install of Ubuntu Server 14.04 with Apt-get Mineos and after carefully following the instructions on http://minecraft.codeemo.com/mineoswiki/index.php?title=MineOS_(apt-get)
I cannot access the webui at all. Am I missing something that is not included with the wiki?

Did you follow these instructions? install-mineos-node-on-ubuntu-server
Did you pay attention to Part 3 on how to start WebUI?

I followed the wiki one. Does your link provide a different set of steps? Would I be able to pick up on step 3? I tried running cd /usr/games/minecraft
sudo node webui.js and already gave me “Could not locate required SSL files” so I guess I am missing other steps that’s not included in the wiki.

Ha nevermind. I just recreated the sslcerts from your list and I got it running now.

You’re welcome. Glad you got it running.

I notice you linked a URL which referred to the Python webui in the instructions.

In following those instructions, you shouldn’t have come across any node webui–those instructions are for the Node-based webui only.

My best guess is that you are currently running the Python based node, having used the only common instruction between the two (regarding ssl certs). If this indeed the case, I highly recommend you consider mineos-node instead, as it is much more modern and is the only webui I’m currently developing and updating.

That said, if it’s working, it’s working; so you may choose to just stay with what you have.

How can I tell which webui I am actually running now? My version says MineOS 1.2.2 on the top left. I did notice right away that the profiles are already pre-filled; not like the old webui where you can create custom profiles which leads to my question. How do I create a profile for bukkit or spigot?

Alright, you’re definitely running the newer webui then; simply mislinked in the OP.

I’m still verifying on my end the legality of actually linking to usable spigot jars (bukkit are a no-go), because as best as I can tell so far…I’m definitely not supposed to link spigot jars. Instead, I’m permitted to link the build_tools.jar, which then downloads vanilla minecraft and then constructs the completed jar. This isn’t a trivial task to automate, though, and seeing as how it will use up all the CPU power in compilation and downloading for quite a while, I feel like it shouldn’t be treated simply like a download (as other profiles are).

That said, if you want to use either of these, you’d have to build the jars manually or download it somewhere in its completed form, such as from http://getspigot.org/ and place it in your server’s directory (/var/games/minecraft/servers/yourserver).

I know it would be nicer for a webui to do these things, but if there’s uncertain legalities in play, I’d err on the side of caution.

That makes sense especially this Eula stuff seems to be more apparent with your new Webui build. I will look into adding spigot manually then.

So I wanted to try adding spigot manually. I created a new folder in the /minecraft/server folder and added the spigot file. How do I actually create the spigot server now on the webui?

  1. Create a server with a non root user
  2. connect to your server via SFTP and drop the jarfile into the directory /var/games/minecraft/servers/<whateveryourservernameis>
  3. from the webui, select your spigot jar from the ‘runnable jar’ dropdown

I actually worked my way to just that! But Thanks for the quick response!!!