MineOS Bedrock Interim Solution

Hello all. I have a working Bedrock Server on MineOS which is quite usable from the UI and provides interactive console access, etc. as you might expect.

You can achieve this by a minor patch (I’ll put a PR into mineos-node too) and one simple CLI action.
I can’t promise whatsoever to offer support - however we’ve been playing Bedrock via MineOS happily for a few days over server restarts, etc.

Please have a look at: GitHub - tucks/mineos-bedrock-wrapper

This works with 1.17.10 and should be good for any future version.

Comments appreciated.

Kind regards,

Jez

3 Likes

Definitely going to try this out. Thanks for posting it. Can you tell me if this allows Java + Bedrock clients to play on the same server?
Thanks!

Not OP, but I believe Java clients cannot join a Bedrock server. However, you can make it so Bedrock clients can join a Java server via Geyser. I have successfully had Bedrock users join my Java server with Geyser and Floodgate on MineOS.

Thanks very much for the response. I will look into your link. I am not familiar with Geyser or Floodgate. Any suggestions on how to implement would be appreciated.
Thanks!

Hey.

I have some time (woah!)
This mod allows you to host bedrock servers in addition to java servers on mineos-node.
As per @SolarRadiation 's post, there are methods of allowing players of either type to join alternative type servers - but this is a different use case.

I am in the process of updating the PR to have the functionality merged into the main release (when hexparrot also has some PR time).

Hi, Tucks;

Where is the Mineosbedrockwrapper profile located?

Regards,
Wade

Hey wade. You’ll need the PR in branch profile for minecraft bedrock wrapper by tucks · Pull Request #432 · hexparrot/mineos-node · GitHub

Alternatively, you can pull down the jarfile from here mineos-bedrock-wrapper/download/latest at master · tucks/mineos-bedrock-wrapper · GitHub and manually configure a unconventional server and put the jar anda n unpacked bedrock server in there and fire it up.

Thanks for the wrapper Tucks.
I see that the instructions given are not clear or straight forward, and had a couple of issues as well. Below is my step by step instructions for those who ended up her in their search for a solution.
Note: This procedure require SSH root and a bit of knowledge to do. With root…be carefull. (I don’t take any resposibility for errors done with the rights)
Explanations:
(#) - is comments for the step needed with following command
($) - is the command needed at command line for this step (without the $)
(-) - is gui steps

Profile installation
I followed step 1 here to install the mineos-node patch (to be able to download profile from within MineOS): https://github.com/tucks/mineos-bedrock-wrapper/tree/master/mineos-node_patch

  1. login to MineOS using ssh as mc user (or the user you normally use) and change to root user (you will be prompted for root password)
    $ su
  2. change working directory to:
    $ cd /usr/games/minecraft/profiles.d
  3. download the mineos node patch from tucks github with following command
    $ wget https://raw.githubusercontent.com/tucks/mineos-bedrock-wrapper/master/mineos-node_patch/minecraftbedrockwrapper.js
  4. Check your MineOS webui “Profiles” menu, if you can find the “Mineosbedrockwrapper” ID.
    4a) If not able to fine the you might have to restart MineOS, or as in my case I did a reboot (running in VM)
    $ reboot now
    You should now be able to download “Mineosbedrockwrapper” profile from MineOS webui.

Downloading profile

  • Login to your MineOS webui as mc user (or the user you normally use)
  • Go to the Profiles menu
  • Select the “Mineosbedrockwrapper” ID
  • Click green Download butten for the “mineos-bedrock-wrapper” profile.
    Note: Due to a bug in the download sctipt the profile .jar file download is not coorect. (downloaded as HTML and not .jar)
    To fix this login to your MinOS via SSH again and elevate to root user (see earlier steps).
    The following steps will not be needed when Tucks updates the profile URL
  • use ssh to login to mineos with mc user
    get root access. You will be asked for root password
    $ su

Create a new server in minos webui

  • Login to your MineOS webui as mc user (or the user you normally use)
  • MineOS menu → “Create New Server”
  • change settings as needed
  • Click “Create New Server”
  • MineOS menu → " Server Status"
  • Change “Currently selected Server” to the one you just created. (if not auto selected)
  • Server Actions selections:
    • “mineos-bedrock-wrapper”
    • else as wanted
  • Java Settings:
    • mineos-bedrock-wrapper-1.0-SNAPSHOT.jar
    • Xmx: as wanted or default (256 MB)
  • Click "Copy profile to live server files
  • Do not start yet… we need to download the bedrock server*

Preparations to download bedrock server

  • To download the bedrock server from ssh you need to know the link including version number*
  • For the Ubuntu version (currently on the right side)*
  • click on “I agree button”
  • hoover over the download button to se link.
  • or you can also right click the button and “copy link”

Download bedrock server

  • use ssh to login to mineos as mc user (NOT root this time. You need to be the same user as the one that will be running the server from MineOS)
  • cd to server directory
    $ cd /var/games/minecraft/servers/
  • download the bedrock server*
    $ wget
    ex: wget https://minecraft.azureedge.net/bin-linux/bedrock-server-1.18.11.01.zip
  • unzip the downloaded zip directly in the direcory we are standing in.*
    $ unzip bedrock-server-1.18.11.01.zip
    Note: Doing this you will be asked if you want to replace the server.properties. I replaced and did the changes needed from webui, before starting server.
  • The bedrock_server software needs to be executable. Do this
    $ chmod +x bedrock_server
  • logout and exit ssh
    $ exit

Start your new minecraft server

  • Go back to MineOS webui
  • user menu (upper left) → “refresh server list”
  • Select your new server “Currently Selected Server”
  • MineOS menu → “Server.properties”
    • Change the server.properties according your needs
  • MineOS menu → “Server Status”
    • Verify that earlier settings are still the same. If not just change them.
    • Click Green start button.
      If not starting see “MineOS menu → logs/latestLog” for information
3 Likes

Hello. Thank you for doing this, it is really appreciated.
The issue of downloading an html page rather than the jar should now be resolved.
Hopefully the ‘ease of use’ should be available via a direct patch to mineos-node once the PR has passed. Meanwhile folks can follow your handy instructions (thanks again).

Thanks, Was able to verify that profile download (from GUI) now works as it should and doesn’t generate a html file.
I was not able to edit my earlier post to change the instructions, so people just need to read all the posts.
Also confirmed that I had to reboot the server for the Profile menu to actually pick up the new profile download script.

So I got the Profile downloaded, created a new server, changed the profile and jar file to bedrock, downloaded the bedrock server, unzipped it, and chmodded it.

But when I start the server the logs say:

[14:14:49] mineos-bedrock-wrapper starting Bedrock dedicated server…
[14:14:50] sh: 1: ./bedrock_server: not found
[14:14:50] mineos-bedrock-wrapper stopped Bedrock dedicated server.

Suggestions?

1 Like

Go up a couple of posts and follow steps to download bedrock server? I am guessing it’s not in the correct location…

I made this same mistake. I started to wonder if I had done something wrong the moment I wasn’t prompted to over write the file when unzipping.

This was obvious to some but not to others.
Go to the servers path as described but then move into the folder of the server you created.

$ cd /var/games/minecraft/servers/YourServer

This is a great extension, but I have a problem. When I start the server it says in logs/latest.log

[19:52:54] mineos-bedrock-wrapper starting Bedrock dedicated server...
[19:52:54] sh: 1: ./bedrock_server: Exec format error
[19:52:55] mineos-bedrock-wrapper stopped Bedrock dedicated server...

Can anyone help me with this?

That’s exactly what happened. The instructions just said:

cd /var/games/minecraft/servers/

So I did EXACTLY that. I should have also gone into the name of my server

cd /var/games/minecraft/servers/[YOUR SERVER]

And THEN done the WGET & UNZIP. Once I did that it worked like a dream.

Thanks for the help everyone!

So long and thanks for all the fish <><

1 Like

Thanks all for catching the bugs in the instructions. I’m not able to edit my post so hope people just read through comments before following them.
Looks like the most common one is in the Download bedrock server section where

cd /var/games/minecraft/servers/

should have been replaced with

cd /var/games/minecraft/servers/[Your server name created above]/

In addition as Tucks has fixed the profile download. The hole section under Downloading profile can be deleted
Section that can be deleted:

 Note: Due to a bug in the download sctipt the profile .jar file download is not coorect. (downloaded as HTML and not .jar)
    To fix this login to your MinOS via SSH again and elevate to root user (see earlier steps).
    The following steps will not be needed when Tucks updates the profile URL
    use ssh to login to mineos with mc user
    get root access. You will be asked for root password
    $ su

    go to bedrock profile directory:*
    $ cd /var/games/minecraft/profiles/mineos-bedrock-wrapper/
    remove the html version of jar.*
    $ rm mineos-bedrock-wrapper-1.0-SNAPSHOT.jar
    download the correct .jar file with wget (note: root need for write access)*
    $ wget https://github.com/tucks/mineos-bedrock-wrapper/raw/master/download/latest/mineos-bedrock-wrapper-1.0-SNAPSHOT.jar 3
    exit root user and become mc user again*
    $ exit

Update: I’ve rejigged the PR and resolved what I believe all the outstanding issue were which were blocking merge. Hopefully you’ll see this functionality in the main MineOS UI sometime soon.

That is awesome, thank you so much, I look forward to it.