Installing Crazy Craft 3.0 Server on FreeNAS 9.10

Hello, I currently have a a few vanilla servers running on my FreeNAS 9.10 box.

I am trying to figure out how to install/start a Crazy Craft 3.0 on my box

this is where I have DL’d the server files:
http://test.voidswrath.com/modpacks/crazy-craft-3-0/

I’ve also DL’d the launcher files, do I need to use this when trying to (eventually) connect to my FreeNAS server?

thanks.

As far as I can see this is for modding clients, not servers. You will not be able to run this as a server.

To use this you need voidlauncher: http://test.voidswrath.com/mod-packs/
And to cut and paste a bit from that page:

“The launcher has custom mod packs made by TheAtlanticCraft and are for
people to play our public servers, record for youtube or to play on
singleplayer!”

This means you cannot use this on minecraft server files.

I accept the challenge. I just set up a test bed for Bungeecraft to teach myself about it, from another thread.

I have d/l the crazy craft and launcher, will determine if a custome home brew can be set up and played for private multi-player use.

Check back soon.

tNt

True. Their launcher is for single player and other uses.

I will build a launcher for us to use.

False. They provide the server files to the public for private multi-player use.

tNt

Where?
Please provide link. When I browsed their website I could fin no links to download server file, only the launcher and modpacks for clients.

http://vl4.voidswrath.com/release/CrazyCraft%203.zip

Turns out any 1.7.10 Client will work so no need to build one. Just add forge and mods as per readme file.

Tested and working MineOS Archive server file here: http://berryred.info/uploader/ssd/download/1463308599.rar

Scroll down the page and enter pw in the “Download Password” box, hit enter button.

D/l pw is 4ASW.

No pw on the .rar file, just d/l and extract. Note the readme file.

Forgot to mention in the readme file:

Server port is 25565 so change as needed for your setup.

Launch the correctly configured mc client per the readme, click “Multi-Player”, click “Direct Connect”, enter your server’s IP and port you chose (192.168.1.xx:25565), click “Join Server”, enjoy!

Good Luck!

tNt

1 Like

Hi there, WOW… thanks for the work!! I woke up this morning to find a bunch of responses… I’m glad to see I am able to run this on my FreeNAS box… however…

I have DL’d the file you’ve provided and have tried to understand the readme contained. Client side, I think I am set, I can play on two of my computers already (local, single player games).

Server side, I am a little fuzzy. Do I just directly copy all of the contained files in the .tgz into a jail? Sorry for the noobness…

Also, this has all started because my kids saw this youtube video linked below. It shows shadows / sky / lighting / terrain / real-looking, flowing water & wind-blown shrubs… etc… When I play single player, it looks more like vanilla minecraft. I have been trying to figure out what other mods I need to make the game look that good?..

again, thank you for the help.

Same problem I had with my kids. They bite off more than I could chew.

Not to worry, we will get you you to it.

Know that it will be one fine day, not today.

There is some ground to cover first and I have to go work now.

I will rely on others to explain and when I get home I will take this up in detail with you.

Best Regards,

tNt

P.S. In the meantime, please ensure you understand and know how to access the turnkey console and either SFTP client or a real understanding of linux commands. I recommend Filezilla and SFTP.

Ya, the turnkey console is no problem to access.

I’ll futz around to see if I can get it to work in the meantime.

Again, thanks for your help.

By default MineOS did not allow SFTP ‘root’ access.

So you have to enable that.

Then u/l the .tgz archive to the mineos archive folder. Then import that archive.

Beware: Do nothing else as root or you can brick your work. Just log in, u/l and log out. Delete that root accesws from your sftp client even.

Have to go, good luck!

tNt

1 Like

I have a few more minutes.

Create or use your own vanilla 1.7.10 mc server, name as you wish with no spaces or underlines. Letters or numbers only. This is to estabish the correct file structure.

Use ‘nano’ to edit config file to allow ‘root’.

Command: nano /etc/ssh/sshd_config

Locate and: (edit “Allow Root Login” to ‘yes’.)

Reboot.

Log on via SFTP, port 22 via Filezilla or other as ‘root’.

Navigate to '/var/games/minecraft/archive/(your server name).

U/L the tarball (.tgz) to that folder.

Go to MineOS WebUI and select “Import Server”. You should see the file you just u/l’d. If not there is a problem.

You can now delete the other vanilla server or a port binding error may occur.

Then you create your crazy craft server named as you wish.

Access with the client, enjoy!

Good Luck!

tNt

EDIT: I just realized the incorrect instuction above,

Should be: /var/games/minecraft/import and u/l the tarbal there.

Can it work both ways? Testing now.

EDIT 2: I just u/l server archive (.tgz) both ways and NOT as root but as mc.

I worked both ways also. The file showed immediately in MineOS WebUI “Import Server” and did not in “Archives”, it did show in “Archives” after a log out and log back in and may have if I would have “refreshed server list”.

Sorry to all my mistakes.

I did get the server up and running. Thanks.

I’d still like to get into making it look like DAN TDM’s video. Like you said, another day.

Ok, I get ‘50 mods loaded 49 active’.

I thought there were 63 mods. What mods are missing? Not sure yet but might be the wavey grass and clear water views.

Also, I don’t know how to work some mods like MC Helicopter. How to get it? Don’t know.

I will keep looking.

I looked around some and I think you want “Shaders” or “Shader Packs”.

These seem to be client side and not server side. Some use “Optifine”.

It is all dependent you the client side hardware and graphics card.

As such, we don’t find it installed on the crazy craft 3 server.

Google it up and youtube it to find the ones you think best to try.

Enjoy crazy craft 3!

tNt

hey, thanks for the help. I’m still trying to figure out what’s needed on the client side, and what the server actually handles. I will look for those mods and hope for the best!

That is the best part I guess. Shaders are not server dependent so as long as it serves up at a decent frame rate with little lag, it will be fine.

the shaders are client side and so use the client’s graphics card to render, not the servers.

With almost any modern laptop, the sky with beautiful clouds should be the limit!

Regards!

Forgot to mention a WARNING depending on the age of your kids.

The “Weeping Angels” mod is not for younger ones, look into that one and you may wish to disable it.

Simply re-name it to ‘weepingangels.jar.old’ both server and client side. EDIT: And restart both server and client.

That way you can easily enable it when you think they are ready.

1 Like

hi there, i’ve got some time to fart around with this again. I am hoping you could help out. I’ve DL’d the Optifine mod HERE - then I DL’d the “SEUS v10.1 Ultra DOF” HERE.

I’ve installed the optifine mod, then I unpacked all of the SEUS files in the into the .minecraft/shaderpacks. It seems, researching the net, that I should now be able to go into the Optifine profile, select the shaders… but I get the attached - see picture…

p.s. - ive been trying this out in vanilla 1.9.4 first too see if I can get this to work… and how to attach a picture?! I’ve been using the upload button, but I don’t see the picture anywheres…

EDIT: newb here… i did not know it was supposed to be left as a .zip file in the folder… :slight_smile: got it!

Ok.
@tNt may be able to help you as a personal thing, since he does this thing for his own servers.

Other than that you are now really talking about client side mods, not server side.

MineOS is a server handling software. Even thoug we should be able to support all types of servers that can be run through a phar or jar file, there is a limited amount of server officially supported out there. Server mods are not supported byt MineOS at all, since this is a server specifik thing, and has to be suppoted by the different server developers. By this I mean: We try to guide you trough all the steps of getting MineOS up and running, and getting one of the standard servers we suppurts up and running (TO specify: the servers available in the profile lists).

If @tNt can help you out further, good for the both of you. My answer that Craxy Craft is not supported out of box (from their developers) or on the MineOS side is still valid.

I am sorry for not being able to give any other answer. As I said @tNt may help you on, but MineOS official support is not there for this.