Import world

I really need help trying to import a server to MineOS. I’ve tried putting the world files into /var/games/minecraft/servers/(server-name)/worlds and just renaming the world folder from my sing player worlds to just ‘world’ and putting it into /var/games/minecraft/servers/(server-name) however any attempt would just leave me with the same inventory, position and seed as the world, but every single thing I built in the world is gone or it’s just a new seed (still with the same inventory and postition)
I’ve been trying to fix this for a long time now and I cannot find a fix. Any help would be greatly appreciated!

how are you uploading the world to your folder, also are type of MineOS platform are you using?

1 Like

This is what is preferred. Second post by hexparrot.

1 Like

This didn’t seem to work for me, whenever I would join the game it would be as if I started a new server

I’m uploading the files by running cp -R * var/games/minecraft/servers/(Server-name) while in a mounted folder which only contained the world files. I’m using putty to do this. I run the server on a virtual machine on windows 10 and access it with the web gui.
If I didn’t give the right info please tell me, I’m still really new to all of this.

Try using cp -rv and watch what is happening you might be having permission issues and using the v will give a verbose output and show any errors

OK Thanks! Is there a specific location I should be doing this or does it not matter?

Sorry for the late response

var/games/minecraft/servers/(Server-name) is correct
Check this if it helps

It’s ok, but it didn’t work, whenever I would issue cp -rv it would come up with the error
cp: missing file operand
Try ‘cp --help’ for more information.

Did you type cp -rv [world to transfer] /var/games/minecraft/servers/[servername]/
make sure / at end so the world will end up in the right place
Also make sure that the server you are trying to import into is shut down at the time.
Also you might need to delete the world first
rm -rv /var/games/minecraft/servers/[servername]/world
If you still have trouble with this try installing Filezilla or WinSCP it is more like doing it in windows than command line. then you can just copy and paste with the mouse

Ah I understand now! Apologies I was just doing cp -rv without anything after it. I will do this now and see if it works! Thanks!

I’m still having problems but I don’t know why, I put the world into the server folder using the command you told me, but whenever the server would load up the world would be a new world. I put it in the server files before and after I pressed ‘start’ for the first time, and I removed the world file that was already in there. Is there something I’m doing wrong?

Are the world folders the same name?

Yes, they were all called ‘world’

I had this same problem for a bit until I understood that there is a sub folder called ‘world’. See this for example:

You will need to use the cp command to the ‘var/games/minecraft/servers/(Server-name)/world’ folder

I’m pretty sure that’s the file I’ve been trying to replace. Unless I’m mistaken. I’ve been moving my zip file called ‘world’ to /var/games/minecraft/servers/(Server Name) after running the command rm world. Unless I’m misunderstanding, apologies if I am.

Should be not zipped or you should unzip the contents into the world folder

Sorry for the late reply
But I’m still having no luck, when I put the unzipped folder in, the player data and world seed is there but the structures are not.

Does anyone have any possible solutions? I still cannot import a world into the server

Assuming nothing’s changed since I last messed with Minecraft, your world save folder, lets call it “spworld”; in your file, world-name would need to match the save folder name if you do not rename “spworld” to the default setting/config/name of world. Under MineOS’ server directory, under your server’s name (/var/games/minecraft/servers/[server]), that is where you place “spworld”, and it should pretty much just work. If for some reason it does not and it appears you are in a new world, take a look at F3 for coordinates and compare where you are on the server vs where you are in single player aka where you expect to be; chances are you will need to travel over to the coords on the server vs singleplayer respawning/continuing at your last coords.

1 Like