How do I import an existing Server easily into MineOS?

So basically, I’m transferring my Minecraft Network from one Server Box to another, but I’m having Download, and upload all the files with SFTP, which is taking a while. And I’m trying to find out how to use the import server from archive. Do I just compress (zip) the entire Server, then upload the compressed file to /var/games/minecraft/import, and just it’ll show up there in the Web-UI, and then upload it? and it should work fine? Or do you suggest I just upload it though SFTP, which is perfectly fine for me, I just don’t know if importing is faster and more convenient.

Thanks In Advance

Preferred way is to use your favorite SFTP client, and upload the files to /var/games/minecraft/import.

At that point, log into the webui as the non-root user of your choice and choose the option ‘create server from archive’, which will take the already-uploaded zip file and extract it for you to the right place.

The server will then be listed in the dashboard to work with.

1 Like

Alright thanks, when compressing the server should I compress the server folder, or only the folders and files within the server folder?

Good question.

I’ve attempted to make it so that either should suffice–that it will identify a parent root folder and automatically move the contents up to their appropriate directory.

So, do whichever is easier for you, and if you can, let me know your successes. It would actually be very valuable to know that both work with real-world user-created archives.

1 Like

Alright, i’ll try a Development server of mine, thanks for the info! I’ll test them out

Both ways do upload correctly, but do NOT show up in the Server Area, so I can’t Start them, or do anything using the Web-UI with them. And I uploaded them with the MineOS Admin, but it said no perms in the SFTP, so I used Root instead, and chown -R the .zip to the MineOS Admin and that uploaded and worked, but doesn’t show in the server list.

did you put them in the import directory?

If so, then goto the 'import a server` page and complete the import

That doesn’t appear to be working in node.js version atm. You select the archive and set a server name - then nothing happens. Looking in the filesystem, nothing (not even the directory) gets created under /var/games/minecraft/servers/

Behavior was identical on both TurnKey and manual install on Debian.

It’s worked so far with all the server archives I’ve handled, either created from the old webui or provided to me by a user.

Since I want it to work as robustly as possible for every single user and every single archive, I’d happily test out your archives for you.

If the archive is too large, you can clear out the contents in the /world directory, as it contains the chunk data but without anything that MineOS would use to test an import.

I’m having the same problem import doesn’t work whatsoever

Have you tried Updating the Webui?
What do the logs say (located at /var/log/mineos.log, upload to a site such as Pastebin then link to the upload here).


About the previous posts from before, for some reason I have a feeling that they tried to compress multiple servers into one zip then tried import, or tried compressing archives into a zip archive and then placing in the directory to import…that’s what the first post has me thinking.

1 Like

Hella commit.

Works for me!

Cheers!

I already got it I didn’t zip the server files lol

So a little to this I’m swapping Servers. Both are FreeNas running the add on Mineos. I moved a Archive file from the old, and then put it into Import and it won’t load the old world. What am I doing wrong?