I can't update java

i can’t understood how to update hava im runni a 1.7 the ssh tells me to update it! i can’t start modpack 1.7.10 for this reason?

What have you tried so far, in trying to update Java?

I have tried with apt-get update
And with repository but it doesn’t work it says me can’t allocate

Have you looked up the errors to see potential causes?

I can sand you the ssh result

It’s probably better you just put it here, or on a service like pastebin. This way, the community can get involved and help.

this is is the minecraft crash https://pastebin.com/sUnpaWGn

root@core ~# apt-get update
Get:1 http://ppa.launchpad.net xenial Release.gpg [299 B]
Hit http://ppa.launchpad.net xenial Release
Ign http://security.debian.org wheezy/updates Release.gpg
Ign http://security.debian.org wheezy/updates Release
Hit http://archive.turnkeylinux.org wheezy-security Release.gpg
Ign http://ppa.launchpad.net xenial Release
Ign http://ppa.launchpad.net xenial/main Sources/DiffIndex
Ign http://ppa.launchpad.net xenial/main i386 Packages/DiffIndex
Ign http://cdn.debian.net wheezy Release.gpg
Hit http://archive.turnkeylinux.org wheezy Release.gpg
Hit http://ppa.launchpad.net xenial/main Translation-en
Err http://security.debian.org wheezy/updates/main i386 Packages
404 Not Found [IP: 80]
Ign http://cdn.debian.net wheezy Release
Err http://security.debian.org wheezy/updates/contrib i386 Packages
404 Not Found [IP: 80]
Hit http://ppa.launchpad.net xenial/main Sources
Hit http://archive.turnkeylinux.org wheezy-security Release
Ign http://security.debian.org wheezy/updates/contrib Translation-en
Hit http://ppa.launchpad.net xenial/main i386 Packages
Ign http://security.debian.org wheezy/updates/main Translation-en
Hit http://archive.turnkeylinux.org wheezy Release
Hit http://archive.turnkeylinux.org wheezy-security/main i386 Packages
Hit http://archive.turnkeylinux.org wheezy/main i386 Packages
Ign http://archive.turnkeylinux.org wheezy-security/main Translation-en
Ign http://archive.turnkeylinux.org wheezy/main Translation-en
Err http://cdn.debian.net wheezy/main i386 Packages
404 Not Found [IP: 80]
Err http://cdn.debian.net wheezy/contrib i386 Packages
404 Not Found [IP: 80]
Ign http://cdn.debian.net wheezy/contrib Translation-en
Ign http://cdn.debian.net wheezy/main Translation-en
Fetched 299 B in 2s (117 B/s)
W: GPG error: http://ppa.launchpad.net xenial Release: The following signatures couldn’t be verified because the public key is not available: NO_PUBK
EY C2518248EEA14886
W: Failed to fetch http://security.debian.org/dists/wheezy/updates/main/binary-i386/Packages 404 Not Found [IP: 80]

W: Failed to fetch http://security.debian.org/dists/wheezy/updates/contrib/binary-i386/Packages 404 Not Found [IP: 80]

W: Failed to fetch http://cdn.debian.net/debian/dists/wheezy/main/binary-i386/Packages 404 Not Found [IP: 80]

W: Failed to fetch http://cdn.debian.net/debian/dists/wheezy/contrib/binary-i386/Packages 404 Not Found [IP: 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

root@core ~# apt-get install oracle-java8-installer
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package oracle-java8-installer
root@core ~#

i don’t know why pastebin isn’t working for shell

 EnderIO: Found the following problem(s) with your installation:
                  * The RF API that is being used (1.7.10R1.0.2 from <unknown>) differes from that that is reported as being loaded (1.7.10R1.0.13B2 from CoFHLib-[1.7.10]1.2.1-185.jar).

This error from your Minecraft logs doesn’t seem to suggest that Java is the cause of the issue.

That said, the error you got from your minecraft crash logs could be explained through this similar issue:

Same error, general gist: you may have client mods mismatching or misplaced.

i have to use a different version of ender io?

Couldn’t tell you. I mean, I know the error refers to ender IO, but I don’t know the solution; this is all very specific to the modpack and the server software.

i have another error i need java 52
so i need to update java… how i can do it?

Unsupported major.minor version 52.0

What distro are you even using?

If you’re using MineOS Turnkey, can you provide me the URL of the ISO you downloaded, because Java 8 should already be there.

nope because i’m using 32bit version


Well, you have Debian “Wheezy”.

It’s called MineOS Turnkey because it comes with the webui, but in all ways, practically and functionally, it’s simply Debian Wheezy.

Any instructions that advise how to get a 32 bit version of Java for Debian Wheezy should work fine.

so how i can update java ?

What have you tried looking up, so far?

this but i have an error every time i try in some way :Unable to locate package default-jdk

i can’t use sudo i don’t know why