FTB SkyFactory 2.5.2 mod not up-to-date

I’ve been fighting with the FTB Presents SkyFactory 2.5.2 profile as, from what I can tell, is pulling the same mods as the 2.5.0 pack… which it shouldn’t.
I’ve tried manually removing the old mods and adding the correct versions but once the server is started back up it re-adds the old mods. Is there some way to prevent this or is there an issue with the profile that’s being provided?

hi alex463,

if i recall a similar issue i had at one time with FTB Infinity, i discovered all the mods were in the .jar itself.

so when FTB loads it extracts the mods for te server from the jar.

the solution then, is to make your own .jar.

simply take the .jar that is loading when the server starts and add “.old” to the end of any mod you do not want to start and add the mods to the jarfile that you do want to start.

if i have not made it clear let me know and i can try to explain again or i may simply do it myself anfd u/l you the new jar with the new mods in it for you.

but i would rather you try for yourself. to do this you will need to understand and access the “profiles” folder of your server, so first you need to make back ups of everything so if some mistakes happen you did not loose everything.

good luck!



i think you need ‘root’ to accomplish what you tried.

without root, the changes would not take affect.

i just thought of something else.

if you have d/l both 2.5.0 and 2.5.2 and they are in the profiles folder. before starting the server you MUST select the proper profile and add to “Live Files” before you select the CORRECT jar on the main server page of MineOS.

please ensure this is correct and fails before you try my first reply.

thanks and best regards,


that is what it is doing and it should. what i found out is that FTB always checks with the “profiles” and if something is ‘wrong’ it fixes it while loading.

so what i did to get a ftb skyfactory with 2.5.2 mods working is rebuild the files in the ‘profiles’ folder and also the files in the server folder with what my client d/l from ftb.

i’ll post the url for a working 2.5.2 archive of a working server but, my client could not connect saying “Fatally missing blocks and items”.

your client might have better luck.

ok, so here is the 2.5.2 server archive, create a server and just put it in the ‘archive’ folder of your server and ‘import’ it. java i used was 512mb min and 3072mb max.

locate the d/l password box and enter test to d/l the file at this url:


good luck!



that is the d/l pw… test

EDIT: hold on here…

i see a problem, i forgot you still need to have the correct data in the ‘profiles’ folder regardless, or you can not select the correct 'profile.

i had to modify that ‘root’ owned folder to get the server working.

let me u/l a seperate file with the folder that need to be u/l to the 'profiles folder via SFTP as ‘root’.

to do that you must be very careful not to do anything e;se as ‘root’ or you can break your server, no big deal in this case as you will have all you eed to make another. give some time to u/l that file.

sorry the delay in your server.

just extract this folder (FTBPresentsSkyfactory25Server) and copy the whole folder (FTBPresentsSkyfactory25Server) as is, to the ‘profiles’ folder as ‘root’. this will give the correct profile and jarfile once selected, to start the server.

Edit: (forgot the link), http://berryred.info/uploader/ssd/download/1465867334.zip

on another note, why don’t we crack this nut another way? i am trying it now. here is how:

create a whole new server, no profiles or anything.

d/l profile mojang 1.7.10 vanilla and run it. (start and then stop server).

d/l profile forge 1.7.10-1614.jar. select and run it. (start and then stop server).

u/l all the mods provided in the mods folder in either of my u/l’s. (extract it from the tar.gz or the .zip file and u/l as ‘mc’ or what you named as ‘user’.)

add those same mods as ‘mods’ folder to a 1.7.10 mojang minecraft client and log in as multiplayer with the ip as issued to your server.

this should work and will be in effect a FTB SkyFactory 2.5.2 server.

testing it now.

EDIT 2 UPDATE: i was unable to d/l from the ‘profiles’ page; Forge 1.7.10-latest Forge Jar (build 1614) (forge) relaese download returns:

Download failed
Remote server did not return forge-1.7.10- (status 404)

will now go to the forge website and d/l the 1614 installer. update later.

EDIT 3: http://files.minecraftforge.net/maven/net/minecraftforge/forge/index_1.7.10.html

d/l both 1.7.10 - installer for server side and installer-win for client side.

add as ‘mc’ or your ‘username’ to main 'server/(servername) folder and run it from MineOS. ie: /var/games/minecraft/servers/(servername)

1.7.10 - installer-win needs to be run in the minecraft client folder. ie: C:\Users(username)\AppData\Roaming.minecraft

1 Like

forget everything above as i made a fatal mistake, the server worked, up and running but the ftb launcher could not log in.

i have now fixed that problem but it required different server files that i am u/l for you all now.

link and instructions soon.

best regards,


The easy answer is to not use profiles. A “profile” is a set of files that exists in /var/games/minecraft/profiles/someprofile. If a profile is set, MineOS copies these files to the server’s live directory, e.g., /var/games/minecraft/servers/myserver. Such a copy occurs either when a server is started or when “copy profile files” is manually clicked.

If a profile is not set, (or if it was once set, and then subsequently set to none), this copy will no longer occur on each server start. A profile is not required to start a server; profiles could very literally be 100% ignored and still have a working servers.

Unsetting a profile does not affect any files in a server’s directory; it merely prevents the profile directory from being copied over (and potentially undoing changes you’ve made to the jars/plugins).

we got a FTB SkyFactory 2.5.2 confirmed up and running.

here is how: Help installing SkyFactory 2.5.2!

Have Fun!


Perfect! Thanks for all the help here. Glad to have it all running :smiley:
Now hopefully I don’t have to touch it for a long time

A guide has also been created here:

Have Fun!