Fresh Install of Mine OS and Web-UI does not load


#23

I actually have a remote management controller pre-installed in the system. It’s setup for Dell OpenManage. The only thing is that I rarely use it.

But an update on the status:

I did a fresh install and got it running. I can’t access the Web-UI as yet. Still trying though.


#24

Ok following the steps you gave me in exact order I made sure I did not make any typos.

Here is the output log of /var/log/mineos.log:

{“level”:“info”,“message”:“Starting up server, using commit: 0e45be7 disabled mcquery on phar servers\n”,“timestamp”:“2016-04-17T22:40:08.988Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 0e45be7 disabled mcquery on phar servers\n”,“timestamp”:“2016-04-17T22:44:22.050Z”}
{“level”:“info”,“message”:“Starting up server, using commit: 2d22dc1 Merge pull request #185 from hexparrot/revert-182-assorted_fixes\n”,“timestamp”:“2016-04-18T21:08:06.836Z”}

The /usr/games/minecraft folder is as follows (I had to use an imgur link because it was too big):

http://imgur.com/KBaOVMT

The command supervisorctl status mineos gives me mineos at the top with no other processes running.

Unfortunately I am still unable to access the mineos Web-UI


#25

Edit 1: I followed the steps in resetting the Web-UI and everything seems to work. I will post an update once everything is running.


#26

I don’t understand what you mean by this.

What does the actual command report? Because I expect something like:

root@mineos games/minecraft# supervisorctl status mineos
mineos                           RUNNING    pid 986, uptime 0:14:35

The reset procedure or the webui?


#27

The actual report looked exactly like what you said:

I followed the reset procedure for the Web-UI.

Also when trying to import a server It will not let me select the Spigot jar and the profile is blank.


#28

If you’re importing a server, it’s likely coming with the necessary jar, so a profile is not necessary. A profile is not necessary at all to start/manage a server–it’s only used to insert the files into a server that doesn’t have them yet.

What does /var/log/mineos.log say?


#29

/var/log/mineos.log (I had to use a link as I was unable to upload it to the forums): https://www.dropbox.com/s/urw8of2n6gvdms5/mineos.log?dl=0

When I import the server it will not start unless I select a profile and the jar file that I select which is Spigot 1.8.4 (for compatibility reasons) just shows up for one second and then disappears.

Here is a .zip file of the whole server (around 783MB): https://www.dropbox.com/s/zcymhordaq26ah9/Backup%201%20%281%29.zip?dl=0


#30

Is this mineos.log file complete? It doesn’t indicate the server ever started (when it starts it reports what commit it is). That means over the course of the entire file, the webui hasn’t been restarted even once (is that accurate?)

In addition, the timestamp says 2015-10-08–is this also wrong?

module.js:310:12)"],"level":"error","message":"uncaughtException: Module did not self-register.","timestamp":"2015-10-08T16:58:40.882Z"}

This error indicates that the webui commit being run doesn’t seem to match the last time npm install was run (from the update/reset instructions).

All these things point to an improper config that you can fix through the reset process. Again, the only way that the new files get loaded into memory is also if the process is restarted, so supervisorctl restart mineos.

Then we can start again and let me know if you still have the same problems with the dropdown and etc.


#31

Ok just give me a few days and I will get back to you ASAP. Going to try the steps on the weekend as I don’t have time at the moment.


#32

Ok so first off sorry for taking a while had go out of the U.S for a bit. Also I tried your steps and I am still getting the error. I am importing a server from a zip file. I am also using the latest build tools jar file with spigot. The Web-UI is loading properly but I cannot start the server. If I start the server it posts to the log page on the Web-UI and shows that the server is starting up properly but I cannot connect to it.


#33

What does it say/show on the log page? (Or what does it say/show in the server log that’s in the server directory (the one located in “/var/games/minecraft/servers/servername/logs”)?)

It’s probably a jar/server problem and not related to the UI if it starts and leaves a log. The logs will help us to determine the problems, and it’s solutions.


#34

Ahem, I have D/L your .zip and preparing to import.

  1. Of note is that I do not find Spigot in the Profiles page of MineOS.

  2. I see the spigot-1.8.4,jar in you .zip file, the question is what version of Minecraft does it require?

  3. I think if you d/l the correct version and select it in your profiles and add to your live server files, it may start.

Edit: 4 Your Memory Allocation (Heapsize) -Xmx is 256MB

Edit: 5. Your server port is 46034, did you open that port in your IP tables? In fact your whole server config is a mess so I have to also ask: Why wouldn’t you just attempt to get one server up and running with little or no change, then once established make the changes one by one as you go along then you could troubleshoot issues as they come up.

max-players set at 10,000? come on man, how are you going to do that with you max java heap is 256mb?

Edit: 7. I can confirm this server as is will in no way start on MineOS.

Edit: 8. Just for fun I d/l minecraft 1.8.4 jar, set in profiles and select the mincraft_server.jar, to no ones surprise it crashes, and spigot still will not start when selected. So my idea at 3 above did not work either.

My advice is to start over, you have bitten off more than you can chew here.

Edit: 9. What Brandon_Veerasammy here has done is take an existing server from who knows where and tried to import it into MineOS.

Where did it come from? what OS was used to make it? Why has he come here looking for answers when it can not ever work on MineOS? Going all the way back to his first post indicating a dell server and trying with no luck to get MineOS up and running, I question his overall motives and ask is he a troll?

Whatever Brandon_Veerasammy Good Luck to you getting that server up and running, ever. I have wasted enough of my life on it.

Edit: 10. Looking at this server files again, it has piqued my interest to see what can be done to make it run. So it seems I have NOT wasted enough of my life on this yet.

Edit: 11. I have the spigot server up and running. I do not have a spigot client or whatever is needed to ‘enter’ the game so I don’t know how ‘well’ it is running. If it is stable later I will generate an archive and u/l it for everyone to try.

Best Regards,

tNt


#35

Ok First off just to mention I took it from a live server that was hosted through a hosting company. I know the config was a mess and the player count is a mess because I had unlimited slots and 2GB of ram. I have 4GB in the server running MineOS. Also Just to mention you don’t need a spigot client to run it just use the regular minecraft client. Its just a modified version of craftbukkit that’s optimised for low usage.

Edit 1: The config file was made by the hosting company and I need to fix it.


#36

I am u/l a working server for you now. I have had it up and running over 2 hours now so I think it is stable.

I only understand forge so I can not learn spigot fast enough. You will have to tell me if it works or not.


#37

Thank your for your time. I will gladly test it and report back.


#38

U/L is at 32% so stand by for the d/l url soon.


#39

That’s great! Thanks for your help so far.


#40

So your server is ready at: http://berryred.info/uploader/ssd/download/1462035177.tgz

Scroll down a bit until you see the “Download Password” box, there enter the PW 4Brandon

Then click the button below and your 788.7 MB d/l will start.

Anyone can play but be clear the server settings are all MineOS to available port and set to ‘easy’, ‘creative’ and heap is 512mb to 4096mb. brodcast is on, place the file in the ‘Import’ folder, then import the server.

Best Regards and Good Luck!

tNt


#41

Oops, forgot to mention that I did d/l mojang 1.8.4 and it was installed in my profiles folder and I did use it.

If it made any difference at all, I can not say,

Edit: Also, the original filename is: server-Test4Brandon_2016-04-30_00_24_57.tgz

Not sure if that matters or not.

Again, Good Luck!

tNt


#42

Still testing the server but just to ask why did you use a chinese upload site?