Fresh Install of Mine OS and Web-UI does not load


#1

Ok this is my first post here so here it goes…

Hi,

I have a fresh installed Mine OS server running the newest Web-UI on a Dell Poweredge 840 with 6GB of ram. I just installed the new ram and rebooted the machine and the web-UI does not load it just says cannot connect to address in google chrome. Also I will be willing to provide any logs or photos if anyone needs it.

Thanks


#2

2 things:

1: Are you sure you’re connecting correctly? (using https://IP:8443 replacing IP with the server IP)
2: Which Linux Distro are you using?


#3

Silly but with the Dell server on, can you confirm the MineOS server is on by connecting at all?

root@IP:22 via SSH or SFTP?


#4
  1. I connected to it once using the port 8443

  2. I am using the Mine OS Debian Jessie Linux Distro


#5

I can use SFTP but not SSH


#6

Did you “git fetch” to update your MineOS commit on your brand new install?

You may be having the same issues I had in another thread. In that case I was able to get a log in page at https://IP:8443 after a hard reboot of the server. But only for a short time.

Good luck.


#7

Not to sound rude but first off I tried git fetch and it does not work I will try it again and see. Also how did you do a hard reboot of the server. I am running this on a Dell Poweredge 840 with MineOS set as the only OS on the whole system.

Edit1: git fetch does not work and gives me an error of no git respatory


#8

Not rude at all, do not worry about that.

To sound rude (see avatar), a bare metal dell poweredge 840 server should not be unlike mine, a dell powererblade3 and it can in no way only have a mineos set as the only os on the whole system. Ever. At all. Full Stop.

So, do you have Freebsd? or Ubuntu14? VMbox, VMWare? Or what do you have? Exactly No Nonsense Please.

Perhaps your poweredge is nothing like mine. Explain.?

Thanks and Best Regards,

tNt


#9

Could be an internet/DNS issue, verify by doing “ping google.com -c 1” and if it works, then it is not an issue, and is an issue with the way you’re trying the command. If you do have internet access (able to ping Google), then follor the steps to update/hard reset the Web UI here.


#10

My internet/DNS works fine I use Open DNS and google’s DNS servers. The git fetch gives me an error that says (most accurate that I can type it) no git repository to fetch.

Edit1: I tried this and the directory /usr/games/minecraft does not exist.


#11

If you don’t mind would you be able to explain what you are saying in more detail. Also I am just running MineOS not windows server or anything else. Its a stock Dell Poweredge 840 that I got used on ebay. I just upgraded the RAM from 2GB to 4GB and it gave me this problem.


#12

@JayMontana36, I sure hope you know what is going on here… because i am clueless

best regards,

tNt


#13

What? How? Dunno how tew dew?


#15

Yes I don’t know how to do it. I mostly work on mac usually and don’t know a lot about linux.


#17

You see I am not a troll this is a legitimate question. I just tried to provide more info I am new to linux. You are a great person.


#18

SFTP and SSH are the same protocol–all logins should work equally well between the two; they are the same port running off the same server-side service.

Ok, so here’s what we need to do, as you are running Debian Jessie (MineOS ISO).

First and foremost, let’s get on the actual machine–not your desktop, but the actual server machine, keyboard and monitor.

  1. Log in as root. You set this password upon the first install and you should be able to log into root directly.
  2. supervisorctl status mineos – share the results of this with us, as this tells us whether it is running at all. Likewise, top would show mineos but the former is a better command.
  3. Share with us /var/log/mineos.log – If mineos ever worked, this file will exist.
  4. ls /usr/games/minecraft – let us know the results and/or any errors.

The only way this could happen is if you deleted it…honestly no other way this could be absent especially if you successfully logged into the webui for this install. I would venture that since this server is not actually in production, that more than likely a full re-install is the quickest, easiest course of action. Even those other steps would be futile if you accidentally deleted this directory somehow.

Some informational tidbits:

  1. When connected directly to the server (via keyboard/monitor), you can log in directly as root and mc.

  2. When attempting SSH/SFTP, you can only log in directly as mc–this is by design (a security-minded decision). If you ever attempt a login and it doesn’t work, the only way for us to provide meaningful explanations is if you’re also able to provide the exact error received from your client.

  3. When running any linux-based console commands, again the best way to get help about a particular step that fails like “/usr/games/minecraft does not exist” is to copy the full command as you typed it and the error. As an example, when I search for MineOS on my macbook pro (which doesn’t have MineOS installed), I get an error: I would provide all the following for help:

    MacBook-Pro:~ will$ ls /usr/games/minecraft
    ls: /usr/games/minecraft: No such file or directory

You’ll notice it simultaneously let’s us know 1) you didn’t make any typos 2) where you typed it in, and 3) precisely what the shell tried to do and failed.


#19

I would recommend just reinstalling from scratch (if you had any servers up you can copy them out and back into the new install) as it’s the quickest, or you can follow the MineOS Debian Install Guide.


Mac OS’ command line is almost exactly the same as Linux’s, as Mac OS is based on Linux, except that different distros have different commands but most of the basic/main commands are the same.


Well now I’m curious as to how one would get MineOS running on Mac OS, but I’m pretty sure it would be moderately easy, if you can grab and manually install the dependencies or some of the programs/components that other Officially Supported distros contain. I’ve never had a Mac and I probably never will to be honest (I have my reasons).


#20

Thank you for the information. I will try these steps and report back in a few days.


#21

Thank you for your help also. Going to try the steps by @hexparrot first.


#22

Boy am I a dummy, i guess you can.

But Systems Build and Update Utility is still required (“bootable utility for a single server Operating System install … pre-OS system configuration”).

Here is an old video that shows the process to do an installation with the SBUU DVD.

Then you would install MineOS, VMware, FreeNAS, Linux or Windows Server I think.

Some people would use Windows Server then run a VIrtual Machine software on that to install MineOS. I went straight for the VMware so I can have many Operating Systems on one Dell headless server. I control it on my laptop with vSphere.

It depends on what you are comfortable with I suppose.

Good Luck!