Forge 1.9; can't load a mod under /mods

I am not certain where I am going wrong, but I dumped the DynMap .jar file under the /mods sub-directory on my server but it never attempts to load it.

What am I doing wrong? I should see errors or warnings at the very least in my console, but I don’t see any indication that the server is actually loading my DynMap .jar file.

Thanks for any input

This is not really a MineOS issue, since MineOS only handles the minecraft servers. Each server must handle any mods itself, so you should possibly check with the Forge forums:
Or the Dynmap help forum:

That being said, where did you get the dynmap jar from? You are positive it is a forge mod, and not (for example) the bukkit/spigot plugin? I have never tried, but I cannot imagine that mods from forge and plugins from bukkit are interchangeable.

You also have to make sure that the version of dynmap you are running are compatible with your forge version


This is the file I was trying with, but obviously it’s for 1.8.9 but in theory I should still be getting a set of errors and warnings, no?

I know it’s not really a MineOS issue but thus far I have had a tough time getting answers from anywhere else. If I could get an error, I’d be happy to know that the reason it won’t load is because of said error, and wait.

On a side note, I got overviewer to render my world, but it isn’t live (from what i can tell) like dynmap was, or more-so I missing a step in having it run.

It also doesn’t act as its own web server, so I am going to require myself to build a small apache server to get it to show up on a website.

Thanks for your input.

I’ve only really used bukkit for plugins and mods, so I can’t really answer for forge. I do agree however, that you ought to get a warning or error telling you that the plugin was ignored due to whatever reason.

But no, I am not convinced that the minecraft 1.9 version of forge supports the version of Dynmap for 1.8.9.

No, forge and bukkit aren’t at all similar with the way plugins/mods work (for example, some bukkit plugins made for older versions of MC will still work on newer/recent versions of MC, meanwhile a mod made for MC 1.5.1 will NOT work for MC 1.5.2 and vice versa, and with the changes made from 1.8 to 1.9 there is no chance of the mod working, but I do get where you’re coming from with the mod just being a simple live server map mod, not affecting players at all)

That being said, any ideas on being able to get it going, or at the very least some troubleshooting to see why the mod isn’t even attempting to load?

Well, possibly if you upload the latest server crash-report log or normal logs here or to pastebin and share the link here.

I have an idea!

Some mod jars are client side only and if you put them serverside will actually crash mincraft. (Not your issue, I know).

Nevertheless some mod jars are unoversal and can go on both server and client, some are not.



Hmm, good point. Place a client-side (only) mod in the mods directory which should either crash or report errors/warnings which would tell me my server is trying to load mods correctly

Thanks for the idea, I’ll give it a go :slight_smile:

I mean if a mod is client side only it could crash you or simply not load, (you may not get a log entry).

Try NOT placing the Dynmap-2.3-alpha-2-forge-1.8.9.jar in the server mod folder, put it in your minecraft client mod folder, if it works in your client then it is not needed serverside.



Well, I would imagine Dynmap wouldn’t be a client side since it reads the server files to populate a map with all the chunks, player placement/location, etc.

I can definitely try it though

It was because my “journeymap” mod only works client side and not serverside.

sorry if it did not work as I never tried the Dynmap-2.3-alpha-2-forge-1.8.9.jar.

I built a test 1.8.9 server and downloaded the appropriate forge installer/universal from

Dynmap v2.3-alpha-1 for MC 1.8.9 (Forge 11.15.1+)

Downloaded DynMap from here:

The pastebin is a log of my errors.

I don’t get any of this when I load up my 1.9 forge build.

So you have a server with java7.

And your jar is for java8.

Do I see this wrong?

I may be wrong, just mad at java8, lol.


Oh, I did follow a guide that told me to download/install JRE 7 and not 8.

Can both be installed and running simultaneously ?

EDIT: where does it show that the JAR requires java8? I see the line about using 1.7.x.x but I can’t seem to find the line about requiring java8

OK, then not java 8.

how about minecraft 1.7.10 (1.7.xx)?

You have Dynmap v2.3-alpha-1 for MC 1.8.9?

EDIT: afaik only one java can run at a time.

I dunno. Sorry.


Yeah, the links I provided show which version of forge works with which version of minecraft.

Then you need to make sure the mod works with forge. DynMap is typically a bukkit mod, but the devs helped get a forge version out.

So, I have all the ingredients to make this recipe work, but I am failing at making the souffle! :slight_smile:
I will keep working at it, but I am starting to wonder if overviewer on a scheduled interval + apache on a server to host it will be what I need (until DynMap updates to 1.9 and 1.9.2)

DynMap acts as its own web server on port 8123 (by default) so it was easy to deploy and ran great.

Dynmap is meant to be server sided, not client sided.

According to the logs, it definitely is Dynmap that is errored. From what I see it has something to do version-wise “Unsupported major.minor version 52.0”. A little research on this particular error (Googling that quoted error) shows that your problem is with your Java version. According to the logs you’re still on Java 7 and not Java 8 (when it comes to Minecraft there is no real reason to still be on Java 7, but in general Java 7 programs/plugins/mods run with no problems under Java 8) so the first solution I’d try is getting rid of Java 7 and replacing it with Java 8, or just setting Java 8 as default.

I’m assuming you already have the WebUpd8 PPA for Oracle’s Java but if not, add it with “add-apt-repository ppa:webupd8team/java” followed by “apt-get update”. Run those commands with sudo/root.

If you will remove Java 7, do that now.
Install Oracle Java 8 with “apt-get install oracle-java8-installer oracle-java8-set-default” (this will also set as default in case you did not remove Java 7).

After this, Dynmap should run fine.

Actually, I believe I used the open JRE version but I’d have to check

Thanks for the info. I’ll update now and retry all my efforts thus far.


You helped fix it! :slight_smile:

Having java8 installed helped return this error, which is exactly what I need to confirm!

Current: Minecraft 1.9
Expected: [1.8.9,1.8.9]
Location: /var/games/minecraft/servers/Gilead_forge/mods/Dynmap-2.3-alpha-1-forge-1.8.9.jar
Mod: Dynmap
Wrong Minecraft Versions!

Thanks again for your help!