Backup of profiles

Hello there

I had to install mineos turnkey new and already got the backups up via ftp and mv’ed them in /var/games…

At the moment I can’t go online with the server to download the profile files, so I thought putting the profiles in var/games/minecraft/profiles would do the trick.
But the webui doesn’t show the profiles.

Is there a trick I don’t know of to help me out of this disaster or do I have to wait till I habe Internet again?

Kind regards

If you did a full backup (archive) of the servers, or copied the entire contents of the /var/games/servers/ folder, you do not need to download profiles. The servers should have the jar- (or phar-) files they need in their respective folders.

the profiles work by being a central repsository of the files servers need, but the servers them selves need the files in their own folder (due to how the servers and jar files work), so after you have downloaded your chosen profiles under profiles, and chosen the wanted profile in the server, the necesary files are copied to the server folder. This means that the files you need should be in the folder all ready.

The first (and easiest) thing you can try is to simply press start on your servers. Missing profile do no tmatter, since the jar file used is defined in the file /var/games/minecraft/servers/servername/server.config

If this do not work, you have to copy the name of the jar file you wish to use into the apropriate line in server.config.

I will try that out tomorrow. Thank you very much

Those you can simply place in the /var/games/minecraft/import directory, and from the WebUI you can use the “Import A Server” option to import them.

You’ll have to actually manually “Create New Server” for every server, then browse to the directories of each server, and then upload the server’s files (overwriting existing files) one server at a time; and if you don’t do that, you won’t be able to just copy the files back (as you’d have no permission for the /var/games/minecraft/server directory) and if you use root to get around it you’ll simply run into many problems caused by messed up permissions.

You’re better off just adding the archives into the /var/games/minecraft/import directory and importing them with the WebUI (or if you go the long route by recreating every server then adding/overwriting existing files). But anyway after importing, you can just click start, and it should start. If not, there will be a pop up showing profile and jar options, ignore the profile option and just select the jar from the server directory to run. Also configure the ram settings if they’re not already set how you want them.

You are correct, but I assumed the files where allready moved into the apropriate folders due to how the request for help was made:

Therefore I only saw the need to clarify how the profiles worked.

If not mistaken, the ‘profiles’ directory is owned by root and might need to be considered when developing your protocol to activate a new distro.

Not really in this case.
This only comes into play if anything should be copied straight into the profiles directory. In this case, with backups, the servers already has all the files necessary available.

Modifying the contents of profiles is not really necesary either, since you can put the files into the server directories directly in stead. I would, rather than messing around with root and the profiles directory, rather create a separate directory for manually downloaded jars and phars, if you need a separate storage of them rather than copying them between servers if you need a jar on more than one server.

1 Like

Exactly. With his original post in mind, I made my comment in the hopes he would follow one of the options you guys gave, instead of following his next logical step of using sftp to access profiles. It looked to me like that would be where he would be going next based on his OP of course.


I found some time to get at it.

The Archives have the jar profiles in it. After moving them to /import I could select “import a server”, but the executable jar is still missing.

I can’t even do like iMelsom said (creating a new server) , because of the missing profiles.

The .jar file name is correct in server.config.

I also tried moving them to /backup and /archive, didnt’t work too.

so…any more ideas?

Ok, let me see if I understand this correctly:

  • importing the archive produces the server correctly, with the jar files corectly placed in the respective directories.

  • the correct jar is listed i server.config

  • but the file is not listed in the WebUI, and the pull down menu where you choose the runnable jar?

As lon as the correct file is entered in “server.config”, what the WebUI say may not matter. I have this happend occationally as well. Just try to press start. Either a popup appears asking you to specify profile and jar, or it starts. If it is defined in the config, my guess is that it starts up just fine :slight_smile:

The correct .jar is listed in server.config

the jar file is in the server directory, just like “server.config, eula, logs, world and so on”

before I tried it with the jar files in /var/games/minecraft/profiles , didn’t work

the pull down menu doesn’t show anything under “change profile to” nor under “change runnable jar to”
I also have to allocate the memory, but I think, thats pretty normal

Edit: If I just allocate the memory and press start the window closes. If I click start again, it wants me to select a runnable jar

Ignore the pulldown for now (@hexparrot will frown upon me for saying so;D ).

Set the memory allocations.
Then SSH back in and edit the server.config. (enter the server directory, mark the filename of the jar you wish to use with your mouse (you do not need to do anything else, it is autmagically copied). open server.config in your prefered editor, when you are able to write in the correct position, simply right click your mouse, and the filename will automagically be pasted in. save and exit)

I think the server jar refernce has ben removed when MineOS added mem-allocations with a no jar selected in the pulldown. If ou edit it back in manually, then press start without doing anything else that might trigger the WebUI to write to server.config your server will most likely start.

After importing a server, you should click your username in the top-right and click refresh server list, then try it again. If that doesn’t solve the missing jar problem, then refresh profile list and if that still persists, either restart MineOS or reboot the server and try again, if that still doesn’t work then come back and tell us. Sometimes a refresh is needed for jars to appear (based on experience of that in the past).

1 Like

@iMelsom did as you said, sadly it doesn’t find the jar.

@JayMontana36 tried it a few times, doesn’t work either.

Both methods should have yielded result. The method I described works for me on my server, and is also the method I use when tinkering (and forcing) new servertypes to run.

Do you have the log files available? Although if it stops you at start by asking for jar, I think you wont find anything.

1 Like

The last log is from playing before the new install.

Here we have what is inside the server file.
And whats inside server.config.

Would love to upload you screens of the file and inside of server.config, but
“Sorry, the file you are trying to upload is too big (maximum size is 3072kb)” pops up.
(jpegs are max 80kb) >.>

This here is in server.config





any more ideas?

Yes, but unsupported at this time.

Let me get my links together. Stand by.

Go to

Download the version you require in ‘Installer’ and ‘installer-win’.

So that the jars are the same on the client and the server, execute the installer-win clientside.

Also install the ‘installer’ jar serverside into the ‘profiles’ folder.

To do this ‘root’ is required.

Not only that you have to put the ‘installer’ file into a previously made folder that should be there, created when you were able to d/l from the WebUI, when you had Internet. Something like “1.8.9” or closely named folder already existing. Very important you use a folder that was already there.

It should then show up in the drop down box as “installer”. select it and click start.

The server should start then stop after a minute.

Then a new jar should list in the drop down box. That is 'universal, select it and start your new server.

Good Luck.

(Do NOT use root for anything else except to place the ‘installer’ jar into the ‘profiles’ folder.)


Sorry, one of those “Have you rebooted the computer” annoying questions coming:
Are you absolutely sure that the file “minecraft_server.1.8.9.jar” is located in the minecraft server directory that belongs to the server you are trying to start?

And if list the contents of the server folder with the command
ls -lsa
Does this line pop up?
8128 -rw-rw-r-- 1 mc mc 8320755 Dec 10 03:21 minecraft_server.1.8.9.jar

It needs to be in the same direcory, and it needs to be owned by the user and group mc (or the not root user you use to manage your servers). In fact: all files in that directory should be owned by that user.

the server.config line in direcotry contents should look like this:
4 -rw-rw-r-- 1 mc mc 120 Mar 31 09:15 server.config

To compare: This is the file contents of a pure vanilla server I am running, so a ls -lsa you run should look something like that:
mc@MineServIV:/var/games/minecraft/servers/Underminer_Survivor$ ls -lsa total 25472 4 drwxrwxr-x 4 mc mc 4096 Mar 31 09:03 . 4 drwxr-xr-x 14 mc mc 4096 Apr 20 01:03 .. 4 -rwxr-xr-x 1 mc mc 8 Jan 26 16:48 admins.txt 4 -rw-rw-r-- 1 mc mc 2 Apr 20 14:11 banned-ips.json 4 -rw-rw-r-- 1 mc mc 2 Apr 20 14:11 banned-players.json 4 -rw-rw-r-- 1 mc mc 89 Jan 26 16:23 cron.config 4 -rw-rw-r-- 1 mc mc 9 Jan 26 16:18 eula.txt 4 drwxrwxr-x 2 mc mc 4096 Apr 28 22:26 logs 8128 -rw-rw-r-- 1 mc mc 8320755 Dec 10 03:21 minecraft_server.1.8.9.jar 8644 -rw-rw-r-- 1 mc mc 8848002 Mar 31 09:03 minecraft_server.1.9.2.jar 8644 -rw-rw-r-- 1 mc mc 8848015 Feb 29 15:18 minecraft_server.1.9.jar 4 -rw-rw-r-- 1 mc mc 135 Apr 20 14:11 ops.json 4 -rw-rw-r-- 1 mc mc 120 Mar 31 09:15 server.config 4 -rw-rw-r-- 1 mc mc 884 Apr 20 14:11 4 -rw-rw-r-- 1 mc mc 858 Apr 27 17:00 usercache.json 4 -rw-rw-r-- 1 mc mc 2460 Mar 20 16:18 whitelist.json 4 drwxrwxr-x 8 mc mc 4096 Apr 29 18:08 world

I ask, because if the server jar is there, and it is correctly defined in server.config the serer should start!

Hello again,


ls -lsa says (I can’t copy it, sorry)

"Total 52
then those thingys with -rw-rw-r-- and then:


I think the Problem is worse than I thought it is…

The second thought I had is: Installing ubuntu 15.4 (have it on dvd here)
and installing the server on it. So I can use the tethering via mobile phone and get all the shit done. what do you think?