After rebooting my unraid server, my server disappeared from the UI (but it still shows as running)

This has happened twice now. Whenever I reboot my Unraid server, my server disappears from the “currently selected server” dropdown. MineOS is running on a Docker container that I installed while logged in as the root user on my Unraid server. I log into MineOS as the “mc” user. If I check the permissions on my servers using ls -la /var/games/minecraft/servers, it shows that my server is owned by mc and the . and .. are owned by root. I’ve tried logging into MineOS as root using the default password (mypass) and my Unraid server’s root password, but I just get authorization errors. I can only seem to log into MineOS as mc.

What should I do to fix this and prevent this from happening with future servers?

Edit: I logged out and relogged into MineOS like 3 times and it miraculously appeared again. Weird.

I’ve seen this, but simply refresh the webui page lists the available servers. I would try to update the commit then reset.
https://minecraft.codeemo.com/mineoswiki/index.php?title=Updating_the_Webui

So it happened again, but not from rebooting my unraid server. I’ve had an uptime of almost a week, it just seemingly randomly happened. I went ahead and updated the webui, it’s up to date. Restarted the docker container too.

About a day ago it seemed to do it where my server list just disappeared, but the server was still running. Now the server stopped running but I don’t know why because the server list disappeared.

Which browser are you using? Are you accessing the WebUI on a mobile device? Recently, I haven’t seen this issue since I upgraded to OS completely and used Chrome instead of Internet Explorer, but also had this on Safari mobile as well.
(Had to update for due to several issues)

I’m using Google Chrome. Just tested it on Edge, same deal, server just disappeared. Also tried it on Google Chrome on my phone and it didn’t pop up.

Looks like the server isn’t running at all, when it first happened the server kept running even though it was completely gone from the UI. The last few days the server’s been offline. It just completely disappeared which is very frustrating and doesn’t make me feel confident about MineOS. I mean, the files are at least still there, but I don’t want to have to do this every week where I reinstall MineOS and import the server as if it’s a new one.

(Sorry just venting a little :P)

I haven’t seen others having these sort of issues. Something else you can try is to spin up a virtual machine and install the latest version ISO to test. You might be running into a java issue like I had. (I was also unable to update the OS because the repository was unavailable.)

I actually figured it out and I feel kinda dumb. I’ll post the solution here in case anyone else finds this thread and has the same issue:

SOLUTION: This issue is kind of specific to Unraid OS and running MineOS as a Docker container:

If you have file permission issues and you choose to go to Tools > New Permissions (On UnraidOS, this isn’t a MineOS setting) and run that setting on your appdata folder, MineOS will stop seeing your servers. It will set the permissions to 99 which MineOS doesn’t like. I haven’t had issues with any other dockers and it’s something I’ve run in the past when dealing with some files being created as a root user but I digress.

Open the MineOS console and run: chown -R mc:mc /var/games/minecraft

  • chown = change ownership
  • -R = recursively (changes for all subfolders and files within the selected folder)
  • mc:mc = gives permission to “mc” user and “mc” group. It won’t work with just mc, you need to add the mc group.
  • /var/games/minecraft = the folder with your archive, backup, import, profiles, and servers.

You can double check the permissions using: ls -la /var/games/minecraft (this just lists out the folders at that location with their permissions).

If you are still having permission issues, try running: chmod -R 777 /var/games/minecraft. This works like chown but changes the read, write, and execute. You can dive in dive in deeper about why 777 but it’s basically a binary shorthand. It gives everyone permission to do whatever they want with the files.

Running ls -la /var/games/minecraft should look like this by the end of it:

Capture

Someone can correct me on if changing the permissions to a very lenient 777 is a risk, but I don’t think so because you’re running in a Docker container that no one else can touch.


Honestly I’m not entirely sure if this was the issue I’ve always had, I definitely feel like I’ve still seen my servers disappear and reappear from the list. But this seems to be at least the solution for the latest time I’ve had my server disappear. Also, my title is wrong and it wasn’t caused by a reboot. I think I must have ran it before a reboot and the settings took effect after a reboot because MineOS restarted and rechecked the permissions or something.

Hopefully this helps someone. :slightly_smiling_face:

3 Likes

Thanks for this wvw

Im an unraid / container user too. I had awful UI issues when starting the container on multiple occasions such as the login page working but the backend personal settings were just blank- Seems like your comments have helped me out.

1 Like