Getting "Error: not found: make" when trying to update the Web UI

I’m trying to update the Web UI and most things I’m doing are getting the same error, “Error: not found: make”. I tried googling and found this thread but the user didn’t say what the fix was and linked to a dead site.

Here’s what happens when I try to do npm install --unsafe-perm

# npm install --unsafe-perm

> posix@4.2.0 install /usr/games/minecraft/node_modules/posix
> node-gyp rebuild

gyp ERR! build error 
gyp ERR! stack Error: not found: make
gyp ERR! stack     at getNotFoundError (/usr/lib/node_modules/npm/node_modules/which/which.js:13:12)
gyp ERR! stack     at F (/usr/lib/node_modules/npm/node_modules/which/which.js:68:19)
gyp ERR! stack     at E (/usr/lib/node_modules/npm/node_modules/which/which.js:80:29)
gyp ERR! stack     at /usr/lib/node_modules/npm/node_modules/which/which.js:89:16
gyp ERR! stack     at /usr/lib/node_modules/npm/node_modules/isexe/index.js:42:5
gyp ERR! stack     at /usr/lib/node_modules/npm/node_modules/isexe/mode.js:8:5
gyp ERR! stack     at FSReqWrap.oncomplete (fs.js:152:21)
gyp ERR! System Linux 4.19.107-Unraid
gyp ERR! command "/usr/bin/node" "/usr/lib/node_modules/npm/node_modules/node-gyp/bin/node-gyp.js" "rebuild"
gyp ERR! cwd /usr/games/minecraft/node_modules/posix
gyp ERR! node -v v8.9.4
gyp ERR! node-gyp -v v5.1.0
gyp ERR! not ok 
npm ERR! errno 1
npm ERR! posix@4.2.0 install: `node-gyp rebuild`
npm ERR! Exit status 1
npm ERR! 
npm ERR! Failed at the posix@4.2.0 install script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR!     /root/.npm/_logs/2020-06-18T16_23_26_176Z-debug.log

I’m running MineOS in a Docker container on Unraid OS.

I’m not familiar with Unraid OS, but I assume it’s just running a container based on the original dockerfile. (correct me if unraid uses any different dockerfile than my official one). I do know that there are many nodejs modules that need to be compiled natively for your system.

In most circumstances, this is apt-get install build-essential or yum install gcc-g++ or something to that effect. These packages include the binary make which is at the crux of your error.

My dockerfile does not include build-essentials because it was my understanding that docker containers would be rebuilt, rather than entered and edited.

No worries, though, it’s possible to do things how you are:

Basically, while inside the container:

# apt-get install -y build-essential
# npm install --unsafe-perm
1 Like

apt-get install -y build-essential wasn’t working until I did apt-get update (just in case for anyone else reading this and has the same issue).

But that did work! Thank you!