Wrong characters shown in WebUI


#1

Hi. I’ve got a problem I’m unable to solve.
In fact, if I start servers in /var/games/minecraft/servers via console commands, I can see every character shown right.
But when characters are shown in Web UI, there are small little squares after every color change, like this:

While they are not present via a normal SSH shell:

I’m running MineOS commit c2db54e on a Debian 8 x64 machine. I have tried reinstalling every font package, re-building fonts cache, generating new locales (i’ve installed UTF-8 and all en_GB ISOs), installing more fonts, but had no luck.

Can you please help me? This is not a big problem, but it’s pretty annoying, expecially when setting up servers, having to access console constantly. Thank you!


#2

The colorization of the text in the webui is handled by a certain function in scriptin.js. It progressively parses logs/latest.log for the colorizing codes, but the server jar you’re using is producing some extra codes this javascript perhaps isn’t ready to handle.

If you’re able to provide to me the logs/latest.log (actual file, not copy paste), I can work with it to figure out this issue. There shouldn’t be any information in the Minecraft log file that is personally identifying, but if you feel more comfy, feel free to send it to me either a) direct message or b) to my email.


#3

Of course, no problem.
I’ve searched around the web in the meanwhile and I figured out that this small square is actually the ESCAPE (U+001B) unicode character.
I tried Minecraft version from 1.8 to 1.11.2 but the square is always here, both if I start server from shell or from MineOS interface. (btw, shell is not showing the square live, only on log file)
May this be a Java problem? I’m using OpenJDK 1.8.0_131 64-bit.

There you are:
Hastebin:
https://hastebin.com/oxuboyipop.md
Mega:
https://mega.nz/#!gRJ0kYyQ!ZCX2qDtzZvUol0W8CrMpI5WAxGBhaK4zEGVdIvUuaBA

Thank you so much!


#4

Hey, sorry if I’m being stressing, but have you figured out anything to do with this? Thanks!


#5

fixed in commit: 657fd9eed32620ae4e8a061013362798b7714cdb