WorldEdit and other Plugins

What is the best way to install WorldEdit?
I would think I can use the command line on the server or the webmin > Tools > Upload and Download.
Want to make sure I follow best practice for installing mods with MineOS server.
Once WorldEdit is downloaded and extracted to the appropriate dir for the world is there anything I need to do in the MineOS Web UI to enable it?
[using Mine OS Turnkey]

The pre-req for WorldEdit is Craftbukkit which appears to be not in Turnkey MineOS.
Unfortunately the Craftbukkit download got removed from their website since Microslop purchase the site.
I am currently searching for a mirror server to download craftbukkit.

Though my familiarity with any given plugins is rather limited, most plugins are simply installed through the inclusion of the plugin jar in the /plugins directory of the server.

The best method is to learn to use SSH/SFTP and to place the file in manually (rather than depend on webmin). Webmin is fine for its purposes, but I believe it is often more effective (read: quick) and educational to learn to use these Linux-standard tools when possible.

That said, there’s nothing that you need to “enable” in the web-ui. Either the minecraft jar is started and it detects the Worldedit jar or it is started and it doesn’t detect it.


For legal issues, MineOS cannot and will not contain or distribute any jars, even the vanilla ones. This is licencing legality and for the most part is complied with by simply linking to it (which is what the stock profiles are). Craftbukkit, however, didn’t get removed since Microsoft bought Mojang, but happened before (it become common knowledge)–they are largely unrelated and there’s much flame war going on about it. The gist of it, however, is that yes, craftbukkit isn’t available through regular channels anymore.

Per your advice I used the CLI and got it working however one side effect is that the MineOS WebUI is no longer applicable to the newly created plugin enabled world.

Is there any way to use the MineOS WebUI with a craftbukkit world? I really appreciate the simplicity of the WebUI and I can see much good work has been done.

Possible Solutions

  1. Add to the gui an editible field showing the start command line for each world. The user could edit it with whatever plugin or command as needed. This would also be a cool way to provide support for any plugin parameters. This should be parsed by the gui to derive the folder location variable for archives and config files.
  2. Find the location of the start command used for a gui world and edit it to be the start command for the bukkit install - a somewhat hidden hack/workaround. Use links to point to archives etc.
    [if these are totally lame ideas then feel free to be blunt]

Tech Notes

  1. Craftbukkit must be installed - this will create a “plugins” folder in the same Craftbukkit folder.
  2. CLI commands used: wget, vi, mv, mkdir, cp, chmod, java, ls, find, cd.
  3. MineOS WebUI could still be used for plain vanilla worlds on a different IP/port.

What were the steps you actually did to make it work?

What are the ownership/permissions of the files now that they are placed?

A great number of MineOS users have bukkit servers with any variety of plugins, including worldedit, without any loss of functionality in the web-ui. In creating your server, did you create a new profile? What were it’s settings?

It won’t be necessary to add to the GUI an editable field for teh start command, as plugins are loaded by their presence in the /plugins directory, not by whether they are listed in the start command.

Let me know what you did, and I’ll try to point out any accommodations that MineOS requires to make it work. For the most part, I see no reason why MineOS and the web-ui AS-IS couldn’t service your need as described.

If you have the download link follow these steps
log into the WebUI as root -> manage profiles -> create custom profile
type in the profile name e.g. latest-craftbukkit
Standalone, runnable JAR
download address
save download as e.g. craftbukkit.jar
jar file to run e.g. craftbukkit.jar
jar file arguments - i left this blank

click update for that profile -
now log out, then in as a user (not root), create a server using this profile
Once the server is created you can SFTP into the server and navigate to /var/games/minecraft/servers/myServer/plugins

copy in any plugins to this plugins directory and start craftbukkit.
This is the process of how I ran craftbukkit with many plugins, dynmap, worldedit, worldguard towny etc

1 Like

That worked ElPres, thanks. Did you use the gui to start craftbukkit the first time and accept the Eula?
I did exactly your steps which worked great…mostly.
However I had to do a few steps at the console - because I did not see Eula in the gui - maybe my mistake.
I used the console to start the craftbukkit, because it would not start on the gui.
I then found the eula.txt and accepted that in vi.
Unfortunately using console root for starting the craftbukkit had the side effect of assigning all the files to root user and group.
The gui uses “mc” user so it did not have permission to start craftbukkit.
So I used chown to change from root to mc.

1 Like

Glad you got it sorted. I keep forgetting about eula as I only use one stock server at the moment and it popped up in the gui though I might have had to launch it once or twice to get it to show.